summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2010-06-21 08:16:25 +0000
committerTorsten Veller <tove@gentoo.org>2010-06-21 08:16:25 +0000
commit26c991c1021d76824f6af763d2ac0bcae8a6267a (patch)
tree684a6f3f659ca0eb302298411d37e3a45c24d7e9 /x11-misc
parentUnmask net-im/ejabberd. (diff)
downloadgentoo-2-26c991c1021d76824f6af763d2ac0bcae8a6267a.tar.gz
gentoo-2-26c991c1021d76824f6af763d2ac0bcae8a6267a.tar.bz2
gentoo-2-26c991c1021d76824f6af763d2ac0bcae8a6267a.zip
Version bump
(Portage version: 2.2_rc67_p176/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/remind/ChangeLog7
-rw-r--r--x11-misc/remind/remind-03.01.09.ebuild46
2 files changed, 52 insertions, 1 deletions
diff --git a/x11-misc/remind/ChangeLog b/x11-misc/remind/ChangeLog
index 8b88cf2ab13d..466e95b31b12 100644
--- a/x11-misc/remind/ChangeLog
+++ b/x11-misc/remind/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/remind
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/remind/ChangeLog,v 1.49 2010/03/10 12:51:04 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/remind/ChangeLog,v 1.50 2010/06/21 08:16:25 tove Exp $
+
+*remind-03.01.09 (21 Jun 2010)
+
+ 21 Jun 2010; Torsten Veller <tove@gentoo.org> +remind-03.01.09.ebuild:
+ Version bump
10 Mar 2010; Torsten Veller <tove@gentoo.org> remind-03.01.08.ebuild:
Test fails if not the right timezone is set
diff --git a/x11-misc/remind/remind-03.01.09.ebuild b/x11-misc/remind/remind-03.01.09.ebuild
new file mode 100644
index 000000000000..72eb2c8f4ef0
--- /dev/null
+++ b/x11-misc/remind/remind-03.01.09.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/remind/remind-03.01.09.ebuild,v 1.1 2010/06/21 08:16:25 tove Exp $
+
+MY_P=${P/_beta/-BETA-}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="Ridiculously functional reminder program"
+HOMEPAGE="http://www.roaringpenguin.com/products/remind"
+SRC_URI="http://www.roaringpenguin.com/files/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86 ~x86-fbsd"
+IUSE="tk"
+
+RDEPEND="tk? ( dev-lang/tk dev-tcltk/tcllib )"
+
+src_unpack() {
+ unpack ${A}
+ sed -i 's:$(MAKE) install:&-nostripped:' "${S}"/Makefile || die
+}
+
+src_test() {
+ if [[ $EUID -eq 0 ]] ; then
+ ewarn "Testing fails if run as root. Skipping tests."
+ return
+ fi
+ make test || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dobin www/rem2html || die "dobin failed"
+
+ dodoc docs/WHATSNEW examples/defs.rem www/README.* || die "dodoc failed"
+
+ if ! use tk ; then
+ rm "${D}"/usr/bin/tkremind "${D}"/usr/share/man/man1/tkremind* \
+ "${D}"/usr/bin/cm2rem* "${D}"/usr/share/man/man1/cm2rem*
+ fi
+
+ rm "${S}"/contrib/rem2ics-*/{Makefile,rem2ics.spec} || die
+ insinto /usr/share/${PN}
+ doins -r contrib/
+}