summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2014-02-19 12:02:03 +0000
committerJeroen Roovers <jer@gentoo.org>2014-02-19 12:02:03 +0000
commit28c553e276991d65a1128cbd2abe33ec89bff06e (patch)
treef8abf59e344563c9f7059cd452850678c833ee59 /x11-misc
parentMask old revision of jikes. (diff)
downloadgentoo-2-28c553e276991d65a1128cbd2abe33ec89bff06e.tar.gz
gentoo-2-28c553e276991d65a1128cbd2abe33ec89bff06e.tar.bz2
gentoo-2-28c553e276991d65a1128cbd2abe33ec89bff06e.zip
Version bump (bug #501748 by Alex Barker).
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/synergy/ChangeLog9
-rw-r--r--x11-misc/synergy/synergy-1.4.16_p1969.ebuild95
2 files changed, 102 insertions, 2 deletions
diff --git a/x11-misc/synergy/ChangeLog b/x11-misc/synergy/ChangeLog
index e07c8b17bb8b..b8d99040ab82 100644
--- a/x11-misc/synergy/ChangeLog
+++ b/x11-misc/synergy/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/synergy
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy/ChangeLog,v 1.105 2013/11/02 16:24:15 jer Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy/ChangeLog,v 1.106 2014/02/19 12:02:03 jer Exp $
+
+*synergy-1.4.16_p1969 (19 Feb 2014)
+
+ 19 Feb 2014; Jeroen Roovers <jer@gentoo.org> +synergy-1.4.16_p1969.ebuild:
+ Version bump (bug #501748 by Alex Barker).
02 Nov 2013; Jeroen Roovers <jer@gentoo.org>
-files/synergy-1.4.12-cryptopp.patch, -synergy-1.4.10.ebuild,
diff --git a/x11-misc/synergy/synergy-1.4.16_p1969.ebuild b/x11-misc/synergy/synergy-1.4.16_p1969.ebuild
new file mode 100644
index 000000000000..9e4c387c4a2f
--- /dev/null
+++ b/x11-misc/synergy/synergy-1.4.16_p1969.ebuild
@@ -0,0 +1,95 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/synergy/synergy-1.4.16_p1969.ebuild,v 1.1 2014/02/19 12:02:03 jer Exp $
+
+EAPI=5
+inherit eutils flag-o-matic gnome2-utils cmake-utils qt4-r2
+
+DESCRIPTION="Lets you easily share a single mouse and keyboard between multiple computers."
+HOMEPAGE="http://synergy-foss.org/"
+SRC_URI="
+ http://fossfiles.com/${PN}/${P/_p/-r}-Source.tar.gz
+ http://dev.gentoo.org/~hasufell/distfiles/${PN}.png
+"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="qt4"
+
+COMMON_DEPEND="
+ dev-libs/crypto++
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libXrandr
+ x11-libs/libXtst
+ qt4? ( dev-qt/qtcore:4 dev-qt/qtgui:4 )
+"
+DEPEND="${COMMON_DEPEND}
+ x11-proto/kbproto
+ x11-proto/randrproto
+ x11-proto/xextproto
+ x11-proto/xineramaproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ qt4? ( !x11-misc/qsynergy )
+"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.15-cryptopp.patch"
+)
+
+S=${WORKDIR}/${P/_p*/}-Source
+
+src_configure() {
+ cmake-utils_src_configure
+
+ if use qt4 ; then
+ cd src/gui || die
+ qt4-r2_src_configure
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+
+ if use qt4 ; then
+ cd src/gui || die
+ qt4-r2_src_compile
+ fi
+}
+
+src_install () {
+ dobin bin/${PN}{c,s}
+
+ if use qt4 ; then
+ newbin bin/${PN} qsynergy
+ newicon -s 256 "${DISTDIR}"/${PN}.png q${PN}.png
+ make_desktop_entry q${PN} ${PN/s/S} q${PN} Utility;
+ fi
+
+ insinto /etc
+ newins doc/synergy.conf.example synergy.conf
+
+ newman doc/${PN}c.man ${PN}c.1
+ newman doc/${PN}s.man ${PN}s.1
+
+ dodoc README doc/synergy.conf.example* ChangeLog
+}
+
+pkg_preinst() {
+ use qt4 && gnome2_icon_savelist
+}
+
+pkg_postinst() {
+ use qt4 && gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ use qt4 && gnome2_icon_cache_update
+}