summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2012-05-21 19:02:38 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2012-05-21 19:02:38 +0000
commit7cc389c388c71f6a707fc02dcbc2cc41d674ab3a (patch)
treef61a06673c7082d8429d85d326740c25dea1507f /x11-misc
parentNeed eutils for epatch. (diff)
downloadgentoo-2-7cc389c388c71f6a707fc02dcbc2cc41d674ab3a.tar.gz
gentoo-2-7cc389c388c71f6a707fc02dcbc2cc41d674ab3a.tar.bz2
gentoo-2-7cc389c388c71f6a707fc02dcbc2cc41d674ab3a.zip
Add missing dependency and execute bit for upload plugins. Bug #414889. Thanks to antu456@googlemail.com
(Portage version: 2.1.10.62/cvs/Linux x86_64)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/shutter/ChangeLog6
-rw-r--r--x11-misc/shutter/shutter-0.88.3.ebuild7
2 files changed, 10 insertions, 3 deletions
diff --git a/x11-misc/shutter/ChangeLog b/x11-misc/shutter/ChangeLog
index cca18dcb99eb..a19b1363d5c3 100644
--- a/x11-misc/shutter/ChangeLog
+++ b/x11-misc/shutter/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-misc/shutter
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/ChangeLog,v 1.31 2012/05/04 23:47:09 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/ChangeLog,v 1.32 2012/05/21 19:02:38 hwoarang Exp $
+
+ 21 May 2012; Markos Chandras <hwoarang@gentoo.org> shutter-0.88.3.ebuild:
+ Add missing dependency and execute bit for upload plugins. Bug #414889. Thanks
+ to antu456@googlemail.com
*shutter-0.88.3 (04 May 2012)
diff --git a/x11-misc/shutter/shutter-0.88.3.ebuild b/x11-misc/shutter/shutter-0.88.3.ebuild
index e6b74dfe5d97..eadb182ad18b 100644
--- a/x11-misc/shutter/shutter-0.88.3.ebuild
+++ b/x11-misc/shutter/shutter-0.88.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/shutter-0.88.3.ebuild,v 1.1 2012/05/04 23:47:09 hwoarang Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/shutter/shutter-0.88.3.ebuild,v 1.2 2012/05/21 19:02:38 hwoarang Exp $
EAPI="2"
@@ -19,7 +19,7 @@ RDEPEND="dev-lang/perl
dev-perl/gnome2-gconf
drawing? ( dev-perl/Goo-Canvas )
webphoto? ( gnome-extra/gnome-web-photo )
- || ( media-gfx/imagemagick media-gfx/graphicsmagick[imagemagick] )
+ || ( media-gfx/imagemagick[perl] media-gfx/graphicsmagick[imagemagick,perl] )
dev-perl/libxml-perl
dev-perl/gnome2-wnck
dev-perl/gnome2-canvas
@@ -29,6 +29,7 @@ RDEPEND="dev-lang/perl
dev-perl/File-DesktopEntry
dev-perl/File-HomeDir
dev-perl/File-Which
+ dev-perl/JSON
dev-perl/File-Copy-Recursive
dev-perl/File-MimeInfo
dev-perl/Locale-gettext
@@ -66,4 +67,6 @@ src_install() {
doins -r share/icons/hicolor/* || die "doins failed"
find "${D}"/usr/share/shutter/resources/system/plugins/ -type f ! -name '*.*' -exec chmod 755 {} \; \
|| die "failed to make plugins executables"
+ find "${D}"/usr/share/shutter/resources/system/upload_plugins/upload -type f \
+ -name "*.pm" -exec chmod 755 {} \; || die "failed to make upload plugins executables"
}