summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Kursawe <phosphan@gentoo.org>2005-12-12 12:53:46 +0000
committerPatrick Kursawe <phosphan@gentoo.org>2005-12-12 12:53:46 +0000
commita8bbda61458edce7d3e9f3220ec17c5b27d7be4a (patch)
tree7e89a64a387927e101e6c2f598262643ba790160 /x11-misc
parentVersion bump. (diff)
downloadgentoo-2-a8bbda61458edce7d3e9f3220ec17c5b27d7be4a.tar.gz
gentoo-2-a8bbda61458edce7d3e9f3220ec17c5b27d7be4a.tar.bz2
gentoo-2-a8bbda61458edce7d3e9f3220ec17c5b27d7be4a.zip
Version bump (bug #114344)
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/xaos/ChangeLog7
-rw-r--r--x11-misc/xaos/Manifest8
-rw-r--r--x11-misc/xaos/files/digest-xaos-3.1.31
-rw-r--r--x11-misc/xaos/xaos-3.1.3.ebuild61
4 files changed, 73 insertions, 4 deletions
diff --git a/x11-misc/xaos/ChangeLog b/x11-misc/xaos/ChangeLog
index 076b24005715..d12bd61105c7 100644
--- a/x11-misc/xaos/ChangeLog
+++ b/x11-misc/xaos/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/xaos
# Copyright 2002-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/ChangeLog,v 1.16 2005/06/28 02:08:59 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/ChangeLog,v 1.17 2005/12/12 12:53:45 phosphan Exp $
+
+*xaos-3.1.3 (12 Dec 2005)
+
+ 12 Dec 2005; Patrick Kursawe <phosphan@gentoo.org> +xaos-3.1.3.ebuild:
+ Version bump (bug #114344)
28 Jun 2005; Jason Wever <weeve@gentoo.org> xaos-3.1.1.ebuild:
Stable on SPARC.
diff --git a/x11-misc/xaos/Manifest b/x11-misc/xaos/Manifest
index 26a05e8c12a2..91e46f86cae3 100644
--- a/x11-misc/xaos/Manifest
+++ b/x11-misc/xaos/Manifest
@@ -1,7 +1,9 @@
-MD5 c065eabc2f3221705288738c010a4a19 ChangeLog 1834
-MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
MD5 dc3ea29a3319b960518790c572768926 xaos-3.1.ebuild 1761
MD5 cdf8eb68c4ce6cc44992f1fa74e854d4 xaos-3.1.1.ebuild 1688
+MD5 99846aca87ae93df6178839ff4f5b5d7 ChangeLog 1964
+MD5 58ee5e5d91f650cb39a5061ded45203c xaos-3.1.3.ebuild 1692
+MD5 8c623e53daafa025137077c6b65815bd metadata.xml 156
+MD5 a5aa09876dbb6a8b3800c2ddeb749264 files/digest-xaos-3.1.1 63
+MD5 ffe0ee7c85eaba15fb216fc1f400fc03 files/digest-xaos-3.1.3 63
MD5 f15bb8d89c74bd6168e7e67b16b789d4 files/digest-xaos-3.1 61
MD5 7589bd8d57e0ddebeb3463df943ed3a2 files/gcc3.4.patch 7778
-MD5 a5aa09876dbb6a8b3800c2ddeb749264 files/digest-xaos-3.1.1 63
diff --git a/x11-misc/xaos/files/digest-xaos-3.1.3 b/x11-misc/xaos/files/digest-xaos-3.1.3
new file mode 100644
index 000000000000..cf2454614600
--- /dev/null
+++ b/x11-misc/xaos/files/digest-xaos-3.1.3
@@ -0,0 +1 @@
+MD5 ba6b3fa020bf68f37af41741db1dc0a0 XaoS-3.1.3.tar.gz 1454434
diff --git a/x11-misc/xaos/xaos-3.1.3.ebuild b/x11-misc/xaos/xaos-3.1.3.ebuild
new file mode 100644
index 000000000000..ed7f536856dc
--- /dev/null
+++ b/x11-misc/xaos/xaos-3.1.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/xaos/xaos-3.1.3.ebuild,v 1.1 2005/12/12 12:53:46 phosphan Exp $
+
+inherit eutils
+
+IUSE="X svga aalib nls"
+
+MY_PN=XaoS
+MY_P=${MY_PN}-${PV}
+
+S=${WORKDIR}/${MY_P}
+DESCRIPTION="A very fast real-time fractal zoomer"
+HOMEPAGE="http://sourceforge.net/projects/xaos/"
+SRC_URI="mirror://sourceforge/xaos/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~amd64 -sparc"
+
+DEPEND="X? ( virtual/x11 )
+ svga? ( >=media-libs/svgalib-1.4.3 )
+ aalib? ( media-libs/aalib )
+ sys-libs/zlib
+ media-libs/libpng"
+# xaos has ggi support, but it doesn't build
+# ggi? ( media-libs/libggi )
+
+
+src_compile() {
+ local myconf
+ use X || myconf="--with-x11-driver=no"
+# use dga || myconf="${myconf} --with-dga-driver=no"
+# ggi support removed due to upstream bug
+ #use ggi ||
+ myconf="${myconf} --with-ggi-driver=no"
+ use svga || myconf="${myconf} --with-svga-driver=no"
+# use aalib || myconf="${myconf} --with-aa-driver=no"
+
+ #i18n support is quite broken in XaoS, it gets installed
+ #anyway, so we remove it later during install if not desired
+ use nls || myconf="${myconf} --with-i18n=no"
+
+ ./configure --prefix=/usr ${myconf} && make || die
+}
+
+src_install() {
+ # these get installed, assuming that the directories exist!
+ mkdir -p ${D}/usr/share/locale/{hu,es,fr,cs,de}/LC_MESSAGES
+ mkdir -p ${D}/usr/share/{man,info}
+ make \
+ prefix=${D}/usr \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ LOCALEDIR=${D}/usr/share/locale \
+ install || die
+
+ use nls || rm -r ${D}/usr/share/locale
+
+ dodoc ChangeLog* COPYING INSTALL* TODO*
+}