summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJulian Ospald <hasufell@gentoo.org>2013-08-29 16:53:50 +0000
committerJulian Ospald <hasufell@gentoo.org>2013-08-29 16:53:50 +0000
commitc29c2ffd1765f0873fefa52a50ce4833910ac66a (patch)
tree1477742738be67fa6d32a599f80b0a8e78b0b016 /x11-misc
parentversion bump (diff)
downloadgentoo-2-c29c2ffd1765f0873fefa52a50ce4833910ac66a.tar.gz
gentoo-2-c29c2ffd1765f0873fefa52a50ce4833910ac66a.tar.bz2
gentoo-2-c29c2ffd1765f0873fefa52a50ce4833910ac66a.zip
version bump
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key E73C35B3)
Diffstat (limited to 'x11-misc')
-rw-r--r--x11-misc/devilspie2/ChangeLog7
-rw-r--r--x11-misc/devilspie2/devilspie2-0.31.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-misc/devilspie2/ChangeLog b/x11-misc/devilspie2/ChangeLog
index d3c42b7dea67..fb504a553e5e 100644
--- a/x11-misc/devilspie2/ChangeLog
+++ b/x11-misc/devilspie2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-misc/devilspie2
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.7 2013/07/21 12:07:23 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/ChangeLog,v 1.8 2013/08/29 16:53:50 hasufell Exp $
+
+*devilspie2-0.31 (29 Aug 2013)
+
+ 29 Aug 2013; Julian Ospald <hasufell@gentoo.org> +devilspie2-0.31.ebuild:
+ version bump
*devilspie2-0.30 (21 Jul 2013)
diff --git a/x11-misc/devilspie2/devilspie2-0.31.ebuild b/x11-misc/devilspie2/devilspie2-0.31.ebuild
new file mode 100644
index 000000000000..1ff5fb3d09e3
--- /dev/null
+++ b/x11-misc/devilspie2/devilspie2-0.31.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-misc/devilspie2/devilspie2-0.31.ebuild,v 1.1 2013/08/29 16:53:50 hasufell Exp $
+
+EAPI=5
+
+# check locales on version bump!
+PLOCALES="fi fr ja nl pt_BR ru sv"
+inherit flag-o-matic toolchain-funcs l10n
+
+DESCRIPTION="Devilspie like window matching utility, using LUA for scripting"
+HOMEPAGE="http://devilspie2.gusnan.se"
+SRC_URI="http://devilspie2.gusnan.se/download/${PN}_${PV}-src.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.32.4:2
+ >=dev-lang/lua-5.1.5
+ >=x11-libs/gtk+-3.4.4:3
+ >=x11-libs/libwnck-3.4.4:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ x11-proto/xproto"
+
+src_prepare() {
+ use debug && append-cflags -D_DEBUG
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) PREFIX="/usr" LANGUAGES="$(l10n_get_locales)"
+}
+
+src_install() {
+ emake PREFIX="/usr" DESTDIR="${D}" LANGUAGES="$(l10n_get_locales)" install
+
+ dodoc AUTHORS ChangeLog README README.translators TODO VERSION
+ doman devilspie2.1
+}
+
+pkg_postinst() {
+ elog "Default folder for scripts is ~/.config/devilspie2/"
+}