summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gardiner <obz@gentoo.org>2003-11-12 11:18:33 +0000
committerMike Gardiner <obz@gentoo.org>2003-11-12 11:18:33 +0000
commit04e026d47ec4b860fd19883bd78409e24b7e2590 (patch)
treebb60f949b24b6b074ca0a04cac2ef6a9350bc7d6 /x11-plugins/desklet-sysinfo/desklet-sysinfo-0.21.2-r1.ebuild
parentFixed up Sensor permissions (diff)
downloadgentoo-2-04e026d47ec4b860fd19883bd78409e24b7e2590.tar.gz
gentoo-2-04e026d47ec4b860fd19883bd78409e24b7e2590.tar.bz2
gentoo-2-04e026d47ec4b860fd19883bd78409e24b7e2590.zip
Fixed up Sensor permissions
Diffstat (limited to 'x11-plugins/desklet-sysinfo/desklet-sysinfo-0.21.2-r1.ebuild')
-rw-r--r--x11-plugins/desklet-sysinfo/desklet-sysinfo-0.21.2-r1.ebuild56
1 files changed, 56 insertions, 0 deletions
diff --git a/x11-plugins/desklet-sysinfo/desklet-sysinfo-0.21.2-r1.ebuild b/x11-plugins/desklet-sysinfo/desklet-sysinfo-0.21.2-r1.ebuild
new file mode 100644
index 000000000000..470bce8c5c15
--- /dev/null
+++ b/x11-plugins/desklet-sysinfo/desklet-sysinfo-0.21.2-r1.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/desklet-sysinfo/desklet-sysinfo-0.21.2-r1.ebuild,v 1.1 2003/11/12 11:18:21 obz Exp $
+
+DESKLET_NAME="SysInfo"
+
+MY_P=${DESKLET_NAME}-${PV}
+S=${WORKDIR}/${DESKLET_NAME}
+
+DESCRIPTION="A system information providing Display/Sensor for gDesklets"
+SRC_URI="http://gdesklets.gnomedesktop.org/files/${MY_P}.tar.bz2"
+HOMEPAGE="http://gdesklets.gnomedesktop.org"
+LICENSE="as-is"
+
+SLOT="0"
+IUSE=""
+KEYWORDS="~x86"
+
+DEPEND=">=gnome-extra/gdesklets-core-0.22"
+
+DOCS="AUTHORS ChangeLog"
+
+src_unpack( ) {
+
+ # *grumble* if you compress an archive using gunzip,
+ # why would you suffix it .tar.bz2 ? <obz@gentoo.org>
+ cd ${WORKDIR}
+ tar zxfv ${DISTDIR}/${MY_P}.tar.bz2
+
+}
+
+src_install() {
+
+ SYS_PATH="/usr/share/gdesklets"
+ INSTALL_BIN="Install_${DESKLET_NAME}_Sensor.bin"
+ dodir ${SYS_PATH}/{Sensors,Displays}
+
+ cd ${WORKDIR}
+ # first we install the Sensor
+ python ${INSTALL_BIN} --nomsg ${D}${SYS_PATH}/Sensors
+
+ cd ${S}
+ # and then the .displays
+ insinto ${SYS_PATH}/Displays/${DESKLET_NAME}
+ doins *.display
+
+ # and finally the graphics
+ cp -R gfx/ ${D}${SYS_PATH}/Displays/${DESKLET_NAME}
+
+ dodoc ${DOCS}
+
+ # desklets unpack preserves the permissions of the archive
+ chown -R root:root ${D}${SYS_PATH}/Sensors/${DESKLET_NAME}
+
+}
+