summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJory Pratt <anarchy@gentoo.org>2006-06-02 23:49:30 +0000
committerJory Pratt <anarchy@gentoo.org>2006-06-02 23:49:30 +0000
commit236bcad3979db41ed71265db7f06b791fd330f56 (patch)
tree9ae40f446148f2ff4daeb14f8e112e9c7bffd48d /x11-plugins/enigmail
parentrevision/security bump, modifications to ia64 and filepicker patches, sparc p... (diff)
downloadgentoo-2-236bcad3979db41ed71265db7f06b791fd330f56.tar.gz
gentoo-2-236bcad3979db41ed71265db7f06b791fd330f56.tar.bz2
gentoo-2-236bcad3979db41ed71265db7f06b791fd330f56.zip
revision bump for latest mozilla-thunderbird release
(Portage version: 2.1_rc3-r4)
Diffstat (limited to 'x11-plugins/enigmail')
-rw-r--r--x11-plugins/enigmail/ChangeLog8
-rw-r--r--x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild136
-rw-r--r--x11-plugins/enigmail/files/digest-enigmail-0.94.0-r49
3 files changed, 152 insertions, 1 deletions
diff --git a/x11-plugins/enigmail/ChangeLog b/x11-plugins/enigmail/ChangeLog
index e1400cb0df0a..68341c7c3105 100644
--- a/x11-plugins/enigmail/ChangeLog
+++ b/x11-plugins/enigmail/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/enigmail
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.19 2006/05/23 18:00:31 gustavoz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/ChangeLog,v 1.20 2006/06/02 23:49:30 anarchy Exp $
+
+*enigmail-0.94.0-r4 (02 Jun 2006)
+
+ 02 Jun 2006; Jory A. Pratt <anarchy@gentoo.org>
+ +enigmail-0.94.0-r4.ebuild:
+ revision bump for latest thunderbird
23 May 2006; Gustavo Zacarias <gustavoz@gentoo.org>
enigmail-0.94.0-r3.ebuild:
diff --git a/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild b/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild
new file mode 100644
index 000000000000..c1ad78d231fb
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild
@@ -0,0 +1,136 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/enigmail/enigmail-0.94.0-r4.ebuild,v 1.1 2006/06/02 23:49:30 anarchy Exp $
+
+unset ALLOWED_FLAGS # stupid extra-functions.sh ... bug 49179
+inherit flag-o-matic toolchain-funcs eutils nsplugins mozcoreconf makeedit multilib autotools
+
+EMVER=${PV}
+TBVER="1.5.0.4"
+TBPVER="0.1"
+
+DESCRIPTION="Gnupg encryption plugin for thunderbird."
+HOMEPAGE="http://www.enigmail.mozdev.org"
+SRC_URI="http://ftp.mozilla.org/pub/mozilla.org/thunderbird/releases/${TBVER}/source/thunderbird-${TBVER}-source.tar.bz2
+ mirror://gentoo/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
+ http://dev.gentoo.org/~anarchy/dist/mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2
+ http://www.mozilla-enigmail.org/downloads/src/enigmail-${EMVER}.tar.gz"
+
+KEYWORDS="amd64 ~ia64 ppc ~sparc ~x86"
+SLOT="0"
+LICENSE="MPL-1.1 NPL-1.1"
+IUSE=""
+
+DEPEND=">=mail-client/mozilla-thunderbird-1.5"
+RDEPEND="${DEPEND}
+ >=app-crypt/gnupg-1.4
+ >=www-client/mozilla-launcher-1.37"
+
+S=${WORKDIR}/mozilla
+
+# Needed by src_compile() and src_install().
+# Would do in pkg_setup but that loses the export attribute, they
+# become pure shell variables.
+export BUILD_OFFICIAL=1
+export MOZILLA_OFFICIAL=1
+export MOZ_CO_PROJECT=mail
+
+src_unpack() {
+ unpack thunderbird-${TBVER}-source.tar.bz2 mozilla-thunderbird-${TBVER}-patches-${TBPVER}.tar.bz2 || die "unpack failed"
+ cd ${S} || die "cd failed"
+
+ # Apply our patches
+ EPATCH_FORCE="yes" epatch ${WORKDIR}/patch
+
+ # Unpack the enigmail plugin
+ cd ${S}/mailnews/extensions || die
+ unpack enigmail-${EMVER}.tar.gz
+ cd ${S}/mailnews/extensions/enigmail || die "cd failed"
+ makemake2
+
+ cd ${S}
+
+ # Use the right theme for thunderbird #45609
+ sed -i -ne '/^enigmail-skin.jar:$/ { :x; n; /^\t/bx; }; p' mailnews/extensions/enigmail/ui/jar.mn
+
+ # Don't allow upgrades via the browser
+ epatch ${FILESDIR}/50_enigmail_no_upgrade-1.patch
+
+ # Fix installation of enigmail.js
+ epatch ${FILESDIR}/70_enigmail-fix.patch
+
+ eautoreconf || die "failed running autoreconf"
+}
+
+src_compile() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+
+ ####################################
+ #
+ # mozconfig, CFLAGS and CXXFLAGS setup
+ #
+ ####################################
+
+ mozconfig_init
+
+ # tb-specific settings
+ mozconfig_annotate '' \
+ --with-system-nspr \
+ --with-system-nss \
+ --with-default-mozilla-five-home=${MOZILLA_FIVE_HOME} \
+ --with-user-appdir=.thunderbird
+
+ # Finalize and report settings
+ mozconfig_final
+
+ # hardened GCC uses -fstack-protector-all by default, and this breaks
+ # thunderbird
+ gcc-specs-ssp && append-flags -fno-stack-protector-all
+ replace-flags -fstack-protector-all -fstack-protector
+
+ ####################################
+ #
+ # Configure and build Thunderbird
+ #
+ ####################################
+
+ econf || die "econf failed"
+
+ # This removes extraneous CFLAGS from the Makefiles to reduce RAM
+ # requirements while compiling
+ edit_makefiles
+
+ # Only build the parts necessary to support building enigmail
+ emake -j1 export || die "make export failed"
+ emake -C modules/libreg || die "make modules/libreg failed"
+ emake -C xpcom/string || die "make xpcom/string failed"
+ emake -C xpcom || die "make xpcom failed"
+ emake -C xpcom/obsolete || die "make xpcom/obsolete failed"
+
+ # Build the enigmail plugin
+ einfo "Building Enigmail plugin..."
+ emake -C ${S}/mailnews/extensions/enigmail || die "make enigmail failed"
+
+ # Package the enigmail plugin; this may be the easiest way to collect the
+ # necessary files
+ emake -j1 -C ${S}/mailnews/extensions/enigmail xpi || die "make xpi failed"
+}
+
+src_install() {
+ declare MOZILLA_FIVE_HOME=/usr/$(get_libdir)/mozilla-thunderbird
+ declare emid
+
+ cd ${T}
+ unzip ${S}/dist/bin/*.xpi install.rdf
+ emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' install.rdf)
+
+ dodir ${MOZILLA_FIVE_HOME}/extensions/${emid}
+ cd ${D}${MOZILLA_FIVE_HOME}/extensions/${emid}
+ unzip ${S}/dist/bin/*.xpi
+
+ # these files will be picked up by mozilla-launcher -register
+ dodir ${MOZILLA_FIVE_HOME}/{chrome,extensions}.d
+ insinto ${MOZILLA_FIVE_HOME}/chrome.d
+ newins ${S}/dist/bin/chrome/installed-chrome.txt ${PN}
+ echo "extension,${emid}" > ${D}${MOZILLA_FIVE_HOME}/extensions.d/${PN}
+}
diff --git a/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r4 b/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r4
new file mode 100644
index 000000000000..989f5ebad96c
--- /dev/null
+++ b/x11-plugins/enigmail/files/digest-enigmail-0.94.0-r4
@@ -0,0 +1,9 @@
+MD5 d326c302c1d2d68217fffcaa01ca7632 enigmail-0.94.0.tar.gz 508113
+RMD160 0fa8f0384b74623c1b84a048bdbf04bfca8c1824 enigmail-0.94.0.tar.gz 508113
+SHA256 db2b5fc014fe5efef95fc46804ac609616557b1696d5f355d2d7641e567904f3 enigmail-0.94.0.tar.gz 508113
+MD5 de966648efd10ee705453bad81f557fc mozilla-thunderbird-1.5.0.4-patches-0.1.tar.bz2 33086
+RMD160 9b97f3844cdc82f0488a5ee7e1ed6d28cfd0eeca mozilla-thunderbird-1.5.0.4-patches-0.1.tar.bz2 33086
+SHA256 3120bfd43d5960a5be9f2be9e59d082d8397620a7c11a335a7a2faaecf068a2c mozilla-thunderbird-1.5.0.4-patches-0.1.tar.bz2 33086
+MD5 ada9c163f5b26fe81958e7a85340811e thunderbird-1.5.0.4-source.tar.bz2 35872600
+RMD160 27e88578d8857e48b46ee4dff2900f27b8a0f447 thunderbird-1.5.0.4-source.tar.bz2 35872600
+SHA256 b665c89bfc18a84c57d85370889973cfc547e1e942aba5798321ea34e4ddbca7 thunderbird-1.5.0.4-source.tar.bz2 35872600