summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDon Seiler <rizzo@gentoo.org>2005-06-13 14:08:07 +0000
committerDon Seiler <rizzo@gentoo.org>2005-06-13 14:08:07 +0000
commitb2d68b750a721d535db23b22b270227cfdab1a51 (patch)
treeb97e237f77a706dc715db1909597b5e179787746 /x11-plugins/gaim-encryption/gaim-encryption-2.38.ebuild
parents/eclectic/eselect/ (diff)
downloadgentoo-2-b2d68b750a721d535db23b22b270227cfdab1a51.tar.gz
gentoo-2-b2d68b750a721d535db23b22b270227cfdab1a51.tar.bz2
gentoo-2-b2d68b750a721d535db23b22b270227cfdab1a51.zip
Version bump, putting into x86 stable
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'x11-plugins/gaim-encryption/gaim-encryption-2.38.ebuild')
-rw-r--r--x11-plugins/gaim-encryption/gaim-encryption-2.38.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/x11-plugins/gaim-encryption/gaim-encryption-2.38.ebuild b/x11-plugins/gaim-encryption/gaim-encryption-2.38.ebuild
new file mode 100644
index 000000000000..8dfafe3eaad3
--- /dev/null
+++ b/x11-plugins/gaim-encryption/gaim-encryption-2.38.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gaim-encryption/gaim-encryption-2.38.ebuild,v 1.1 2005/06/13 14:08:07 rizzo Exp $
+
+inherit flag-o-matic eutils debug
+
+DESCRIPTION="GAIM Encryption PlugIn"
+HOMEPAGE="http://gaim-encryption.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ia64 ~mips ~ppc ~ppc64 ~sparc x86"
+IUSE=""
+
+DEPEND=">=net-im/gaim-1.0.1
+ >=dev-libs/nss-3.9.2-r2"
+
+src_compile() {
+ strip-flags
+ replace-flags -O? -O2
+
+ local myconf
+ myconf="${myconf} --with-nspr-includes=/usr/include/nspr"
+ myconf="${myconf} --with-nss-includes=/usr/include/nss"
+ myconf="${myconf} --with-nspr-libs=/usr/lib/nspr"
+ myconf="${myconf} --with-nss-libs=/usr/lib/nss"
+
+ econf ${myconf} || die "Configuration failed"
+
+ emake || MAKEOPTS="${MAKEOPTS} -j1" emake || die "Make failed"
+}
+
+src_install() {
+ make install DESTDIR=${D} || die "Install failed"
+ dodoc CHANGELOG INSTALL NOTES README TODO VERSION WISHLIST
+}