summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJim Ramsay <lack@gentoo.org>2007-04-26 17:46:36 +0000
committerJim Ramsay <lack@gentoo.org>2007-04-26 17:46:36 +0000
commit7dd1710b16f3817ec49591e4887f1f0860dd9cea (patch)
tree70e4362de1a1941c084920959949243db62a3196 /x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
parentMasked app-admin/bastille until it works again (diff)
downloadgentoo-2-7dd1710b16f3817ec49591e4887f1f0860dd9cea.tar.gz
gentoo-2-7dd1710b16f3817ec49591e4887f1f0860dd9cea.tar.bz2
gentoo-2-7dd1710b16f3817ec49591e4887f1f0860dd9cea.zip
Updated to use gkrellm-plugin.eclass
(Portage version: 2.1.2.4)
Diffstat (limited to 'x11-plugins/gkrellmss/gkrellmss-2.6.ebuild')
-rw-r--r--x11-plugins/gkrellmss/gkrellmss-2.6.ebuild19
1 files changed, 9 insertions, 10 deletions
diff --git a/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild b/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
index 43ceed933aed..747a97099d5c 100644
--- a/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
+++ b/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild,v 1.4 2006/07/27 06:41:38 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/gkrellmss/gkrellmss-2.6.ebuild,v 1.5 2007/04/26 17:46:36 lack Exp $
-inherit eutils
+inherit gkrellm-plugin
IUSE="alsa esd nls"
@@ -10,15 +10,19 @@ DESCRIPTION="A plugin for GKrellM2 that has a VU meter and a sound chart"
HOMEPAGE="http://members.dslextreme.com/users/billw/gkrellmss/gkrellmss.html"
SRC_URI="http://web.wt.net/~billw/gkrellmss/${P}.tar.gz"
-DEPEND="=app-admin/gkrellm-2*
- =sci-libs/fftw-2*
+RDEPEND="=sci-libs/fftw-2*
esd? ( media-sound/esound )
alsa? ( media-libs/alsa-lib )"
+DEPEND="${RDEPEND}"
+
SLOT="0"
LICENSE="GPL-2"
KEYWORDS="~x86 ~ppc ~sparc ~alpha ~amd64"
+PLUGIN_SO="src/gkrellmss.so"
+PLUGIN_DOCS="Themes"
+
src_compile() {
local myconf
@@ -28,8 +32,3 @@ src_compile() {
emake ${myconf} || die
}
-src_install () {
- exeinto /usr/$(get_libdir)/gkrellm2/plugins
- doexe src/gkrellmss.so
- dodoc README Changelog Themes
-}