summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2010-02-12 07:38:09 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2010-02-12 07:38:09 +0000
commitfd208fcaf91ef7ab8275705cbc2c47f2c3ae4341 (patch)
treed581553f5b847eeb7bc88b2116c069df43b342b0 /x11-plugins/msn-pecan
parentVersion bump (diff)
downloadgentoo-2-fd208fcaf91ef7ab8275705cbc2c47f2c3ae4341.tar.gz
gentoo-2-fd208fcaf91ef7ab8275705cbc2c47f2c3ae4341.tar.bz2
gentoo-2-fd208fcaf91ef7ab8275705cbc2c47f2c3ae4341.zip
Version bump, mostly fixes after valgrind runs
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/msn-pecan')
-rw-r--r--x11-plugins/msn-pecan/ChangeLog8
-rw-r--r--x11-plugins/msn-pecan/msn-pecan-0.1.0_rc4.ebuild46
2 files changed, 53 insertions, 1 deletions
diff --git a/x11-plugins/msn-pecan/ChangeLog b/x11-plugins/msn-pecan/ChangeLog
index 6ed6b2a49e89..12f8cfaf163e 100644
--- a/x11-plugins/msn-pecan/ChangeLog
+++ b/x11-plugins/msn-pecan/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/msn-pecan
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/ChangeLog,v 1.6 2010/01/29 00:49:04 voyageur Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/ChangeLog,v 1.7 2010/02/12 07:38:09 voyageur Exp $
+
+*msn-pecan-0.1.0_rc4 (12 Feb 2010)
+
+ 12 Feb 2010; Bernard Cafarelli <voyageur@gentoo.org>
+ +msn-pecan-0.1.0_rc4.ebuild:
+ Version bump, mostly fixes after valgrind runs
*msn-pecan-0.1.0_rc3 (29 Jan 2010)
diff --git a/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc4.ebuild b/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc4.ebuild
new file mode 100644
index 000000000000..88ec5781024f
--- /dev/null
+++ b/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/msn-pecan/msn-pecan-0.1.0_rc4.ebuild,v 1.1 2010/02/12 07:38:09 voyageur Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="Alternative MSN protocol plugin for libpurple"
+HOMEPAGE="http://code.google.com/p/msn-pecan/"
+
+SRC_URI="http://msn-pecan.googlecode.com/files/${P/_/-}.tar.bz2"
+LICENSE="GPL-2"
+
+SLOT="0"
+
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="net-im/pidgin"
+DEPEND="dev-util/pkgconfig
+ ${RDEPEND}"
+
+S=${WORKDIR}/${P/_/-}
+
+src_prepare() {
+ sed -e "/^LDFLAGS/{s/$/ ${LDFLAGS}/;}" \
+ -e "/^CFLAGS/{s/$/ ${CFLAGS}/;}" -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "Select the 'WLM' protocol to use this plugin"
+ einfo
+ elog "For more information (how to change personal message, add"
+ elog "missing emoticons, ...), please read:"
+ elog "http://code.google.com/p/msn-pecan/wiki/FAQ"
+}