summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2008-01-28 13:57:15 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2008-01-28 13:57:15 +0000
commite30dea1acdc3b1adc8113d53f0283432f0b1e40e (patch)
treed8b00dda1d6def49a29ce475140aeb6e2d17c8c2 /x11-plugins/wmMatrix
parentRevision bump, closing bug #207802. Some QA fixing on previous ebuild. (diff)
downloadgentoo-2-e30dea1acdc3b1adc8113d53f0283432f0b1e40e.tar.gz
gentoo-2-e30dea1acdc3b1adc8113d53f0283432f0b1e40e.tar.bz2
gentoo-2-e30dea1acdc3b1adc8113d53f0283432f0b1e40e.zip
Revision bump, with fixes for multilib, LDFLAGS, crosscompile, ecc. Closes bug #207766.
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins/wmMatrix')
-rw-r--r--x11-plugins/wmMatrix/ChangeLog9
-rw-r--r--x11-plugins/wmMatrix/files/digest-wmMatrix-0.2-r13
-rw-r--r--x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch34
-rw-r--r--x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild37
4 files changed, 82 insertions, 1 deletions
diff --git a/x11-plugins/wmMatrix/ChangeLog b/x11-plugins/wmMatrix/ChangeLog
index c7ba68f4bfbd..01a9b222e465 100644
--- a/x11-plugins/wmMatrix/ChangeLog
+++ b/x11-plugins/wmMatrix/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/wmMatrix
# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmMatrix/ChangeLog,v 1.12 2007/07/22 05:35:02 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmMatrix/ChangeLog,v 1.13 2008/01/28 13:57:14 s4t4n Exp $
+
+*wmMatrix-0.2-r1 (28 Jan 2008)
+
+ 28 Jan 2008; Michele Noberasco <s4t4n@gentoo.org> wmMatrix-0.2-r1.ebuild,
+ wmMatrix-0.2-makefile.patch, digest-wmMatrix-0.2-r1 :
+ Revision bump, with fixes for LDFLAGS, crosscompile, multilib, etc...
+ Closes bug #207766.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; wmMatrix-0.2.ebuild:
Drop virtual/x11 references.
diff --git a/x11-plugins/wmMatrix/files/digest-wmMatrix-0.2-r1 b/x11-plugins/wmMatrix/files/digest-wmMatrix-0.2-r1
new file mode 100644
index 000000000000..b1924861c02d
--- /dev/null
+++ b/x11-plugins/wmMatrix/files/digest-wmMatrix-0.2-r1
@@ -0,0 +1,3 @@
+MD5 4e9f0c94e78ad65ea9a564fba5f7a187 wmMatrix-0.2.tar.gz 225343
+RMD160 af7734e6fab719329d4f2170941e6c219c17159e wmMatrix-0.2.tar.gz 225343
+SHA256 ce7b18b1046985237388846332234fd5aaae7b6ba2476ba465e4e57208b75053 wmMatrix-0.2.tar.gz 225343
diff --git a/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch b/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch
new file mode 100644
index 000000000000..5225ad38f679
--- /dev/null
+++ b/x11-plugins/wmMatrix/files/wmMatrix-0.2-makefile.patch
@@ -0,0 +1,34 @@
+--- Makefile.orig 1999-08-16 18:01:58.000000000 +0200
++++ Makefile 2008-01-27 23:23:36.000000000 +0100
+@@ -1,8 +1,8 @@
+-CC = gcc
+-CFLAGS = -O2 -Wall
+-INCDIR = -I/usr/X11R6/include/X11 -I/usr/X11R6/include
+-DESTDIR= /usr/X11R6
+-LIBDIR = -L/usr/X11R6/lib
++CC ?= gcc
++CFLAGS += -Wall
++INCDIR = -I/usr/include/X11 -I/usr/include
++PREFIX ?= /usr
++LIBDIR ?= /usr/lib
+
+ # for Linux
+ LIBS = -lXpm -lX11 -lXext
+@@ -24,7 +24,7 @@
+
+ wmMatrix.o: wmMatrix_master.xpm wmMatrix_mask.xbm
+ wmMatrix: $(OBJS)
+- $(CC) $(COPTS) $(SYSTEM) -o wmMatrix $^ $(INCDIR) $(LIBDIR) $(LIBS)
++ $(CC) $(COPTS) $(SYSTEM) -o wmMatrix $^ $(INCDIR) -L$(LIBDIR) $(LDFLAGS) $(LIBS)
+
+
+ clean:
+@@ -34,5 +34,6 @@
+ rm -f wmMatrix
+
+ install:: wmMatrix
+- install -c -s -m 0755 wmMatrix $(DESTDIR)/bin
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install -m 0755 wmMatrix $(DESTDIR)$(PREFIX)/bin
+
+
diff --git a/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild b/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild
new file mode 100644
index 000000000000..5e1bf82f476f
--- /dev/null
+++ b/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmMatrix/wmMatrix-0.2-r1.ebuild,v 1.1 2008/01/28 13:57:14 s4t4n Exp $
+
+inherit eutils toolchain-funcs multilib
+
+DESCRIPTION="WMaker DockApp: Slightly modified version of Jamie Zawinski's xmatrix screenhack."
+SRC_URI="http://www.dockapps.org/download.php/id/17/${P}.tar.gz"
+HOMEPAGE="http://www.dockapps.org/file.php/id/10"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ x11-proto/xproto
+ x11-proto/xextproto"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~sparc ~amd64 ~ppc ~ppc64"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-makefile.patch
+}
+
+src_compile() {
+ # this version is distributed with compiled binaries!
+ make clean
+ emake CC="$(tc-getCC)" LIBDIR="/usr/$(get_libdir)" || die "compile failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "install failed"
+}