summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2014-06-19 19:16:29 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2014-06-19 19:16:29 +0000
commit0a41751f1a917afdcf3ed8c0e9265f6280efc903 (patch)
tree61de61c3a13f8a13ea40606d2cf8f19ada59c03b /x11-plugins/wmbattery
parentppc/ppc64 stable wrt #513700 (diff)
downloadgentoo-2-0a41751f1a917afdcf3ed8c0e9265f6280efc903.tar.gz
gentoo-2-0a41751f1a917afdcf3ed8c0e9265f6280efc903.tar.bz2
gentoo-2-0a41751f1a917afdcf3ed8c0e9265f6280efc903.zip
Version bump; patch for excluding obsolete UPower API.
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'x11-plugins/wmbattery')
-rw-r--r--x11-plugins/wmbattery/ChangeLog8
-rw-r--r--x11-plugins/wmbattery/files/wmbattery-2.43-upower-0.99.patch13
-rw-r--r--x11-plugins/wmbattery/wmbattery-2.43.ebuild37
3 files changed, 57 insertions, 1 deletions
diff --git a/x11-plugins/wmbattery/ChangeLog b/x11-plugins/wmbattery/ChangeLog
index 503bcb4cce24..967a51deec9c 100644
--- a/x11-plugins/wmbattery/ChangeLog
+++ b/x11-plugins/wmbattery/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmbattery
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbattery/ChangeLog,v 1.27 2014/05/26 19:57:06 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbattery/ChangeLog,v 1.28 2014/06/19 19:16:29 ssuominen Exp $
+
+*wmbattery-2.43 (19 Jun 2014)
+
+ 19 Jun 2014; Samuli Suominen <ssuominen@gentoo.org>
+ +files/wmbattery-2.43-upower-0.99.patch, +wmbattery-2.43.ebuild:
+ Version bump; patch for excluding obsolete UPower API.
26 May 2014; Samuli Suominen <ssuominen@gentoo.org> wmbattery-2.42.ebuild:
Fix dependencies to allow sys-power/upower-pm-utils.
diff --git a/x11-plugins/wmbattery/files/wmbattery-2.43-upower-0.99.patch b/x11-plugins/wmbattery/files/wmbattery-2.43-upower-0.99.patch
new file mode 100644
index 000000000000..320c037195b1
--- /dev/null
+++ b/x11-plugins/wmbattery/files/wmbattery-2.43-upower-0.99.patch
@@ -0,0 +1,13 @@
+--- upower.c
++++ upower.c
+@@ -62,8 +62,10 @@
+ return 0;
+ }
+
++ #if !UP_CHECK_VERSION(0, 9, 99)
+ /* Allow a battery that was not present before to appear. */
+ up_client_enumerate_devices_sync(up, NULL, NULL);
++ #endif
+
+ devices = up_client_get_devices(up);
+
diff --git a/x11-plugins/wmbattery/wmbattery-2.43.ebuild b/x11-plugins/wmbattery/wmbattery-2.43.ebuild
new file mode 100644
index 000000000000..032ce94b779c
--- /dev/null
+++ b/x11-plugins/wmbattery/wmbattery-2.43.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmbattery/wmbattery-2.43.ebuild,v 1.1 2014/06/19 19:16:29 ssuominen Exp $
+
+EAPI=5
+inherit autotools eutils
+
+DESCRIPTION="A dockable app to report APM, ACPI, or SPIC battery status"
+HOMEPAGE="http://joeyh.name/code/wmbattery/"
+SRC_URI="mirror://debian/pool/main/w/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE=""
+
+RDEPEND="sys-apps/apmd
+ || ( >=sys-power/upower-0.9.23 sys-power/upower-pm-utils )
+ x11-libs/libX11
+ x11-libs/libXext
+ x11-libs/libXpm"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+S=${WORKDIR}/${PN}
+
+DOCS=( README TODO )
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-upower-0.99.patch
+
+ sed -i \
+ -e '/^icondir/s:icons:pixmaps:' \
+ autoconf/makeinfo.in || die
+
+ eautoconf
+}