summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-03-15 22:03:02 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-03-15 22:03:02 +0000
commitceecfe97a55b3af6fc9425ca460ff90bad42955b (patch)
treeee138cf6b0e0ad89c88bfe54f80693ab7c31934d /x11-plugins/wmfire
parentRemoved old with incorrect wxwindows flag (diff)
downloadgentoo-2-ceecfe97a55b3af6fc9425ca460ff90bad42955b.tar.gz
gentoo-2-ceecfe97a55b3af6fc9425ca460ff90bad42955b.tar.bz2
gentoo-2-ceecfe97a55b3af6fc9425ca460ff90bad42955b.zip
Version bump wrt #309651 by "hitachi".
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'x11-plugins/wmfire')
-rw-r--r--x11-plugins/wmfire/ChangeLog9
-rw-r--r--x11-plugins/wmfire/wmfire-1.2.4.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/x11-plugins/wmfire/ChangeLog b/x11-plugins/wmfire/ChangeLog
index e84d2943a384..897f009774b2 100644
--- a/x11-plugins/wmfire/ChangeLog
+++ b/x11-plugins/wmfire/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmfire
-# Copyright 2002-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/ChangeLog,v 1.14 2009/06/04 00:14:08 tcunha Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/ChangeLog,v 1.15 2010/03/15 22:03:02 ssuominen Exp $
+
+*wmfire-1.2.4 (15 Mar 2010)
+
+ 15 Mar 2010; Samuli Suominen <ssuominen@gentoo.org> +wmfire-1.2.4.ebuild:
+ Version bump wrt #309651 by "hitachi".
04 Jun 2009; Tiago Cunha <tcunha@gentoo.org> wmfire-1.2.3.ebuild:
stable sparc, bug 215651
diff --git a/x11-plugins/wmfire/wmfire-1.2.4.ebuild b/x11-plugins/wmfire/wmfire-1.2.4.ebuild
new file mode 100644
index 000000000000..5d9477c90e4e
--- /dev/null
+++ b/x11-plugins/wmfire/wmfire-1.2.4.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmfire/wmfire-1.2.4.ebuild,v 1.1 2010/03/15 22:03:02 ssuominen Exp $
+
+EAPI=2
+inherit autotools eutils
+
+DESCRIPTION="Load monitoring dockapp displaying dancing flame."
+HOMEPAGE="http://www.swanson.ukfsn.org/#wmfire"
+SRC_URI="http://www.swanson.ukfsn.org/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="session"
+
+RDEPEND="x11-libs/gtk+:2
+ >=gnome-base/libgtop-2
+ x11-libs/libX11
+ x11-libs/libXext
+ session? ( x11-libs/libSM
+ x11-libs/libICE )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2.3-stringh.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable session)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc ALL_I_GET_IS_A_GREY_BOX AUTHORS ChangeLog NEWS README
+}