summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-14 17:41:13 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-14 17:41:13 +0000
commitbaa2566c651d4fcebb3dd13834cadcc26fec0d13 (patch)
treeb0a78d5f86914615c2f7624dc1220a06edb65154 /x11-plugins/wmix/wmix-3.1-r1.ebuild
parentMark stable on X86 based on compile test, as requested by Samuli Suominen <dr... (diff)
downloadgentoo-2-baa2566c651d4fcebb3dd13834cadcc26fec0d13.tar.gz
gentoo-2-baa2566c651d4fcebb3dd13834cadcc26fec0d13.tar.bz2
gentoo-2-baa2566c651d4fcebb3dd13834cadcc26fec0d13.zip
Respect CC and LDFLAGS flags.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins/wmix/wmix-3.1-r1.ebuild')
-rw-r--r--x11-plugins/wmix/wmix-3.1-r1.ebuild45
1 files changed, 18 insertions, 27 deletions
diff --git a/x11-plugins/wmix/wmix-3.1-r1.ebuild b/x11-plugins/wmix/wmix-3.1-r1.ebuild
index 6e7de4f63024..9ac06d0ed1d6 100644
--- a/x11-plugins/wmix/wmix-3.1-r1.ebuild
+++ b/x11-plugins/wmix/wmix-3.1-r1.ebuild
@@ -1,47 +1,38 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmix/wmix-3.1-r1.ebuild,v 1.5 2007/07/22 04:57:50 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmix/wmix-3.1-r1.ebuild,v 1.6 2008/01/14 17:41:13 drac Exp $
-inherit eutils
+inherit eutils toolchain-funcs
-IUSE=""
DESCRIPTION="Dockapp mixer for OSS or ALSA"
+HOMEPAGE="http://www.ne.jp/asahi/linux/timecop"
SRC_URI="http://www.ne.jp/asahi/linux/timecop/software/${P}.tar.gz"
-HOMEPAGE="http://www.ne.jp/asahi/linux/timecop/"
-SLOT="0"
LICENSE="GPL-2"
+SLOT="0"
KEYWORDS="amd64 ~ppc ~sparc x86"
+IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXext
x11-libs/libXpm"
DEPEND="${RDEPEND}
x11-proto/xproto
- x11-proto/xextproto
- >=sys-apps/sed-4"
+ x11-proto/xextproto"
-src_unpack()
-{
- unpack ${A} ; cd ${S}
- sed -i -e "/^CFLAGS/d" Makefile
-
- # duh, wmix author forgot to update the version number
- epatch ${FILESDIR}/fix-wmix-3.1-version-number.patch
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/fix-wmix-3.1-version-number.patch
}
-src_compile()
-{
- emake || die
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" \
+ LDFLAGS="${LDFLAGS}" || die "emake failed."
}
-src_install ()
-{
- exeinto /usr/bin
- doexe wmix
-
- # Original manpage does not work, we provide a fixed (and updated) one
- doman ${FILESDIR}/wmix.1
-
- dodoc README NEWS BUGS AUTHORS sample.wmixrc
+src_install() {
+ dobin ${PN}
+ doman "${FILESDIR}"/${PN}.1
+ dodoc AUTHORS BUGS NEWS README sample.wmixrc
}