summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichele Noberasco <s4t4n@gentoo.org>2005-08-24 07:54:42 +0000
committerMichele Noberasco <s4t4n@gentoo.org>2005-08-24 07:54:42 +0000
commit9f18f2d12e4c4ba654a9312abc4560641797801e (patch)
treee6e4480f7a85688dd34f4ce37ebd3de55432a081 /x11-plugins/wmmp3
parentFixed cp commandline and removed root:root chown. (diff)
downloadgentoo-2-9f18f2d12e4c4ba654a9312abc4560641797801e.tar.gz
gentoo-2-9f18f2d12e4c4ba654a9312abc4560641797801e.tar.bz2
gentoo-2-9f18f2d12e4c4ba654a9312abc4560641797801e.zip
Added patch to make safety checks on X includes and libraries. Closes bug #103531.
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'x11-plugins/wmmp3')
-rw-r--r--x11-plugins/wmmp3/ChangeLog6
-rw-r--r--x11-plugins/wmmp3/Manifest3
-rw-r--r--x11-plugins/wmmp3/files/wmmp3-0.12-x_includes_n_libraries.patch20
-rw-r--r--x11-plugins/wmmp3/wmmp3-0.12.ebuild15
4 files changed, 40 insertions, 4 deletions
diff --git a/x11-plugins/wmmp3/ChangeLog b/x11-plugins/wmmp3/ChangeLog
index 46420181c17e..b10419f88ef9 100644
--- a/x11-plugins/wmmp3/ChangeLog
+++ b/x11-plugins/wmmp3/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/wmmp3
# Copyright 1999-2004 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmp3/ChangeLog,v 1.5 2004/11/24 23:24:41 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmp3/ChangeLog,v 1.6 2005/08/24 07:54:42 s4t4n Exp $
+
+ 24 Aug 2005; Michele Noberasco <s4t4n@gentoo.org> wmmp3-0.12.ebuild:
+ Added patch to make safety checks on X includes and libraries, fixes
+ bug #103531.
24 Nov 2004; Jason Wever <weeve@gentoo.org> wmmp3-0.12.ebuild:
Added ~sparc keyword.
diff --git a/x11-plugins/wmmp3/Manifest b/x11-plugins/wmmp3/Manifest
index ad0bb20801a0..accb1be30198 100644
--- a/x11-plugins/wmmp3/Manifest
+++ b/x11-plugins/wmmp3/Manifest
@@ -1,4 +1,5 @@
+MD5 32cbc285bb4227cf5786ec30f4f1ca69 wmmp3-0.12.ebuild 1016
MD5 2a504dc58f78b65131cc053c88c2d944 ChangeLog 825
MD5 62ba71d3b2fa785a4cbd5d47fdbd0eb6 metadata.xml 165
-MD5 3a639961b0c2bce204e2c7ff8dae9d07 wmmp3-0.12.ebuild 890
MD5 632f433b2b4fca8b12da86ca825f44d6 files/digest-wmmp3-0.12 61
+MD5 15e66942968039ecdb324c4dee9f1e00 files/wmmp3-0.12-x_includes_n_libraries.patch 582
diff --git a/x11-plugins/wmmp3/files/wmmp3-0.12-x_includes_n_libraries.patch b/x11-plugins/wmmp3/files/wmmp3-0.12-x_includes_n_libraries.patch
new file mode 100644
index 000000000000..91e6c679dcda
--- /dev/null
+++ b/x11-plugins/wmmp3/files/wmmp3-0.12-x_includes_n_libraries.patch
@@ -0,0 +1,20 @@
+--- configure.orig 2005-08-24 09:45:23.000000000 +0200
++++ configure 2005-08-24 09:45:08.000000000 +0200
+@@ -1977,11 +1977,15 @@
+
+
+ if test "$x_includes" != "NONE"; then
+- CFLAGS="$CFLAGS -I$x_includes"
++ if test "$x_includes" != ""; then
++ CFLAGS="$CFLAGS -I$x_includes"
++ fi
+ fi
+
+ if test "$x_libraries" != "NONE"; then
+- LDFLAGS="$LDFLAGS -L$x_libraries"
++ if test "$x_libraries" != ""; then
++ LDFLAGS="$LDFLAGS -L$x_libraries"
++ fi
+ fi
+
+ echo $ac_n "checking for XOpenDisplay in -lX11""... $ac_c" 1>&6
diff --git a/x11-plugins/wmmp3/wmmp3-0.12.ebuild b/x11-plugins/wmmp3/wmmp3-0.12.ebuild
index ff9515dfbf6b..a7afb49268c7 100644
--- a/x11-plugins/wmmp3/wmmp3-0.12.ebuild
+++ b/x11-plugins/wmmp3/wmmp3-0.12.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2004 Gentoo Foundation
+# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmp3/wmmp3-0.12.ebuild,v 1.5 2004/11/24 23:24:41 weeve Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmmp3/wmmp3-0.12.ebuild,v 1.6 2005/08/24 07:54:42 s4t4n Exp $
+
+inherit eutils
IUSE=""
@@ -15,6 +17,15 @@ KEYWORDS="x86 ppc ~sparc"
DEPEND="virtual/x11
>=media-sound/mpg123-0.59s-r2"
+src_unpack()
+{
+ unpack ${A}
+ cd ${S}
+
+ # Fix #103531
+ epatch ${FILESDIR}/${P}-x_includes_n_libraries.patch
+}
+
src_compile()
{
# override wmmp3 self-calculated cflags