summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2008-01-12 13:36:31 +0000
committerSamuli Suominen <drac@gentoo.org>2008-01-12 13:36:31 +0000
commit51806fe518faed93c555a3d8b3c1d71084529086 (patch)
treec0d6d817cbfc6cc7dc0713be8a27ee31255f78c3 /x11-plugins/wmtz
parentadd ~x86 (diff)
downloadgentoo-2-51806fe518faed93c555a3d8b3c1d71084529086.tar.gz
gentoo-2-51806fe518faed93c555a3d8b3c1d71084529086.tar.bz2
gentoo-2-51806fe518faed93c555a3d8b3c1d71084529086.zip
Stop using epatch in src_compile, use toolchain-funcs for CC and some more.
(Portage version: 2.1.4)
Diffstat (limited to 'x11-plugins/wmtz')
-rw-r--r--x11-plugins/wmtz/ChangeLog9
-rw-r--r--x11-plugins/wmtz/files/wmtz-0.7-gcc34.patch18
-rw-r--r--x11-plugins/wmtz/files/wmtz-0.7.patch48
-rw-r--r--x11-plugins/wmtz/files/wmtz.c.patch12
-rw-r--r--x11-plugins/wmtz/wmtz-0.7.ebuild32
5 files changed, 71 insertions, 48 deletions
diff --git a/x11-plugins/wmtz/ChangeLog b/x11-plugins/wmtz/ChangeLog
index a05793c0d682..c985727d77f9 100644
--- a/x11-plugins/wmtz/ChangeLog
+++ b/x11-plugins/wmtz/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/wmtz
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/ChangeLog,v 1.16 2007/07/22 04:24:31 dberkholz Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/ChangeLog,v 1.17 2008/01/12 13:36:30 drac Exp $
+
+ 12 Jan 2008; Samuli Suominen <drac@gentoo.org>
+ -files/wmtz-0.7-gcc34.patch, +files/wmtz-0.7.patch, -files/wmtz.c.patch,
+ wmtz-0.7.ebuild:
+ Stop using epatch in src_compile, use toolchain-funcs for CC and some more.
22 Jul 2007; Donnie Berkholz <dberkholz@gentoo.org>; wmtz-0.7.ebuild:
Drop virtual/x11 references.
diff --git a/x11-plugins/wmtz/files/wmtz-0.7-gcc34.patch b/x11-plugins/wmtz/files/wmtz-0.7-gcc34.patch
deleted file mode 100644
index 2eeb153626a0..000000000000
--- a/x11-plugins/wmtz/files/wmtz-0.7-gcc34.patch
+++ /dev/null
@@ -1,18 +0,0 @@
---- wmtz-0.7/wmtz/wmtz.c.old 2004-09-18 11:52:09.487481335 -0700
-+++ wmtz-0.7/wmtz/wmtz.c 2004-09-18 11:52:45.805696921 -0700
-@@ -478,6 +478,7 @@
- but_stat = -1;
- break;
- default:
-+ break;
- }
- }
-
-@@ -528,6 +529,7 @@
- exit(0);
- break;
- default:
-+ break;
- }
- return;
- }
diff --git a/x11-plugins/wmtz/files/wmtz-0.7.patch b/x11-plugins/wmtz/files/wmtz-0.7.patch
new file mode 100644
index 000000000000..adb5c68f1b6c
--- /dev/null
+++ b/x11-plugins/wmtz/files/wmtz-0.7.patch
@@ -0,0 +1,48 @@
+diff -ur wmtz-0.7.orig/wmtz/Makefile wmtz-0.7/wmtz/Makefile
+--- wmtz-0.7.orig/wmtz/Makefile 2001-03-11 15:57:59.000000000 +0200
++++ wmtz-0.7/wmtz/Makefile 2008-01-12 15:24:29.000000000 +0200
+@@ -1,5 +1,5 @@
+ CC = gcc
+-LIBDIR = -L/usr/X11R6/lib
++LIBDIR = -L/usr/lib
+ LIBS = -lXpm -lXext -lX11 -lm
+ FLAGS = -O2
+ DESTDIR = /usr/local
+@@ -10,7 +10,7 @@
+
+
+ .c.o:
+- $(CC) -I/usr/X11R6/include $(FLAGS) -c -Wall $< -o $*.o
++ $(CC) -I/usr/include $(FLAGS) -c -Wall $< -o $*.o
+
+ wmtz: $(OBJS)
+ $(CC) $(FLAGS) -o wmtz $^ -lXext $(LIBDIR) $(LIBS)
+diff -ur wmtz-0.7.orig/wmtz/wmtz.c wmtz-0.7/wmtz/wmtz.c
+--- wmtz-0.7.orig/wmtz/wmtz.c 2001-04-16 22:26:34.000000000 +0300
++++ wmtz-0.7/wmtz/wmtz.c 2008-01-12 15:17:37.000000000 +0200
+@@ -51,8 +51,7 @@
+ #define STRSIZE 10
+ #define LMST 1
+ #define GMST 0
+-#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7
+-http://www.geocities.com/jl1n/wmtz/wmtz.html\""
++#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7\nhttp://www.geocities.com/jl1n/wmtz/wmtz.html\""
+
+
+ /*
+@@ -479,6 +478,7 @@
+ but_stat = -1;
+ break;
+ default:
++ break;
+ }
+ }
+
+@@ -529,6 +529,7 @@
+ exit(0);
+ break;
+ default:
++ break;
+ }
+ return;
+ }
diff --git a/x11-plugins/wmtz/files/wmtz.c.patch b/x11-plugins/wmtz/files/wmtz.c.patch
deleted file mode 100644
index 7ae6edf247fb..000000000000
--- a/x11-plugins/wmtz/files/wmtz.c.patch
+++ /dev/null
@@ -1,12 +0,0 @@
---- wmtz.c 2001-04-16 21:26:34.000000000 +0200
-+++ wmtz.c_ 2004-04-07 14:15:06.171481088 +0200
-@@ -51,8 +51,7 @@
- #define STRSIZE 10
- #define LMST 1
- #define GMST 0
--#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7
--http://www.geocities.com/jl1n/wmtz/wmtz.html\""
-+#define ABOUT "xmessage -center -buttons \"Close\" \"WMTZ - Window Maker Time Zone dockapp v0.7\nhttp://www.geocities.com/jl1n/wmtz/wmtz.html\""
-
-
- /*
diff --git a/x11-plugins/wmtz/wmtz-0.7.ebuild b/x11-plugins/wmtz/wmtz-0.7.ebuild
index d88e47bde948..e2784c8aa007 100644
--- a/x11-plugins/wmtz/wmtz-0.7.ebuild
+++ b/x11-plugins/wmtz/wmtz-0.7.ebuild
@@ -1,17 +1,17 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.16 2007/07/22 04:24:31 dberkholz Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmtz/wmtz-0.7.ebuild,v 1.17 2008/01/12 13:36:30 drac Exp $
-inherit eutils toolchain-funcs
+inherit eutils multilib toolchain-funcs
-IUSE=""
DESCRIPTION="dockapp that shows the time in multiple timezones."
-SRC_URI="http://www.geocities.com/jl1n/wmtz/${P}.tar.gz"
HOMEPAGE="http://www.geocities.com/jl1n/wmtz/wmtz.html"
+SRC_URI="http://www.geocities.com/jl1n/wmtz/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="x86 amd64 ppc ~sparc"
+KEYWORDS="amd64 ppc ~sparc x86"
+IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXext
@@ -19,23 +19,23 @@ RDEPEND="x11-libs/libX11
DEPEND="${RDEPEND}
x11-proto/xextproto"
+S=${WORKDIR}/${P}/${PN}
+
src_unpack() {
unpack ${A}
- cd ${S}
-
- #apply both patches to compile with gcc-3.4 closing bug #64556
- epatch ${FILESDIR}/wmtz-0.7-gcc34.patch
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}.patch
}
src_compile() {
- cd ${S}/wmtz
- epatch ${FILESDIR}/wmtz.c.patch
- emake FLAGS="$CFLAGS" || die
+ emake CC="$(tc-getCC)" FLAGS="${CFLAGS}" \
+ LIBDIR="-L/usr/$(get_libdir)" || die "emake failed."
}
src_install () {
- dobin wmtz/wmtz
+ dobin ${PN}
+ doman ${PN}.1
insinto /etc
- doins wmtz/wmtzrc
- dodoc BUGS CHANGES README
+ doins wmtzrc
+ dodoc ../{BUGS,CHANGES,README}
}