summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-01-19 19:31:07 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-01-19 19:31:07 +0000
commit5ddcf125537839536f99677a20e17e3b90805535 (patch)
tree3c0ef652a5579615ab64522d27e1f35acd59a18b /x11-plugins
parentInitial commit. (diff)
downloadgentoo-2-5ddcf125537839536f99677a20e17e3b90805535.tar.gz
gentoo-2-5ddcf125537839536f99677a20e17e3b90805535.tar.bz2
gentoo-2-5ddcf125537839536f99677a20e17e3b90805535.zip
Move under desktop-dock, block app-emulation/docker in current stable, clean ebuild and rename binary
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/docker/ChangeLog11
-rw-r--r--x11-plugins/docker/docker-1.5-r1.ebuild37
-rw-r--r--x11-plugins/docker/docker-1.5.ebuild7
-rw-r--r--x11-plugins/docker/files/docker-1.5-makefile_rename.patch49
-rw-r--r--x11-plugins/docker/metadata.xml6
5 files changed, 102 insertions, 8 deletions
diff --git a/x11-plugins/docker/ChangeLog b/x11-plugins/docker/ChangeLog
index 51511ae2b6e8..a780672ef811 100644
--- a/x11-plugins/docker/ChangeLog
+++ b/x11-plugins/docker/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-plugins/docker
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/docker/ChangeLog,v 1.23 2013/10/19 15:15:47 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/docker/ChangeLog,v 1.24 2015/01/19 19:31:07 voyageur Exp $
+
+*docker-1.5-r1 (19 Jan 2015)
+
+ 19 Jan 2015; Bernard Cafarelli <voyageur@gentoo.org> docker-1.5.ebuild,
+ +docker-1.5-r1.ebuild, +files/docker-1.5-makefile_rename.patch, metadata.xml:
+ Move under desktop-dock, block app-emulation/docker in current stable, clean
+ ebuild and rename binary
19 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Cleanup due desktop-wm removal
diff --git a/x11-plugins/docker/docker-1.5-r1.ebuild b/x11-plugins/docker/docker-1.5-r1.ebuild
new file mode 100644
index 000000000000..cc20fc594c3e
--- /dev/null
+++ b/x11-plugins/docker/docker-1.5-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/docker/docker-1.5-r1.ebuild,v 1.1 2015/01/19 19:31:07 voyageur Exp $
+
+EAPI=5
+inherit eutils toolchain-funcs
+
+DESCRIPTION="Openbox app which acts as a system tray for KDE and GNOME2"
+HOMEPAGE="http://icculus.org/openbox/2/docker/"
+SRC_URI="http://icculus.org/openbox/2/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.0.4
+ x11-libs/libX11"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-makefile_rename.patch"
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo "To avoid collision with app-emulation/docker, binary was renamed to wmdocker"
+}
diff --git a/x11-plugins/docker/docker-1.5.ebuild b/x11-plugins/docker/docker-1.5.ebuild
index 76f180eab64f..1c255ef60edf 100644
--- a/x11-plugins/docker/docker-1.5.ebuild
+++ b/x11-plugins/docker/docker-1.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/docker/docker-1.5.ebuild,v 1.18 2012/05/05 05:12:02 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/docker/docker-1.5.ebuild,v 1.19 2015/01/19 19:31:07 voyageur Exp $
inherit eutils toolchain-funcs
@@ -9,7 +9,8 @@ HOMEPAGE="http://icculus.org/openbox/2/docker/"
SRC_URI="http://icculus.org/openbox/2/${PN}/${P}.tar.gz"
RDEPEND=">=dev-libs/glib-2.0.4
- x11-libs/libX11"
+ x11-libs/libX11
+ !app-emulation/docker"
DEPEND="${RDEPEND}
virtual/pkgconfig"
diff --git a/x11-plugins/docker/files/docker-1.5-makefile_rename.patch b/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
new file mode 100644
index 000000000000..2e742661b11d
--- /dev/null
+++ b/x11-plugins/docker/files/docker-1.5-makefile_rename.patch
@@ -0,0 +1,49 @@
+--- Makefile.orig 2015-01-19 20:10:47.762522964 +0100
++++ Makefile 2015-01-19 20:11:11.463545692 +0100
+@@ -5,12 +5,10 @@
+ #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+
+ # Change this PREFIX to where you want docker to be installed
+-PREFIX=/usr/local
+-# Change this XLIBPATH to point to your X11 development package's installation
+-XLIBPATH=/usr/X11R6/lib
++PREFIX = /usr
+
+ # Sets some flags for stricter compiling
+-CFLAGS=-pedantic -Wall -W -O
++CFLAGS += -pedantic -Wall -W
+
+ #-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#-#
+ # #
+@@ -21,17 +19,17 @@
+ PACKAGE=docker
+ VERSION=1.5
+
+-target=docker
++target=wmdocker
+ sources=docker.c kde.c icons.c xproperty.c net.c
+ headers=docker.h kde.h icons.h xproperty.h net.h version.h
+-extra=README COPYING version.h.in
++extra=README version.h.in
+
+ all: $(target) $(sources) $(headers)
+ @echo Build Successful
+
+ $(target): $(sources:.c=.o)
+- $(CC) $(CFLAGS) -L$(XLIBPATH) -lX11 \
+- `pkg-config --libs glib-2.0` $^ -o $@
++ $(CC) $(LDFLAGS) $(CFLAGS) $^ -lX11 \
++ `pkg-config --libs glib-2.0` -o $@
+
+ %.o: %.c
+ $(CC) -c $(CFLAGS) `pkg-config --cflags glib-2.0` $<
+@@ -40,7 +38,8 @@
+ sed -e "s/@VERSION@/$(VERSION)/" version.h.in > $@
+
+ install: all
+- install $(target) $(PREFIX)/bin/$(target)
++ install -d $(DESTDIR)$(PREFIX)/bin
++ install $(target) $(DESTDIR)$(PREFIX)/bin/$(target)
+
+ uninstall:
+ rm -f $(PREFIX)/$(target)
diff --git a/x11-plugins/docker/metadata.xml b/x11-plugins/docker/metadata.xml
index 4497ed96289f..6a888dd1add1 100644
--- a/x11-plugins/docker/metadata.xml
+++ b/x11-plugins/docker/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<maintainer><email>maintainer-needed@gentoo.org</email></maintainer>
- <longdescription>
+<herd>desktop-dock</herd>
+<longdescription>
Openbox app which acts as a system tray for KDE and GNOME2.
- </longdescription>
+</longdescription>
</pkgmetadata>