summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2014-03-23 17:32:23 +0000
committerMichael Palimaka <kensington@gentoo.org>2014-03-23 17:32:23 +0000
commit6175dd08156e43708b4ec345986b3aff98040092 (patch)
tree946a8f835c54f81afcf140efca363d8bbbe1a924 /x11-plugins
parentPing virtual/jpeg to SLOT 0. (diff)
downloadgentoo-2-6175dd08156e43708b4ec345986b3aff98040092.tar.gz
gentoo-2-6175dd08156e43708b4ec345986b3aff98040092.tar.bz2
gentoo-2-6175dd08156e43708b4ec345986b3aff98040092.zip
Revision bump migrating to EAPI 5. Add missing dependency. Remove transitive dependency. Remove jpeg USE flag that did nothing. Update HOMEPAGE wrt bug #367185. Respect LDFLAGS wrt bug #336818. Fully respect CC wrt bug #444944.
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key 0x06B1F38DCA45A1EC!)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/asapm/ChangeLog12
-rw-r--r--x11-plugins/asapm/asapm-3.1-r1.ebuild36
-rw-r--r--x11-plugins/asapm/files/asapm-3.1-ldflags.patch11
3 files changed, 57 insertions, 2 deletions
diff --git a/x11-plugins/asapm/ChangeLog b/x11-plugins/asapm/ChangeLog
index 87c39391466a..05bf9fad7063 100644
--- a/x11-plugins/asapm/ChangeLog
+++ b/x11-plugins/asapm/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for x11-plugins/asapm
-# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/ChangeLog,v 1.19 2013/10/19 14:49:51 pacho Exp $
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/ChangeLog,v 1.20 2014/03/23 17:32:23 kensington Exp $
+
+*asapm-3.1-r1 (23 Mar 2014)
+
+ 23 Mar 2014; Michael Palimaka <kensington@gentoo.org> +asapm-3.1-r1.ebuild,
+ +files/asapm-3.1-ldflags.patch:
+ Revision bump migrating to EAPI 5. Add missing dependency. Remove transitive
+ dependency. Remove jpeg USE flag that did nothing. Update HOMEPAGE wrt bug
+ #367185. Respect LDFLAGS wrt bug #336818. Fully respect CC wrt bug #444944.
19 Oct 2013; Pacho Ramos <pacho@gentoo.org> metadata.xml:
Drop afterstep herd
diff --git a/x11-plugins/asapm/asapm-3.1-r1.ebuild b/x11-plugins/asapm/asapm-3.1-r1.ebuild
new file mode 100644
index 000000000000..68c90ff8c29a
--- /dev/null
+++ b/x11-plugins/asapm/asapm-3.1-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/asapm/asapm-3.1-r1.ebuild,v 1.1 2014/03/23 17:32:23 kensington Exp $
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="APM monitor for AfterStep"
+HOMEPAGE="http://tigr.net/afterstep/applets/"
+SRC_URI="http://www.tigr.net/afterstep/download/asapm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc -sparc ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXpm"
+
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+pkg_setup() {
+ tc-export CC
+}
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-ldflags.patch"
+}
+
+src_install() {
+ dobin asapm
+ newman asapm.man asapm.1
+ dodoc CHANGES README TODO NOTES
+}
diff --git a/x11-plugins/asapm/files/asapm-3.1-ldflags.patch b/x11-plugins/asapm/files/asapm-3.1-ldflags.patch
new file mode 100644
index 000000000000..11466cdbb1bd
--- /dev/null
+++ b/x11-plugins/asapm/files/asapm-3.1-ldflags.patch
@@ -0,0 +1,11 @@
+--- autoconf/Makefile.common.in
++++ autoconf/Makefile.common.in
+@@ -34,7 +34,7 @@
+ done
+
+ $(PROG): $(OBJS)
+- $(CC) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
++ $(CC) $(LDFLAGS) $(OBJS) $(LIBRARIES) $(EXTRA_LIBRARIES) -o $(@)
+
+ .c.o:
+ $(CC) $(CCFLAGS) $(EXTRA_DEFINES) $(INCLUDES) $(EXTRA_INCLUDES) -c $*.c