summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Whyman <thev00d00@gentoo.org>2015-02-12 14:54:11 +0000
committerIan Whyman <thev00d00@gentoo.org>2015-02-12 14:54:11 +0000
commite269d80065f42cfa879db2e79a308a79d5ee2da0 (patch)
treee51e8346a464bc6a78a0d6b318bdfad3178145ad /x11-plugins
parentAdd missing dependency, #539812 (diff)
downloadgentoo-2-e269d80065f42cfa879db2e79a308a79d5ee2da0.tar.gz
gentoo-2-e269d80065f42cfa879db2e79a308a79d5ee2da0.tar.bz2
gentoo-2-e269d80065f42cfa879db2e79a308a79d5ee2da0.zip
Version bump
(Portage version: 2.2.15/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-sipe/ChangeLog9
-rw-r--r--x11-plugins/pidgin-sipe/pidgin-sipe-1.19.0.ebuild67
2 files changed, 74 insertions, 2 deletions
diff --git a/x11-plugins/pidgin-sipe/ChangeLog b/x11-plugins/pidgin-sipe/ChangeLog
index ae41dce1a29d..3c5a205cdc4c 100644
--- a/x11-plugins/pidgin-sipe/ChangeLog
+++ b/x11-plugins/pidgin-sipe/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-plugins/pidgin-sipe
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.34 2014/12/30 08:49:56 thev00d00 Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/ChangeLog,v 1.35 2015/02/12 14:54:11 thev00d00 Exp $
+
+*pidgin-sipe-1.19.0 (12 Feb 2015)
+
+ 12 Feb 2015; Ian Whyman <thev00d00@gentoo.org> +pidgin-sipe-1.19.0.ebuild:
+ Version bump
*pidgin-sipe-1.18.5 (30 Dec 2014)
diff --git a/x11-plugins/pidgin-sipe/pidgin-sipe-1.19.0.ebuild b/x11-plugins/pidgin-sipe/pidgin-sipe-1.19.0.ebuild
new file mode 100644
index 000000000000..441428758325
--- /dev/null
+++ b/x11-plugins/pidgin-sipe/pidgin-sipe-1.19.0.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-sipe/pidgin-sipe-1.19.0.ebuild,v 1.1 2015/02/12 14:54:11 thev00d00 Exp $
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="Pidgin Plug-in SIPE (Sip Exchange Protocol)"
+HOMEPAGE="http://sipe.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sipe/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+IUSE="debug kerberos ocs2005-message-hack openssl telepathy voice"
+
+RDEPEND=">=dev-libs/gmime-2.4.16
+ dev-libs/libxml2
+ openssl? ( dev-libs/openssl )
+ !openssl? ( dev-libs/nss )
+ kerberos? ( virtual/krb5 )
+ voice? (
+ >=dev-libs/glib-2.28.0
+ >=net-libs/libnice-0.1.0
+ media-libs/gstreamer:0.10
+ >=net-im/pidgin-2.8.0
+ )
+ !voice? (
+ >=dev-libs/glib-2.12.0:2
+ net-im/pidgin
+ )
+ telepathy? (
+ >=sys-apps/dbus-1.1.0
+ >=dev-libs/dbus-glib-0.61
+ >=dev-libs/glib-2.28:2
+ >=net-libs/telepathy-glib-0.18.0
+ )
+"
+
+DEPEND="dev-util/intltool
+ virtual/pkgconfig
+ ${RDEPEND}
+"
+
+src_prepare() {
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --enable-purple \
+ --disable-quality-check \
+ $(use_enable telepathy) \
+ $(use_enable debug) \
+ $(use_enable ocs2005-message-hack) \
+ $(use_with kerberos krb5) \
+ $(use_with voice vv) \
+ $(use_enable !openssl nss) \
+ $(use_enable openssl)
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS TODO README
+}