summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Crête <tester@gentoo.org>2008-01-07 04:27:26 +0000
committerOlivier Crête <tester@gentoo.org>2008-01-07 04:27:26 +0000
commite4e3c525f34eac6f02a58e914da647d32f84cbf2 (patch)
treeca1a1ed95907e08ff25289ec827e0a3f21379f29 /x11-plugins
parentAdd dev-util/pkgconfig to DEPEND. (bug #204600) (diff)
downloadgentoo-2-e4e3c525f34eac6f02a58e914da647d32f84cbf2.tar.gz
gentoo-2-e4e3c525f34eac6f02a58e914da647d32f84cbf2.tar.bz2
gentoo-2-e4e3c525f34eac6f02a58e914da647d32f84cbf2.zip
Add dep on gtk (and check that pidgin has it too)
(Portage version: 2.1.3.19)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-otr/ChangeLog8
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild15
-rw-r--r--x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild14
3 files changed, 29 insertions, 8 deletions
diff --git a/x11-plugins/pidgin-otr/ChangeLog b/x11-plugins/pidgin-otr/ChangeLog
index df5ce8dfb1f0..082b9439dffd 100644
--- a/x11-plugins/pidgin-otr/ChangeLog
+++ b/x11-plugins/pidgin-otr/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-plugins/pidgin-otr
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/ChangeLog,v 1.7 2007/08/28 16:29:15 nixnut Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/ChangeLog,v 1.8 2008/01/07 04:27:26 tester Exp $
+
+ 07 Jan 2008; <tester@gentoo.org> pidgin-otr-3.0.0.ebuild,
+ pidgin-otr-3.1.0.ebuild:
+ Add dep on gtk (and check that pidgin has it too)
28 Aug 2007; nixnut <nixnut@gentoo.org> pidgin-otr-3.0.0.ebuild:
Stable on ppc wrt bug 189781
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild
index 1706bc95e186..318d10fabf5c 100644
--- a/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild
+++ b/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild,v 1.6 2007/08/28 16:29:15 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.0.0.ebuild,v 1.7 2008/01/07 04:27:26 tester Exp $
inherit flag-o-matic eutils autotools
@@ -17,10 +17,19 @@ KEYWORDS="amd64 ppc sparc x86"
IUSE=""
DEPEND=">=net-libs/libotr-3.0.0
+ >=x11-libs/gtk+-2
net-im/pidgin"
S="${WORKDIR}"/${MY_P}
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
+
+
src_unpack() {
unpack ${A}
cd "${S}"
@@ -40,5 +49,5 @@ src_compile() {
src_install() {
emake -j1 install DESTDIR="${D}" || die "Install failed"
- dodoc COPYING ChangeLog README
+ dodoc ChangeLog README
}
diff --git a/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild b/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild
index eb76765f010e..465b18071747 100644
--- a/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild
+++ b/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild,v 1.1 2007/08/07 02:17:22 tester Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/pidgin-otr/pidgin-otr-3.1.0.ebuild,v 1.2 2008/01/07 04:27:26 tester Exp $
inherit flag-o-matic eutils autotools
@@ -14,8 +14,16 @@ KEYWORDS="~amd64 ~ppc ~sparc ~x86"
IUSE=""
DEPEND=">=net-libs/libotr-3.1.0
+ >=x11-libs/gtk+-2
net-im/pidgin"
+pkg_setup() {
+ if ! built_with_use net-im/pidgin gtk; then
+ eerror "You need to compile net-im/pidgin with USE=gtk"
+ die "Missing gtk USE flag on net-im/pidgin"
+ fi
+}
+
src_compile() {
strip-flags
replace-flags -O? -O2
@@ -26,5 +34,5 @@ src_compile() {
src_install() {
emake -j1 install DESTDIR="${D}" || die "Install failed"
- dodoc COPYING ChangeLog README
+ dodoc ChangeLog README
}