summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2015-01-20 16:34:32 +0000
committerBernard Cafarelli <voyageur@gentoo.org>2015-01-20 16:34:32 +0000
commitffcd9c16ded715ce072f5ad56871b8b50f90ebfa (patch)
tree56673a0bc5a9d37fb7d8fe9c604d0c53cda499ea /x11-plugins
parentForce X USE-flag for correct font handling, bug #536492 by Toralf Förster <t... (diff)
downloadgentoo-2-ffcd9c16ded715ce072f5ad56871b8b50f90ebfa.tar.gz
gentoo-2-ffcd9c16ded715ce072f5ad56871b8b50f90ebfa.tar.bz2
gentoo-2-ffcd9c16ded715ce072f5ad56871b8b50f90ebfa.zip
Finally fix underlinking, bug #370111
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key C74525F2)
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmswallow/ChangeLog10
-rw-r--r--x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild37
2 files changed, 45 insertions, 2 deletions
diff --git a/x11-plugins/wmswallow/ChangeLog b/x11-plugins/wmswallow/ChangeLog
index 59379416285e..3cc40e00713a 100644
--- a/x11-plugins/wmswallow/ChangeLog
+++ b/x11-plugins/wmswallow/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-plugins/wmswallow
-# Copyright 2000-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmswallow/ChangeLog,v 1.9 2014/08/10 20:09:04 slyfox Exp $
+# Copyright 2000-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmswallow/ChangeLog,v 1.10 2015/01/20 16:34:32 voyageur Exp $
+
+*wmswallow-0.6.1-r1 (20 Jan 2015)
+
+ 20 Jan 2015; Bernard Cafarelli <voyageur@gentoo.org>
+ +wmswallow-0.6.1-r1.ebuild:
+ Finally fix underlinking, bug #370111
10 Aug 2014; Sergei Trofimovich <slyfox@gentoo.org> wmswallow-0.6.1.ebuild:
QA: drop trailing '.' from DESCRIPTION
diff --git a/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
new file mode 100644
index 000000000000..e3048bfc11fb
--- /dev/null
+++ b/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-plugins/wmswallow/wmswallow-0.6.1-r1.ebuild,v 1.1 2015/01/20 16:34:32 voyageur Exp $
+
+EAPI=5
+inherit toolchain-funcs
+
+DESCRIPTION="A dock applet to make any application dockable"
+HOMEPAGE="http://burse.uni-hamburg.de/~friedel/software/wmswallow.html"
+SRC_URI="http://burse.uni-hamburg.de/~friedel/software/wmswallow/${PN}.tar.Z"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-proto/xproto"
+
+S=${WORKDIR}/wmswallow
+
+src_prepare() {
+ sed -e "s:\${OBJS} -o:\${OBJS} \${LDFLAGS} -o:" \
+ -e "/LIBS/s/-lXext/-lX11 \0/"\
+ -i Makefile || die
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" CFLAGS="${CFLAGS}" LDFLAGS="${LDFLAGS}" xfree
+}
+
+src_install() {
+ dobin wmswallow
+ dodoc CHANGELOG README todo
+}