summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-12 13:37:40 +0000
committerChí-Thanh Christopher Nguyễn <chithanh@gentoo.org>2012-07-12 13:37:40 +0000
commit209443640059d3e2c90bf14423044552d4870c83 (patch)
tree6da81df2d2ae3265c68b1688e1018ed31b9c547e /x11-proto
parentMask x11-proto/glproto-1.4.16 too (diff)
downloadgentoo-2-209443640059d3e2c90bf14423044552d4870c83.tar.gz
gentoo-2-209443640059d3e2c90bf14423044552d4870c83.tar.bz2
gentoo-2-209443640059d3e2c90bf14423044552d4870c83.zip
Version bump.
(Portage version: 2.2.0_alpha115/cvs/Linux x86_64)
Diffstat (limited to 'x11-proto')
-rw-r--r--x11-proto/glproto/ChangeLog9
-rw-r--r--x11-proto/glproto/glproto-1.4.16.ebuild38
2 files changed, 45 insertions, 2 deletions
diff --git a/x11-proto/glproto/ChangeLog b/x11-proto/glproto/ChangeLog
index 7aa34cb4e3e2..2579ad059ef9 100644
--- a/x11-proto/glproto/ChangeLog
+++ b/x11-proto/glproto/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-proto/glproto
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.101 2012/07/11 20:11:36 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/ChangeLog,v 1.102 2012/07/12 13:37:40 chithanh Exp $
+
+*glproto-1.4.16 (12 Jul 2012)
+
+ 12 Jul 2012; Chí-Thanh Christopher Nguyễn <chithanh@gentoo.org>
+ +glproto-1.4.16.ebuild:
+ Version bump.
11 Jul 2012; Brent Baude <ranger@gentoo.org> glproto-1.4.15.ebuild:
Marking glproto-1.4.15 ppc64 stable for bug 419473
@@ -371,4 +377,3 @@
08 Aug 2005; Donnie Berkholz <spyderous@gentoo.org>; +glproto-1.4.ebuild:
Initial commit for modular X
-
diff --git a/x11-proto/glproto/glproto-1.4.16.ebuild b/x11-proto/glproto/glproto-1.4.16.ebuild
new file mode 100644
index 000000000000..c0f522b67a8a
--- /dev/null
+++ b/x11-proto/glproto/glproto-1.4.16.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-proto/glproto/glproto-1.4.16.ebuild,v 1.1 2012/07/12 13:37:40 chithanh Exp $
+
+EAPI=4
+inherit xorg-2
+DESCRIPTION="X.Org GL protocol headers"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x64-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x64-solaris ~x86-solaris"
+LICENSE="SGI-B-2.0"
+IUSE=""
+
+RDEPEND=">=app-admin/eselect-opengl-1.2.6"
+DEPEND=""
+
+src_install() {
+ xorg-2_src_install
+ dynamic_libgl_install
+}
+
+pkg_postinst() {
+ xorg-2_pkg_postinst
+ eselect opengl set --ignore-missing --use-old xorg-x11
+}
+
+dynamic_libgl_install() {
+ # next section is to setup the dynamic libGL stuff
+ ebegin "Moving GL files for dynamic switching"
+ local gldir=/usr/$(get_libdir)/opengl/xorg-x11/include/GL
+ dodir ${gldir}
+ local x=""
+ # glext.h added for #54984
+ for x in "${ED}"/usr/include/GL/{glxtokens.h,glxmd.h,glxproto.h}; do
+ if [[ -f ${x} || -L ${x} ]]; then
+ mv -f "${x}" "${ED}"${gldir}
+ fi
+ done
+ eend 0
+}