summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-02-25 14:09:55 +0000
committerJustin Lecher <jlec@gentoo.org>2013-02-25 14:09:55 +0000
commit0879e2b2ba4b2ffac61a2d6c7b1c87e463d46aed (patch)
tree8f1599ca09195c5d0883ef64d82245b2cdc041f1 /x11-terms
parentapp-text/multitail: Version Bump (diff)
downloadgentoo-2-0879e2b2ba4b2ffac61a2d6c7b1c87e463d46aed.tar.gz
gentoo-2-0879e2b2ba4b2ffac61a2d6c7b1c87e463d46aed.tar.bz2
gentoo-2-0879e2b2ba4b2ffac61a2d6c7b1c87e463d46aed.zip
x11-terms/terminator: Move to new python eclass
(Portage version: 2.2.0_alpha163/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminator/ChangeLog10
-rw-r--r--x11-terms/terminator/metadata.xml14
-rw-r--r--x11-terms/terminator/terminator-0.96-r2.ebuild48
3 files changed, 63 insertions, 9 deletions
diff --git a/x11-terms/terminator/ChangeLog b/x11-terms/terminator/ChangeLog
index e00c0d2454f8..351a7145aac8 100644
--- a/x11-terms/terminator/ChangeLog
+++ b/x11-terms/terminator/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-terms/terminator
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/terminator/ChangeLog,v 1.26 2012/10/19 07:13:01 jlec Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/terminator/ChangeLog,v 1.27 2013/02/25 14:09:55 jlec Exp $
+
+*terminator-0.96-r2 (25 Feb 2013)
+
+ 25 Feb 2013; Justin Lecher <jlec@gentoo.org> +terminator-0.96-r2.ebuild,
+ metadata.xml:
+ Move to new python eclass
19 Oct 2012; Justin Lecher <jlec@gentoo.org> terminator-0.96-r1.ebuild:
Enable the notification support by default
diff --git a/x11-terms/terminator/metadata.xml b/x11-terms/terminator/metadata.xml
index 3c4e06613ac2..a2b59963a3c9 100644
--- a/x11-terms/terminator/metadata.xml
+++ b/x11-terms/terminator/metadata.xml
@@ -1,17 +1,17 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <maintainer>
- <email>jlec@gentoo.org</email>
- </maintainer>
- <longdescription>
+ <maintainer>
+ <email>jlec@gentoo.org</email>
+ </maintainer>
+ <longdescription>
Much of the behaviour of Terminator is based on GNOME Terminal, and
we are adding more features from that as time goes by, but we also
want to extend out in different directions with useful features for
sysadmins and other users. If you have any suggestions, please file
wishlist bugs! (see below for the address)
</longdescription>
- <use>
- <flag name="libnotify">Enables desktop notifications via<pkg>dev-python/notify-python</pkg></flag>
- </use>
+ <use>
+ <flag name="libnotify">Enables desktop notifications via<pkg>dev-python/notify-python</pkg></flag>
+ </use>
</pkgmetadata>
diff --git a/x11-terms/terminator/terminator-0.96-r2.ebuild b/x11-terms/terminator/terminator-0.96-r2.ebuild
new file mode 100644
index 000000000000..2d89f162ad57
--- /dev/null
+++ b/x11-terms/terminator/terminator-0.96-r2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/terminator/terminator-0.96-r2.ebuild,v 1.1 2013/02/25 14:09:55 jlec Exp $
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_6,2_7} )
+DISTUTILS_NO_PARALLEL_BUILD=true
+
+inherit gnome2 distutils-r1
+
+DESCRIPTION="Multiple GNOME terminals in one window"
+HOMEPAGE="http://www.tenshu.net/p/terminator.html"
+SRC_URI="http://launchpad.net/${PN}/trunk/${PV}/+download/${PN}_${PV}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="dbus gnome +libnotify"
+
+RDEPEND="
+ dev-libs/keybinder:0[python]
+ x11-libs/vte:0[python]
+ dbus? ( sys-apps/dbus )
+ gnome? (
+ dev-python/gconf-python
+ dev-python/libgnome-python
+ dev-python/pygobject:2[${PYTHON_USEDEP}]
+ dev-python/pygtk:2[${PYTHON_USEDEP}]
+ )
+ libnotify? ( dev-python/notify-python[${PYTHON_USEDEP}] )"
+DEPEND="dev-util/intltool"
+
+python_prepare_all() {
+ local PATCHES=(
+ "${FILESDIR}"/0.90-without-icon-cache.patch
+ "${FILESDIR}"/0.94-session.patch
+ )
+ distutils-r1_python_prepare_all
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+}
+
+pkg_postrm() {
+ gnome2_pkg_postrm
+}