summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Nazaroff <naz@gentoo.org>2002-06-06 19:34:39 +0000
committerMichael Nazaroff <naz@gentoo.org>2002-06-06 19:34:39 +0000
commit22d043151abc19c27fa5f29402579b0e2d5adff6 (patch)
treec8e86a1adb4ef911378d3d4fed9a922760a51058 /x11-terms
parentxfs rc-script update (diff)
downloadgentoo-2-22d043151abc19c27fa5f29402579b0e2d5adff6.tar.gz
gentoo-2-22d043151abc19c27fa5f29402579b0e2d5adff6.tar.bz2
gentoo-2-22d043151abc19c27fa5f29402579b0e2d5adff6.zip
Added small patch to rxvt
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt/ChangeLog10
-rw-r--r--x11-terms/rxvt/files/digest-rxvt-2.7.8-r31
-rw-r--r--x11-terms/rxvt/files/rxvt-2.7.8-azz4.diff135
-rw-r--r--x11-terms/rxvt/rxvt-2.7.8-r3.ebuild53
4 files changed, 198 insertions, 1 deletions
diff --git a/x11-terms/rxvt/ChangeLog b/x11-terms/rxvt/ChangeLog
index 3aed661ae785..86736c1aa781 100644
--- a/x11-terms/rxvt/ChangeLog
+++ b/x11-terms/rxvt/ChangeLog
@@ -1,7 +1,15 @@
# ChangeLog for x11-terms/rxvt
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/ChangeLog,v 1.4 2002/05/04 04:00:26 seemant Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/ChangeLog,v 1.5 2002/06/06 19:34:39 naz Exp $
+*rxvt-2.7.8-r3 (3 May 2002)
+
+ 6 Jun 2002; Michael Nazaroff <naz@gentoo.org> rxvt-2.7.8-r3.ebuild :
+
+ Add a patch to rxvt that add a borderless option and fix's a small memory
+ leak. Requires motif though so I set the patch as use variable against motif
+ for those people that don't want the patch.
+
*rxvt-2.7.8-r2 (3 May 2002)
3 May 2002; Seemant Kulleen <seemant@gentoo.org> rxvt-2.7.8-r2.ebuild
diff --git a/x11-terms/rxvt/files/digest-rxvt-2.7.8-r3 b/x11-terms/rxvt/files/digest-rxvt-2.7.8-r3
new file mode 100644
index 000000000000..d71a447c4606
--- /dev/null
+++ b/x11-terms/rxvt/files/digest-rxvt-2.7.8-r3
@@ -0,0 +1 @@
+MD5 e91b733b4f480f218db4b3b331ea42f6 rxvt-2.7.8.tar.gz 488213
diff --git a/x11-terms/rxvt/files/rxvt-2.7.8-azz4.diff b/x11-terms/rxvt/files/rxvt-2.7.8-azz4.diff
new file mode 100644
index 000000000000..09bc45805107
--- /dev/null
+++ b/x11-terms/rxvt/files/rxvt-2.7.8-azz4.diff
@@ -0,0 +1,135 @@
+diff -Naur rxvt-2.7.8/AZZ-ChangeLog rxvt-2.7.8-azz4/AZZ-ChangeLog
+--- rxvt-2.7.8/AZZ-ChangeLog Thu Jan 1 01:00:00 1970
++++ rxvt-2.7.8-azz4/AZZ-ChangeLog Mon May 20 23:10:36 2002
+@@ -0,0 +1,7 @@
++- Modified to support borderlessness with -nb and override-redirect with
++ -or (or resources borderless and overrideRedirect).
++- Modified to allow an arbitrary command to be run instead of the bell
++ with -bc.
++- Fixed buffer overflow in command.c (not that you should install this suid
++ root anyway)
++
+diff -Naur rxvt-2.7.8/src/command.c rxvt-2.7.8-azz4/src/command.c
+--- rxvt-2.7.8/src/command.c Thu Nov 29 06:53:58 2001
++++ rxvt-2.7.8-azz4/src/command.c Mon May 20 23:11:21 2002
+@@ -2930,7 +2930,7 @@
+ unsigned char buf[256];
+
+ va_start(arg_ptr, fmt);
+- vsprintf((char *)buf, fmt, arg_ptr);
++ vsnprintf((char *)buf, sizeof buf, fmt, arg_ptr);
+ va_end(arg_ptr);
+ rxvt_tt_write(r, buf, (unsigned int)STRLEN(buf));
+ }
+diff -Naur rxvt-2.7.8/src/init.c rxvt-2.7.8-azz4/src/init.c
+--- rxvt-2.7.8/src/init.c Thu Nov 29 06:38:07 2001
++++ rxvt-2.7.8-azz4/src/init.c Mon May 20 23:22:45 2002
+@@ -34,6 +34,7 @@
+ #include "../config.h" /* NECESSARY */
+ #include "rxvt.h" /* NECESSARY */
+ #include "init.h"
++#include <Xm/MwmUtil.h>
+
+ #include <signal.h>
+
+@@ -917,6 +918,24 @@
+ r->PixColors[Color_border],
+ r->PixColors[Color_fg]);
+ #endif
++ if (r->Options & Opt_borderless) {
++ Atom mwmatom;
++ MotifWmHints hints;
++
++ mwmatom = XInternAtom(r->Xdisplay, _XA_MOTIF_WM_HINTS, FALSE);
++ hints.flags = MWM_HINTS_DECORATIONS;
++ hints.decorations = 0;
++ XChangeProperty(r->Xdisplay, r->TermWin.parent[0], mwmatom, mwmatom,
++ 32, PropModeReplace, (unsigned char *)&hints,
++ sizeof(MotifWmHints)/sizeof(long));
++ }
++ if (r->Options & Opt_overrideredirect) {
++ XSetWindowAttributes attrib;
++
++ attrib.override_redirect = True;
++ XChangeWindowAttributes(r->Xdisplay, r->TermWin.parent[0],
++ CWOverrideRedirect, &attrib);
++ }
+ rxvt_xterm_seq(r, XTerm_title, r->h->rs[Rs_title], CHAR_ST);
+ rxvt_xterm_seq(r, XTerm_iconName, r->h->rs[Rs_iconName], CHAR_ST);
+
+@@ -1079,7 +1098,7 @@
+ * We don't want them, we don't need them.
+ */
+ for (i = 0; i < r->num_fds; i++) {
+- if (i == STDERR_FILENO || i == cfd || i == r->tty_fd
++ if (i == STDERR_FILENO || i == STDOUT_FILENO || i == cfd || i == r->tty_fd
+ #ifdef __sgi /* Alex Coventry says we need 4 & 7 too */
+ || i == 4 || i == 7
+ #endif
+diff -Naur rxvt-2.7.8/src/rxvt.h rxvt-2.7.8-azz4/src/rxvt.h
+--- rxvt-2.7.8/src/rxvt.h Thu Nov 29 06:38:07 2001
++++ rxvt-2.7.8-azz4/src/rxvt.h Mon May 20 23:30:20 2002
+@@ -556,6 +556,9 @@
+ Rs_modifier,
+ Rs_answerbackstring,
+ Rs_tripleclickwords,
++ Rs_borderless,
++ Rs_overrideRedirect,
++ Rs_bellCommand,
+ NUM_RESOURCES
+ } ;
+
+diff -Naur rxvt-2.7.8/src/rxvtlib.h.in rxvt-2.7.8-azz4/src/rxvtlib.h.in
+--- rxvt-2.7.8/src/rxvtlib.h.in Tue Nov 27 12:51:15 2001
++++ rxvt-2.7.8-azz4/src/rxvtlib.h.in Mon May 20 23:15:31 2002
+@@ -189,6 +189,8 @@
+ #define Opt_tripleclickwords (1LU<<16)
+ #define Opt_scrollWithBuffer (1LU<<17)
+ #define Opt_jumpScroll (1LU<<18)
++#define Opt_borderless (1LU<<19)
++#define Opt_overrideredirect (1LU<<20)
+ /* place holder used for parsing command-line options */
+ #define Opt_Reverse (1LU<<30)
+ #define Opt_Boolean (1LU<<31)
+diff -Naur rxvt-2.7.8/src/screen.c rxvt-2.7.8-azz4/src/screen.c
+--- rxvt-2.7.8/src/screen.c Wed Nov 28 11:58:12 2001
++++ rxvt-2.7.8-azz4/src/screen.c Mon May 20 23:28:19 2002
+@@ -29,6 +29,7 @@
+ #include "screen.intpro" /* PROTOS for internal routines */
+
+ #include <X11/Xmd.h> /* get the typedef for CARD32 */
++#include <stdlib.h>
+
+ /* ------------------------------------------------------------------------- */
+ #ifdef MULTICHAR_SET
+@@ -1829,6 +1830,9 @@
+ void
+ rxvt_scr_bell(rxvt_t *r)
+ {
++ if (r->h->rs[Rs_bellCommand]) {
++ system(r->h->rs[Rs_bellCommand]);
++ } else {
+ #ifndef NO_BELL
+ # ifndef NO_MAPALERT
+ # ifdef MAPALERT_OPTION
+@@ -1842,6 +1846,7 @@
+ } else
+ XBell(r->Xdisplay, 0);
+ #endif
++ }
+ }
+
+ /* ------------------------------------------------------------------------- */
+diff -Naur rxvt-2.7.8/src/xdefaults.c rxvt-2.7.8-azz4/src/xdefaults.c
+--- rxvt-2.7.8/src/xdefaults.c Thu Nov 29 07:22:51 2001
++++ rxvt-2.7.8-azz4/src/xdefaults.c Mon May 20 23:29:42 2002
+@@ -108,6 +108,9 @@
+ "scroll-on-tty-output inhibit"),
+ BOOL(Rs_scrollTtyKeypress, "scrollTtyKeypress", "sk", Opt_scrollTtyKeypress,
+ "scroll-on-keypress"),
++ BOOL(Rs_borderless, "borderless", "nb", Opt_borderless, "use MWM hints to remove the window border"),
++ BOOL(Rs_overrideRedirect, "overrideRedirect", "or", Opt_overrideredirect, "set the override_redirect flag"),
++ STRG(Rs_bellCommand, "bellCommand", "bc", "string", "command to execute instead of beeping"),
+ BOOL(Rs_scrollWithBuffer, "scrollWithBuffer", "sw", Opt_scrollWithBuffer,
+ "scroll-with-buffer"),
+ #ifdef TRANSPARENT
diff --git a/x11-terms/rxvt/rxvt-2.7.8-r3.ebuild b/x11-terms/rxvt/rxvt-2.7.8-r3.ebuild
new file mode 100644
index 000000000000..7adc111fd393
--- /dev/null
+++ b/x11-terms/rxvt/rxvt-2.7.8-r3.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt/rxvt-2.7.8-r3.ebuild,v 1.1 2002/06/06 19:34:39 naz Exp $
+
+S=${WORKDIR}/${P}
+DESCRIPTION="rxvt -- nice small x11 terminal"
+SRC_URI="ftp://ftp.rxvt.org/pub/rxvt/${P}.tar.gz"
+
+HOMEPAGE=http://www.rxvt.org
+
+DEPEND="virtual/glibc
+ virtual/x11
+ motif? ( x11-libs/openmotif )"
+
+
+src_unpack() {
+
+ unpack ${A}
+ cd ${S}
+
+
+ [ "`use motif`" ] && patch -p1 < ${FILESDIR}/rxvt-2.7.8-azz4.diff
+}
+
+src_compile() {
+ ./configure \
+ --host=${CHOST} \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --enable-rxvt-scroll \
+ --enable-transparency \
+ --enable-xpm-background \
+ --enable-utmp \
+ --enable-wtmp \
+ --enable-mousewheel \
+ --enable-slipwheeling \
+ --enable-smart-resize \
+ --enable-menubar \
+ --enable-shared \
+ --enable-keepscrolling || die
+
+ emake || die
+}
+
+src_install() {
+
+ einstall
+
+ cd ${S}/doc
+ dodoc README* *.txt BUGS FAQ
+ dohtml *.html
+}