summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2012-01-07 12:31:48 +0000
committerAlex Alexander <wired@gentoo.org>2012-01-07 12:31:48 +0000
commit4be3e17978a726920d3dfe3087065ab624d137e7 (patch)
tree3e9b13071400ec02e620887bdb8165e254c82006 /x11-terms
parentRemove .la file if not static-libs (diff)
downloadgentoo-2-4be3e17978a726920d3dfe3087065ab624d137e7.tar.gz
gentoo-2-4be3e17978a726920d3dfe3087065ab624d137e7.tar.bz2
gentoo-2-4be3e17978a726920d3dfe3087065ab624d137e7.zip
made the clear patch optional (buffer-on-clear USE flag) because it seems to break some prompts - bug #397829
(Portage version: 2.2.0_alpha84/cvs/Linux x86_64)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/rxvt-unicode/ChangeLog7
-rw-r--r--x11-terms/rxvt-unicode/metadata.xml2
-rw-r--r--x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild17
3 files changed, 20 insertions, 6 deletions
diff --git a/x11-terms/rxvt-unicode/ChangeLog b/x11-terms/rxvt-unicode/ChangeLog
index 20d4f0951aa1..8fb6aa6c9a9b 100644
--- a/x11-terms/rxvt-unicode/ChangeLog
+++ b/x11-terms/rxvt-unicode/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/rxvt-unicode
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.199 2012/01/04 18:02:50 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/ChangeLog,v 1.200 2012/01/07 12:31:48 wired Exp $
+
+ 07 Jan 2012; Alex Alexander <wired@gentoo.org> rxvt-unicode-9.14.ebuild,
+ metadata.xml:
+ made the clear patch optional (buffer-on-clear USE flag) because it seems to
+ break some prompts - bug #397829
04 Jan 2012; Pawel Hajdan jr <phajdan.jr@gentoo.org>
rxvt-unicode-9.12-r1.ebuild:
diff --git a/x11-terms/rxvt-unicode/metadata.xml b/x11-terms/rxvt-unicode/metadata.xml
index ba4ea3c8b296..b59615812233 100644
--- a/x11-terms/rxvt-unicode/metadata.xml
+++ b/x11-terms/rxvt-unicode/metadata.xml
@@ -15,6 +15,8 @@
<pkg>media-libs/libafterimage</pkg> (deprecated in 9.14)</flag>
<flag name='alt-font-width'>Calculate the font width using a different method</flag>
<flag name='blink'>Enable blinking text</flag>
+<flag name='buffer-on-clear'>Store visible output to history buffer when clearing the screen with ctrl-l.
+ Read https://bbs.archlinux.org/viewtopic.php?id=129302</flag>
<flag name='fading-colors'>Enable colors fading when off focus</flag>
<flag name='focused-urgency'>Enable the urgent flag when a terminal window is focused</flag>
<flag name='font-styles'>Enable support for bold and italic fonts</flag>
diff --git a/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild b/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild
index f68202870964..63d050ca7da4 100644
--- a/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild
+++ b/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild,v 1.3 2012/01/02 13:25:59 wired Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/rxvt-unicode/rxvt-unicode-9.14.ebuild,v 1.4 2012/01/07 12:31:48 wired Exp $
EAPI="4"
@@ -14,8 +14,8 @@ LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris"
IUSE="
- 256-color alt-font-width afterimage blink +focused-urgency fading-colors
- +font-styles iso14755 +mousewheel +perl pixbuf secondary-wheel
+ 256-color alt-font-width afterimage blink buffer-on-clear +focused-urgency
+ fading-colors +font-styles iso14755 +mousewheel +perl pixbuf secondary-wheel
startup-notification truetype unicode3 +vanilla wcwidth
"
@@ -37,7 +37,7 @@ DEPEND="
x11-proto/xproto
"
-REQUIRED_USE="vanilla? ( !alt-font-width focused-urgency !secondary-wheel !wcwidth )"
+REQUIRED_USE="vanilla? ( !alt-font-width !buffer-on-clear focused-urgency !secondary-wheel !wcwidth )"
src_prepare() {
# fix for prefix not installing properly
@@ -66,7 +66,7 @@ src_prepare() {
use secondary-wheel && epatch "${FILESDIR}"/${P}-secondary-wheel.patch
# ctrl-l buffer fix
- epatch "${FILESDIR}"/${P}-clear.patch
+ use buffer-on-clear && epatch "${FILESDIR}"/${P}-clear.patch
use alt-font-width && epatch "${FILESDIR}"/${PN}-9.06-font-width.patch
fi
@@ -114,6 +114,13 @@ src_install() {
}
pkg_postinst() {
+ if use buffer-on-clear; then
+ ewarn "You have enabled the buffer-on-clear USE flag."
+ ewarn "Please note that, although this works well for most prompts,"
+ ewarn "there have been cases with fancy prompts, like bug #397829,"
+ ewarn "where it caused issues. Proceed with caution."
+ ewarn " (keep this terminal open until you make sure it works)"
+ fi
if use secondary-wheel; then
elog "You have enabled the secondary-wheel USE flag."
elog "This allows you to scroll in secondary screens"