summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKrzysztof Pawlik <nelchael@gentoo.org>2006-06-28 12:15:30 +0000
committerKrzysztof Pawlik <nelchael@gentoo.org>2006-06-28 12:15:30 +0000
commitdce461f1ced8caf66d1f854e0c3b33be72c1b2c0 (patch)
tree0dc0dac2fdb137925cd0623116b9f4b2f68f80b9 /x11-terms
parentVersion bump. (diff)
downloadgentoo-2-dce461f1ced8caf66d1f854e0c3b33be72c1b2c0.tar.gz
gentoo-2-dce461f1ced8caf66d1f854e0c3b33be72c1b2c0.tar.bz2
gentoo-2-dce461f1ced8caf66d1f854e0c3b33be72c1b2c0.zip
Version bump, see bug #138144.
(Portage version: 2.1.1_pre1-r5)
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/mrxvt/ChangeLog7
-rw-r--r--x11-terms/mrxvt/files/digest-mrxvt-0.5.13
-rw-r--r--x11-terms/mrxvt/mrxvt-0.5.1.ebuild106
3 files changed, 115 insertions, 1 deletions
diff --git a/x11-terms/mrxvt/ChangeLog b/x11-terms/mrxvt/ChangeLog
index 504e57b73972..c6a5db664df1 100644
--- a/x11-terms/mrxvt/ChangeLog
+++ b/x11-terms/mrxvt/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-terms/mrxvt
# Copyright 1999-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/ChangeLog,v 1.34 2006/04/16 22:33:53 hansmi Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/ChangeLog,v 1.35 2006/06/28 12:15:30 nelchael Exp $
+
+*mrxvt-0.5.1 (28 Jun 2006)
+
+ 28 Jun 2006; Krzysiek Pawlik <nelchael@gentoo.org> +mrxvt-0.5.1.ebuild:
+ Version bump, see bug #138144.
16 Apr 2006; Michael Hanselmann <hansmi@gentoo.org> mrxvt-0.4.2.ebuild:
Stable on ppc.
diff --git a/x11-terms/mrxvt/files/digest-mrxvt-0.5.1 b/x11-terms/mrxvt/files/digest-mrxvt-0.5.1
new file mode 100644
index 000000000000..c6ff9a21e89b
--- /dev/null
+++ b/x11-terms/mrxvt/files/digest-mrxvt-0.5.1
@@ -0,0 +1,3 @@
+MD5 68d19a89978d39b770b89aca1259b0f3 mrxvt-0.5.1.tar.gz 711657
+RMD160 fc133e9ae6835c5e0881909e77c6298128a9779c mrxvt-0.5.1.tar.gz 711657
+SHA256 f33bbef378a59d4a209650d57822fdc4b4147a51200f0b30484509749c119d71 mrxvt-0.5.1.tar.gz 711657
diff --git a/x11-terms/mrxvt/mrxvt-0.5.1.ebuild b/x11-terms/mrxvt/mrxvt-0.5.1.ebuild
new file mode 100644
index 000000000000..a80f797ab40b
--- /dev/null
+++ b/x11-terms/mrxvt/mrxvt-0.5.1.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-terms/mrxvt/mrxvt-0.5.1.ebuild,v 1.1 2006/06/28 12:15:30 nelchael Exp $
+
+inherit eutils
+
+IUSE="debug png jpeg session truetype menubar"
+
+DESCRIPTION="Multi-tabbed rxvt clone with XFT, transparent background and CJK support"
+HOMEPAGE="http://materm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/materm/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc-macos ~amd64 ~ppc ~alpha"
+
+RDEPEND="png? ( media-libs/libpng )
+ jpeg? ( media-libs/jpeg )
+ truetype? ( virtual/xft
+ media-libs/fontconfig
+ media-libs/freetype )
+ || ( (
+ x11-libs/libX11
+ x11-libs/libXt
+ x11-libs/libXpm
+ x11-libs/libXrender )
+ virtual/x11 )"
+
+DEPEND="${RDEPEND}
+ || ( x11-proto/xproto virtual/x11 )"
+
+src_compile() {
+
+ local myconf
+
+ # if you want to pass any other flags, use EXTRA_ECONF.
+ if use linguas_el ; then
+ myconf="${myconf} --enable-greek"
+ fi
+ if use linguas_ja ; then
+ # --with-encoding=sjis
+ myconf="${myconf} --enable-kanji --with-encoding=eucj"
+ fi
+ if use linguas_ko ; then
+ myconf="${myconf} --enable-kr --with-encoding=kr"
+ fi
+ if use linguas_th ; then
+ myconf="${myconf} --enable-thai"
+ fi
+ if use linguas_zh_CN ; then
+ # --with-encoding=gbk
+ myconf="${myconf} --enable-gb --with-encoding=gb"
+ fi
+ if use linguas_zh_TW ; then
+ myconf="${myconf} --enable-big5 --with-encoding=big5"
+ fi
+
+ # 2006-03-13 gi1242: mrxvt works best with TERM=rxvt AND correctly set
+ # termcap / terminfo entries. If the rxvt termcap / terminfo entries are
+ # messed up then then it's better to set TERM=xterm.
+ #
+ # Provide support for this by setting the or RXVT_TERM environment variables
+ # before emerging, as done in the rxvt ebuild.
+
+ if [[ -n ${RXVT_TERM} ]]; then
+ myconf="${myconf} --with-term=${RXVT_TERM}"
+ fi
+
+ econf \
+ --enable-everything \
+ $(use_enable debug) \
+ $(use_enable png) \
+ $(use_enable jpeg) \
+ $(use_enable session sessionmgr) \
+ $(use_enable truetype xft) \
+ $(use_enable menubar) \
+ ${myconf} || die
+
+ emake || die
+
+}
+
+src_install() {
+
+ make DESTDIR=${D} docdir=/usr/share/doc/${PF} install || die
+ dodoc AUTHORS CREDITS ChangeLog FAQ NEWS README* TODO
+
+}
+
+pkg_postinst() {
+
+ if [[ -z $RXVT_TERM ]]; then
+ einfo
+ einfo "If you experience problems with curses programs, then this is"
+ einfo "most likely because of incorrectly set termcap / terminfo"
+ einfo "entries. If you are unsure how to fix them, then you can try"
+ einfo "setting TERM=xterm."
+ einfo
+ einfo "To emerge mrxvt with TERM=xterm by default, set the RXVT_TERM"
+ einfo "environment variable to 'xterm', or your desired default"
+ einfo "terminal name. Alternately you can put 'Mrxvt.termName: xterm'"
+ einfo "in your ~/.mrxvtrc, or /etc/mrxvt/mrxvtrc."
+ einfo
+ fi
+
+}