summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-03-02 13:26:08 +0000
committerBen de Groot <yngwin@gentoo.org>2009-03-02 13:26:08 +0000
commita2b07dae458ab6e66a8a2bc38e5c61fa0318e877 (patch)
treed686a4e540007999b7de66ebe4c3e1cf4f9756b7 /x11-themes/gtk-engines-qtcurve
parent~mips keyworded, bug #258611. (diff)
downloadgentoo-2-a2b07dae458ab6e66a8a2bc38e5c61fa0318e877.tar.gz
gentoo-2-a2b07dae458ab6e66a8a2bc38e5c61fa0318e877.tar.bz2
gentoo-2-a2b07dae458ab6e66a8a2bc38e5c61fa0318e877.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gtk-engines-qtcurve')
-rw-r--r--x11-themes/gtk-engines-qtcurve/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.61.4.ebuild35
2 files changed, 42 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/ChangeLog b/x11-themes/gtk-engines-qtcurve/ChangeLog
index 5f3b8ee8636f..cb5969580abf 100644
--- a/x11-themes/gtk-engines-qtcurve/ChangeLog
+++ b/x11-themes/gtk-engines-qtcurve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-qtcurve
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.48 2009/02/25 17:35:14 josejx Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.49 2009/03/02 13:26:08 yngwin Exp $
+
+*gtk-engines-qtcurve-0.61.4 (02 Mar 2009)
+
+ 02 Mar 2009; Ben de Groot <yngwin@gentoo.org>
+ +gtk-engines-qtcurve-0.61.4.ebuild:
+ Version bump
25 Feb 2009; Joseph Jezak <josejx@gentoo.org>
gtk-engines-qtcurve-0.59.7.ebuild, gtk-engines-qtcurve-0.61.2.ebuild:
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.61.4.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.61.4.ebuild
new file mode 100644
index 000000000000..d799d0fcaa30
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.61.4.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.61.4.ebuild,v 1.1 2009/03/02 13:26:08 yngwin Exp $
+
+EAPI=1
+inherit eutils cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozilla firefox3"
+
+RDEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ firefox3? ( || ( >=www-client/mozilla-firefox-3.0
+ >=www-client/mozilla-firefox-bin-3.0 ) )"
+DEPEND="x11-libs/gtk+:2
+ x11-libs/cairo
+ >=dev-util/cmake-2.4"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_compile() {
+ local mycmakeargs=""
+ use mozilla && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_MODIFY_MOZILLA_USER_JS=true"
+ use firefox3 && mycmakeargs="-DQTC_NEW_MOZILLA=true -DQTC_MODIFY_MOZILLA=true -DQTC_MODIFY_MOZILLA_USER_JS=true"
+ cmake-utils_src_compile
+}