summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2008-07-19 22:06:20 +0000
committerBen de Groot <yngwin@gentoo.org>2008-07-19 22:06:20 +0000
commitc17901e60ee0f1028a4d4e9dced5903e09e17864 (patch)
treeb6162a959104fc0b34374e6cf91f490f9283c060 /x11-themes/gtk-engines-qtcurve
parentSecond release candidate, bugfixes and enables SOCKS5 and HTTP/1.1 proxy supp... (diff)
downloadgentoo-2-c17901e60ee0f1028a4d4e9dced5903e09e17864.tar.gz
gentoo-2-c17901e60ee0f1028a4d4e9dced5903e09e17864.tar.bz2
gentoo-2-c17901e60ee0f1028a4d4e9dced5903e09e17864.zip
gtk-engines-qtcurve version bump
(Portage version: 2.2_rc1/cvs/Linux 2.6.25-hh7 i686)
Diffstat (limited to 'x11-themes/gtk-engines-qtcurve')
-rw-r--r--x11-themes/gtk-engines-qtcurve/ChangeLog8
-rw-r--r--x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.6.ebuild30
2 files changed, 37 insertions, 1 deletions
diff --git a/x11-themes/gtk-engines-qtcurve/ChangeLog b/x11-themes/gtk-engines-qtcurve/ChangeLog
index 598a356cf4be..f62e63889eaf 100644
--- a/x11-themes/gtk-engines-qtcurve/ChangeLog
+++ b/x11-themes/gtk-engines-qtcurve/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines-qtcurve
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.36 2008/07/12 20:13:01 yngwin Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/ChangeLog,v 1.37 2008/07/19 22:06:20 yngwin Exp $
+
+*gtk-engines-qtcurve-0.59.6 (19 Jul 2008)
+
+ 19 Jul 2008; Ben de Groot <yngwin@gentoo.org>
+ +gtk-engines-qtcurve-0.59.6.ebuild:
+ Version bump
12 Jul 2008; Ben de Groot <yngwin@gentoo.org> -files/build.patch,
-gtk-engines-qtcurve-0.57.1.ebuild, -gtk-engines-qtcurve-0.59.2.ebuild,
diff --git a/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.6.ebuild b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.6.ebuild
new file mode 100644
index 000000000000..2af6e00b13ab
--- /dev/null
+++ b/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.6.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtcurve/gtk-engines-qtcurve-0.59.6.ebuild,v 1.1 2008/07/19 22:06:20 yngwin Exp $
+
+inherit eutils cmake-utils
+
+MY_P=${P/gtk-engines-qtcurve/QtCurve-Gtk2}
+
+DESCRIPTION="A set of widget styles for GTK2 based apps, also available for KDE3 and Qt4"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc64 ~sparc ~x86"
+IUSE="mozilla"
+
+RDEPEND=">=x11-libs/gtk+-2
+ x11-libs/cairo"
+DEPEND="${RDEPEND}
+ >=dev-util/cmake-2.4"
+
+S=${WORKDIR}/${MY_P}
+DOCS="ChangeLog README TODO"
+
+src_compile() {
+ local mycmakeargs=""
+ use mozilla && mycmakeargs="-DQTC_MODIFY_MOZILLA=true -DQTC_MODIFY_MOZILLA_USER_JS=true"
+ cmake-utils_src_compile
+}