summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2010-01-05 11:01:29 +0000
committerMart Raudsepp <leio@gentoo.org>2010-01-05 11:01:29 +0000
commit894558c144109c148c6845b73d70bbde44a425fa (patch)
treeeda93eed83ccf301e18421c57186f3bb9d5998e5 /x11-themes/gtk-engines
parentVersion bump, remove some old versions (diff)
downloadgentoo-2-894558c144109c148c6845b73d70bbde44a425fa.tar.gz
gentoo-2-894558c144109c148c6845b73d70bbde44a425fa.tar.bz2
gentoo-2-894558c144109c148c6845b73d70bbde44a425fa.zip
Version bump. Fixes a potential infinite loop with buggy clearlooks themes, translation updates
(Portage version: 2.2_rc61/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/gtk-engines')
-rw-r--r--x11-themes/gtk-engines/ChangeLog10
-rw-r--r--x11-themes/gtk-engines/gtk-engines-2.18.5.ebuild29
2 files changed, 37 insertions, 2 deletions
diff --git a/x11-themes/gtk-engines/ChangeLog b/x11-themes/gtk-engines/ChangeLog
index f26cd80ccc83..70e2c26b7c46 100644
--- a/x11-themes/gtk-engines/ChangeLog
+++ b/x11-themes/gtk-engines/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gtk-engines
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/ChangeLog,v 1.156 2009/12/03 16:56:45 ranger Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/ChangeLog,v 1.157 2010/01/05 11:01:29 leio Exp $
+
+*gtk-engines-2.18.5 (05 Jan 2010)
+
+ 05 Jan 2010; Mart Raudsepp <leio@gentoo.org> +gtk-engines-2.18.5.ebuild:
+ Version bump. Fixes a potential infinite loop with buggy clearlooks
+ themes, translation updates
03 Dec 2009; Brent Baude <ranger@gentoo.org> ChangeLog:
Marking gtk-engines-2.18.3 ppc64 stable for bug 281427
diff --git a/x11-themes/gtk-engines/gtk-engines-2.18.5.ebuild b/x11-themes/gtk-engines/gtk-engines-2.18.5.ebuild
new file mode 100644
index 000000000000..420b0ce71099
--- /dev/null
+++ b/x11-themes/gtk-engines/gtk-engines-2.18.5.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines/gtk-engines-2.18.5.ebuild,v 1.1 2010/01/05 11:01:29 leio Exp $
+
+EAPI="2"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="GTK+2 standard engines and themes"
+HOMEPAGE="http://www.gtk.org/"
+
+LICENSE="LGPL-2.1"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="accessibility lua"
+
+RDEPEND=">=x11-libs/gtk+-2.12
+ lua? ( dev-lang/lua )"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.31
+ >=dev-util/pkgconfig-0.9"
+
+DOCS="AUTHORS ChangeLog NEWS README"
+
+pkg_setup() {
+ G2CONF="${G2CONF} --enable-animation $(use_enable lua) $(use_with lua system-lua)"
+ use accessibility || G2CONF="${G2CONF} --disable-hc"
+}