summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen de Groot <yngwin@gentoo.org>2009-03-24 01:15:48 +0000
committerBen de Groot <yngwin@gentoo.org>2009-03-24 01:15:48 +0000
commitb5fa35ba06e2528839ede6da59890288a60e1e1b (patch)
tree9a8b4294ae7a06773de667ea7eebac2e4b302d02 /x11-themes/obsidian-xcursors/obsidian-xcursors-1.0.ebuild
parentNew package, initial commit (diff)
downloadgentoo-2-b5fa35ba06e2528839ede6da59890288a60e1e1b.tar.gz
gentoo-2-b5fa35ba06e2528839ede6da59890288a60e1e1b.tar.bz2
gentoo-2-b5fa35ba06e2528839ede6da59890288a60e1e1b.zip
New package, initial commit
(Portage version: 2.2_rc26/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/obsidian-xcursors/obsidian-xcursors-1.0.ebuild')
-rw-r--r--x11-themes/obsidian-xcursors/obsidian-xcursors-1.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/obsidian-xcursors/obsidian-xcursors-1.0.ebuild b/x11-themes/obsidian-xcursors/obsidian-xcursors-1.0.ebuild
new file mode 100644
index 000000000000..1ac307ffb14a
--- /dev/null
+++ b/x11-themes/obsidian-xcursors/obsidian-xcursors-1.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/obsidian-xcursors/obsidian-xcursors-1.0.ebuild,v 1.1 2009/03/24 01:15:48 yngwin Exp $
+
+MY_PN="Obsidian"
+DESCRIPTION="A shiny and clean xcursor theme"
+HOMEPAGE="http://www.kde-look.org/content/show.php/Obsidian+Cursors?content=73135"
+SRC_URI="http://www.kde-look.org/CONTENT/content-files/73135-${MY_PN}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=""
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}/${MY_PN}"
+
+src_install() {
+ insinto /usr/share/cursors/xorg-x11/${MY_PN}
+ doins -r cursors || die "doins failed"
+}
+
+pkg_postinst() {
+ elog "To use this set of cursors, edit or create the file ~/.Xdefaults"
+ elog "and add the following line:"
+ elog "Xcursor.theme: ${MY_PN}"
+ elog
+ elog "You can change the size by adding a line like:"
+ elog "Xcursor.size: 48"
+ elog
+ elog "Also, to globally use this set of mouse cursors edit the file:"
+ elog " /usr/share/cursors/xorg-x11/default/index.theme"
+ elog "and change the line:"
+ elog " Inherits=[current setting]"
+ elog "to"
+ elog " Inherits=${MY_PN}"
+ elog
+ elog "Note this will be overruled by a user's ~/.Xdefaults file."
+ elog
+ ewarn "If you experience flickering, try setting the following line in"
+ ewarn "the Device section of your xorg.conf file:"
+ ewarn " Option \"HWCursor\" \"false\""
+}