summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-02 08:34:15 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-02 08:34:15 +0000
commitdd3d53e1c80863893dc9020a02e792552520257d (patch)
tree8934d99819c63b2f6f2d428c35f45ecb2d84e958 /x11-themes/xfce-gant-icon-theme/xfce-gant-icon-theme-3.9_p6.ebuild
parentfix changelog entry... (diff)
downloadgentoo-2-dd3d53e1c80863893dc9020a02e792552520257d.tar.gz
gentoo-2-dd3d53e1c80863893dc9020a02e792552520257d.tar.bz2
gentoo-2-dd3d53e1c80863893dc9020a02e792552520257d.zip
Initial commit.
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes/xfce-gant-icon-theme/xfce-gant-icon-theme-3.9_p6.ebuild')
-rw-r--r--x11-themes/xfce-gant-icon-theme/xfce-gant-icon-theme-3.9_p6.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/x11-themes/xfce-gant-icon-theme/xfce-gant-icon-theme-3.9_p6.ebuild b/x11-themes/xfce-gant-icon-theme/xfce-gant-icon-theme-3.9_p6.ebuild
new file mode 100644
index 000000000000..e674888d74b2
--- /dev/null
+++ b/x11-themes/xfce-gant-icon-theme/xfce-gant-icon-theme-3.9_p6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/xfce-gant-icon-theme/xfce-gant-icon-theme-3.9_p6.ebuild,v 1.1 2009/09/02 08:34:15 ssuominen Exp $
+
+inherit gnome2-utils
+
+DESCRIPTION="Xfce Gant Icon Theme"
+HOMEPAGE="http://www.xfce-look.org/content/show.php/GANT?content=23297"
+SRC_URI="http://overlay.uberpenguin.net/icons-xfce-gant-${PV/_p/-}.tar.bz2"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE=""
+
+RDEPEND="x11-themes/hicolor-icon-theme"
+DEPEND="${RDEPEND}"
+
+RESTRICT="binchecks strip"
+
+S=${WORKDIR}/Gant.Xfce
+
+src_install() {
+ dodoc README || die
+ rm -f icons/iconrc~ README || die
+ insinto /usr/share/icons/Gant.Xfce
+ doins -r * || die
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }