summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlex Alexander <wired@gentoo.org>2009-09-17 18:56:19 +0000
committerAlex Alexander <wired@gentoo.org>2009-09-17 18:56:19 +0000
commit122ff311aee5f37915824bdf995982f83735875d (patch)
tree4d5ea7e4347ec69f76ad66f617fec9067a57cd89 /x11-themes
parentversion bump (diff)
downloadgentoo-2-122ff311aee5f37915824bdf995982f83735875d.tar.gz
gentoo-2-122ff311aee5f37915824bdf995982f83735875d.tar.bz2
gentoo-2-122ff311aee5f37915824bdf995982f83735875d.zip
version bump
(Portage version: 2.2_rc40/cvs/Linux x86_64)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/qtcurve-qt4/ChangeLog7
-rw-r--r--x11-themes/qtcurve-qt4/qtcurve-qt4-0.68.1.ebuild33
2 files changed, 39 insertions, 1 deletions
diff --git a/x11-themes/qtcurve-qt4/ChangeLog b/x11-themes/qtcurve-qt4/ChangeLog
index e52d70a98899..2a114811923e 100644
--- a/x11-themes/qtcurve-qt4/ChangeLog
+++ b/x11-themes/qtcurve-qt4/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-themes/qtcurve-qt4
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.75 2009/08/28 14:26:41 klausman Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/ChangeLog,v 1.76 2009/09/17 18:56:19 wired Exp $
+
+*qtcurve-qt4-0.68.1 (17 Sep 2009)
+
+ 17 Sep 2009; Alex Alexander <wired@gentoo.org> +qtcurve-qt4-0.68.1.ebuild:
+ version bump
28 Aug 2009; Tobias Klausmann <klausman@gentoo.org>
qtcurve-qt4-0.65.2.ebuild:
diff --git a/x11-themes/qtcurve-qt4/qtcurve-qt4-0.68.1.ebuild b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.68.1.ebuild
new file mode 100644
index 000000000000..9210a64b9a4a
--- /dev/null
+++ b/x11-themes/qtcurve-qt4/qtcurve-qt4-0.68.1.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/qtcurve-qt4/qtcurve-qt4-0.68.1.ebuild,v 1.1 2009/09/17 18:56:19 wired Exp $
+
+EAPI="2"
+KDE_REQUIRED="optional"
+inherit flag-o-matic cmake-utils kde4-base
+
+MY_P="${P/qtcurve-qt4/QtCurve-KDE4}"
+DESCRIPTION="A set of widget styles for Qt4 based apps, also available for KDE3 and GTK2"
+HOMEPAGE="http://www.kde-look.org/content/show.php?content=40492"
+SRC_URI="http://home.freeuk.com/cpdrummond/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~sparc ~x86"
+IUSE="kde"
+
+DEPEND="x11-libs/qt-gui:4[dbus]
+ kde? ( >=kde-base/kwin-4.1.0 )"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+DOCS="ChangeLog README TODO"
+
+src_configure() {
+ if use kde ; then
+ kde4-base_src_configure
+ else
+ mycmakeargs="-DQTC_QT_ONLY=true"
+ cmake-utils_src_configure
+ fi
+}