summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2015-04-27 21:38:00 +0000
committerSebastian Pipping <sping@gentoo.org>2015-04-27 21:38:00 +0000
commit1c4109260ddcdfc898fe4e0a960115382def22d4 (patch)
tree2fef661832c56fe97a790258b1de688b65dfdf74 /x11-themes
parenttypos (diff)
downloadgentoo-2-1c4109260ddcdfc898fe4e0a960115382def22d4.tar.gz
gentoo-2-1c4109260ddcdfc898fe4e0a960115382def22d4.tar.bz2
gentoo-2-1c4109260ddcdfc898fe4e0a960115382def22d4.zip
x11-themes/light-themes: 15.04_p20150410
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x401A1600)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/light-themes/ChangeLog10
-rw-r--r--x11-themes/light-themes/light-themes-15.04_p20150410.ebuild62
2 files changed, 70 insertions, 2 deletions
diff --git a/x11-themes/light-themes/ChangeLog b/x11-themes/light-themes/ChangeLog
index 1d4d72733323..83e56daaf775 100644
--- a/x11-themes/light-themes/ChangeLog
+++ b/x11-themes/light-themes/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/light-themes
-# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/light-themes/ChangeLog,v 1.28 2014/04/27 10:02:55 pacho Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/light-themes/ChangeLog,v 1.29 2015/04/27 21:38:00 sping Exp $
+
+*light-themes-15.04_p20150410 (27 Apr 2015)
+
+ 27 Apr 2015; Sebastian Pipping <sping@gentoo.org>
+ +light-themes-15.04_p20150410.ebuild:
+ Bump to 15.04_p20150410
27 Apr 2014; Pacho Ramos <pacho@gentoo.org> -light-themes-0.1.93-r2.ebuild:
drop old
diff --git a/x11-themes/light-themes/light-themes-15.04_p20150410.ebuild b/x11-themes/light-themes/light-themes-15.04_p20150410.ebuild
new file mode 100644
index 000000000000..f84d9ddf23f0
--- /dev/null
+++ b/x11-themes/light-themes/light-themes-15.04_p20150410.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/light-themes/light-themes-15.04_p20150410.ebuild,v 1.1 2015/04/27 21:38:00 sping Exp $
+
+EAPI=5
+inherit eutils
+
+MY_PN=ubuntu-themes
+MY_PV=14.04+15.04.20150410
+
+DESCRIPTION="GTK2/GTK3 Ambiance and Radiance themes from Ubuntu"
+HOMEPAGE="https://launchpad.net/light-themes"
+SRC_URI="
+ mirror://ubuntu/pool/main/${MY_PN:0:1}/${MY_PN}/${MY_PN}_${MY_PV}.orig.tar.gz
+ http://dev.gentoo.org/~pacho/${PN}/Gentoo-Buttons-r1.tar.xz
+"
+
+LICENSE="CC-BY-SA-3.0 CC-BY-SA-4.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gtk3"
+
+DEPEND="app-arch/xz-utils"
+RDEPEND="
+ x11-themes/gtk-engines-murrine
+ gtk3? ( x11-themes/gtk-engines-unico )
+"
+
+S="${WORKDIR}"/${MY_PN}-${MY_PV}
+
+src_prepare() {
+ cp -r Ambiance/ Ambiance-Gentoo || die
+ cp -r Radiance/ Radiance-Gentoo || die
+ sed -i -e 's/Ambiance/Ambiance-Gentoo/g' Ambiance-Gentoo/index.theme \
+ Ambiance-Gentoo/metacity-1/metacity-theme-1.xml || die
+ sed -i -e 's/Radiance/Radiance-Gentoo/g' Radiance-Gentoo/index.theme \
+ Radiance-Gentoo/metacity-1/metacity-theme-1.xml || die
+ sed -i -e 's/nselected_bg_color:#f07746/nselected_bg_color:#755fbb/g' \
+ Ambiance-Gentoo/gtk-2.0/gtkrc Ambiance-Gentoo/gtk-3.0/settings.ini \
+ Radiance-Gentoo/gtk-2.0/gtkrc Radiance-Gentoo/gtk-3.0/settings.ini || die
+ sed -i -e 's/selected_bg_color #f07746/selected_bg_color #755fbb/g' \
+ Ambiance-Gentoo/gtk-3.0/gtk-main.css \
+ Radiance-Gentoo/gtk-3.0/gtk-main.css || die
+
+ cp -f "${WORKDIR}"/Gentoo-Buttons/*.png "${S}"/Ambiance-Gentoo/metacity-1/. || die
+ cp -f "${WORKDIR}"/Gentoo-Buttons/*.png "${S}"/Radiance-Gentoo/metacity-1/. || die
+ cp -f "${WORKDIR}"/Gentoo-Buttons/assets/*.png "${S}"/Ambiance-Gentoo/gtk-3.0/assets/. || die
+ cp -f "${WORKDIR}"/Gentoo-Buttons/assets/*.png "${S}"/Radiance-Gentoo/gtk-3.0/assets/. || die
+}
+
+src_compile() {
+ :
+}
+
+src_install() {
+ insinto /usr/share/themes
+ doins -r Radiance* Ambiance*
+
+ use gtk3 || {
+ rm -R "${D}"/usr/share/themes/*/gtk-3.0 || die
+ }
+}