summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2013-09-29 09:30:01 +0000
committerPacho Ramos <pacho@gentoo.org>2013-09-29 09:30:01 +0000
commit3d5ff0d5c050b16fbb76e3d2c6f60c54e0df5687 (patch)
tree721b53edcb4e6965bc475b641921ecc6fe1dcfb0 /x11-themes
parentx86 stable wrt bug #478742; Drop old wrt bug #478744 (diff)
downloadgentoo-2-3d5ff0d5c050b16fbb76e3d2c6f60c54e0df5687.tar.gz
gentoo-2-3d5ff0d5c050b16fbb76e3d2c6f60c54e0df5687.tar.bz2
gentoo-2-3d5ff0d5c050b16fbb76e3d2c6f60c54e0df5687.zip
Fix compile with latest automake (#469828)
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key A188FBD4)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-qtpixmap/ChangeLog9
-rw-r--r--x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild43
2 files changed, 26 insertions, 26 deletions
diff --git a/x11-themes/gtk-engines-qtpixmap/ChangeLog b/x11-themes/gtk-engines-qtpixmap/ChangeLog
index 63988657853c..fa1e1374e6d4 100644
--- a/x11-themes/gtk-engines-qtpixmap/ChangeLog
+++ b/x11-themes/gtk-engines-qtpixmap/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for x11-themes/gtk-engines-qtpixmap
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtpixmap/ChangeLog,v 1.14 2012/05/05 04:10:06 jdhore Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtpixmap/ChangeLog,v 1.15 2013/09/29 09:30:01 pacho Exp $
+
+ 29 Sep 2013; Pacho Ramos <pacho@gentoo.org>
+ gtk-engines-qtpixmap-0.28-r2.ebuild:
+ Fix compile with latest automake (#469828)
05 May 2012; Jeff Horelick <jdhore@gentoo.org>
gtk-engines-qtpixmap-0.28-r2.ebuild:
@@ -117,4 +121,3 @@
22 Jul 2003; Brad Laue <brad@gentoo.org> qtpixmap-0.25.ebuild:
Add qtpixmap, a dependency of gtk-engines-geramik
-
diff --git a/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild b/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild
index fc52e56593d2..c26cb725c280 100644
--- a/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild
+++ b/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild
@@ -1,10 +1,12 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild,v 1.11 2012/05/05 04:10:06 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gtk-engines-qtpixmap/gtk-engines-qtpixmap-0.28-r2.ebuild,v 1.12 2013/09/29 09:30:01 pacho Exp $
-EAPI="1"
+EAPI=5
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
-inherit autotools eutils
+inherit autotools eutils gnome2
MY_P="QtPixmap-${PV}"
@@ -19,34 +21,29 @@ SLOT="0"
IUSE=""
RDEPEND="x11-libs/gtk+:2"
+
DEPEND="${RDEPEND}
- virtual/pkgconfig"
+ virtual/pkgconfig
+"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
+src_prepare() {
# Add switches to enable/disable gtk1 and gtk2 engines in the configure
# script.
epatch "${FILESDIR}/${P}-gtk_switches.patch"
- sed -i \
- -e 's/AC_CHECK_COMPILERS/AC_PROG_CC/' \
- configure.in
- rm acinclude.m4
- eautoreconf
-}
-src_compile() {
- local myconf="--enable-gtk2 --disable-gtk1"
+ sed -i -e 's/AC_CHECK_COMPILERS/AC_PROG_CC/' configure.in || die
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.in || die
- econf $myconf || die "Configuration failed"
- emake || die "Compilation failed"
-}
+ rm acinclude.m4
-src_install() {
- emake DESTDIR="${D}" install || die "Installation failed"
+ eautoreconf
+ gnome2_src_prepare
+}
- dodoc AUTHORS ChangeLog README
+src_configure() {
+ gnome2_src_configure \
+ --enable-gtk2 \
+ --disable-gtk1
}