summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2015-03-18 15:04:10 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2015-03-18 15:04:10 +0000
commite0a1b4025e7550bfa13b4727f17a1c446bdbbaa9 (patch)
treefc562ae4164be5f551f87c509ec3f5d9632be2e5 /x11-themes
parentamd64 stable for #543666 (diff)
downloadgentoo-2-e0a1b4025e7550bfa13b4727f17a1c446bdbbaa9.tar.gz
gentoo-2-e0a1b4025e7550bfa13b4727f17a1c446bdbbaa9.tar.bz2
gentoo-2-e0a1b4025e7550bfa13b4727f17a1c446bdbbaa9.zip
Add multilib support.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key 0x18E5B6F2D8D5EC8D)
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gnome-themes-standard/ChangeLog8
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/x11-themes/gnome-themes-standard/ChangeLog b/x11-themes/gnome-themes-standard/ChangeLog
index ce7b81d30f29..cc215d3589d6 100644
--- a/x11-themes/gnome-themes-standard/ChangeLog
+++ b/x11-themes/gnome-themes-standard/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for x11-themes/gnome-themes-standard
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.77 2015/03/15 13:34:44 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/ChangeLog,v 1.78 2015/03/18 15:04:10 tetromino Exp $
+
+*gnome-themes-standard-3.14.2.3-r1 (18 Mar 2015)
+
+ 18 Mar 2015; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +gnome-themes-standard-3.14.2.3-r1.ebuild:
+ Add multilib support.
15 Mar 2015; Pacho Ramos <pacho@gentoo.org>
gnome-themes-standard-3.14.2.3.ebuild:
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild
new file mode 100644
index 000000000000..8f7b29bcf03f
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-themes/gnome-themes-standard/gnome-themes-standard-3.14.2.3-r1.ebuild,v 1.1 2015/03/18 15:04:10 tetromino Exp $
+
+EAPI="5"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit eutils gnome2 multilib-minimal
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE="+gtk"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ gnome-base/librsvg:2[${MULTILIB_USEDEP}]
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ gtk? (
+ >=x11-libs/gtk+-2.24.15:2[${MULTILIB_USEDEP}]
+ >=x11-libs/gtk+-3.12:3[${MULTILIB_USEDEP}] )
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+# gnome-themes{,-extras} are OBSOLETE for GNOME 3
+# http://comments.gmane.org/gmane.comp.gnome.desktop/44130
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="${COMMON_DEPEND}
+ >=gnome-base/gsettings-desktop-schemas-3.4
+ !<x11-themes/gnome-themes-2.32.1-r1
+"
+
+multilib_src_configure() {
+ # The icon cache needs to be generated in pkg_postinst()
+ ECONF_SOURCE="${S}" \
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable gtk gtk2-engine) \
+ $(use_enable gtk gtk3-engine) \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+emake_engines_only() {
+ pushd themes/Adwaita/gtk-2.0 > /dev/null || die
+ if [[ $1 = install ]]; then
+ emake DESTDIR="${D}" install-engineLTLIBRARIES
+ else
+ emake libadwaita.la
+ fi
+ popd > /dev/null
+}
+
+multilib_src_compile() {
+ # processing >3500 icons is slow on old hard drives, do it only for native ABI
+ if multilib_is_native_abi; then
+ gnome2_src_compile
+ else
+ emake_engines_only
+ fi
+}
+
+multilib_src_install() {
+ # processing >3500 icons is slow on old hard drives, do it only for native ABI
+ if multilib_is_native_abi; then
+ gnome2_src_install
+ else
+ emake_engines_only install
+ prune_libtool_files --modules
+ fi
+}