summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-11-20 20:26:17 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-11-20 20:26:17 +0000
commite7d89f262e318acbc27b9b9aca1d843d26c4db30 (patch)
tree3322835b7dbb370ccd0a822d7d57b26a1530506e /x11-wm/aewm++-goodies
parentminor doc fix (diff)
downloadgentoo-2-e7d89f262e318acbc27b9b9aca1d843d26c4db30.tar.gz
gentoo-2-e7d89f262e318acbc27b9b9aca1d843d26c4db30.tar.bz2
gentoo-2-e7d89f262e318acbc27b9b9aca1d843d26c4db30.zip
initial
Diffstat (limited to 'x11-wm/aewm++-goodies')
-rw-r--r--x11-wm/aewm++-goodies/ChangeLog11
-rw-r--r--x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild40
-rw-r--r--x11-wm/aewm++-goodies/files/aewm++-goodies-gcc3-gentoo.patch82
-rw-r--r--x11-wm/aewm++-goodies/files/digest-aewm++-goodies-1.01
4 files changed, 134 insertions, 0 deletions
diff --git a/x11-wm/aewm++-goodies/ChangeLog b/x11-wm/aewm++-goodies/ChangeLog
new file mode 100644
index 000000000000..952cbdaefbcd
--- /dev/null
+++ b/x11-wm/aewm++-goodies/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-wm/aewm++-goodies
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++-goodies/ChangeLog,v 1.1 2002/11/20 20:26:17 mkennedy Exp $
+
+*aewm++-goodies-1.0 (19 Nov 2002)
+
+ 19 Nov 2002; Matthew Kennedy <mkennedy@gentoo.org> aewm++-goodies-1.0.ebuild,
+ files/digest-aewm++-goodies-1.0, ChangeLog,
+ files/aewm++-goodies-gcc3-gentoo.patch :
+
+ Initial import.
diff --git a/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild b/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild
new file mode 100644
index 000000000000..b997ad92b292
--- /dev/null
+++ b/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/aewm++-goodies/aewm++-goodies-1.0.ebuild,v 1.1 2002/11/20 20:26:17 mkennedy Exp $
+
+IUSE=""
+
+DESCRIPTION="Goodies for aewm++."
+HOMEPAGE="http://sapphire.sourceforge.net/"
+SRC_URI="mirror://sourceforge/sapphire/${P/-/_}.tar.bz2"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86"
+DEPEND="virtual/x11"
+
+S="${WORKDIR}/${PN/-/_}"
+
+GOODIES="ae_fspanel-1.0 appbar-1.0 setrootimage-1.0"
+
+src_unpack() {
+ unpack ${A}
+ # compatibility with ANSI C++ and GCC3.2
+ cd ${S} && patch -p1 <${FILESDIR}/aewm++-goodies-gcc3-gentoo.patch || die
+}
+
+src_compile() {
+ for i in ${GOODIES}
+ do
+ make CFLAGS="${CFLAGS}" -C $i || die
+ done
+}
+
+src_install() {
+ dodir /usr/bin
+ for i in ${GOODIES}
+ do
+ make DESTDIR=${D} -C $i install || die
+ docinto $i
+ dodoc $i/{README,ChangeLog,COPYING,LICENSE}
+ done
+}
diff --git a/x11-wm/aewm++-goodies/files/aewm++-goodies-gcc3-gentoo.patch b/x11-wm/aewm++-goodies/files/aewm++-goodies-gcc3-gentoo.patch
new file mode 100644
index 000000000000..487b3b60d524
--- /dev/null
+++ b/x11-wm/aewm++-goodies/files/aewm++-goodies-gcc3-gentoo.patch
@@ -0,0 +1,82 @@
+diff -ur aewm++_goodies/ae_fspanel-1.0/Makefile aewm++_goodies~/ae_fspanel-1.0/Makefile
+--- aewm++_goodies/ae_fspanel-1.0/Makefile 2002-11-11 18:30:27.000000000 -0600
++++ aewm++_goodies~/ae_fspanel-1.0/Makefile 2002-11-20 14:00:07.000000000 -0600
+@@ -1,7 +1,7 @@
+ CC = gcc
+ prefix=/usr
+-C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I/usr/X11R6/include -m386 -malign-loops=2 -malign-jumps=2 -malign-functions=2
+-L_FLAGS = -O1 -Xlinker -s -L/usr/X11R6/lib -lX11 -lXpm
++C_FLAGS = -DNOSTDLIB -DHAVE_XPM -Wall -I/usr/X11R6/include -falign-loops=2 -falign-jumps=2 -falign-functions=2 $(CFLAGS)
++L_FLAGS = -Xlinker -s -L/usr/X11R6/lib -lX11 -lXpm
+ PROGNAME = ae_fspanel
+
+ $(PROGNAME): Makefile ae_fspanel.c ae_fspanel.h icon.xpm
+diff -ur aewm++_goodies/appbar-1.0/Makefile aewm++_goodies~/appbar-1.0/Makefile
+--- aewm++_goodies/appbar-1.0/Makefile 2002-11-11 18:36:35.000000000 -0600
++++ aewm++_goodies~/appbar-1.0/Makefile 2002-11-20 14:01:49.000000000 -0600
+@@ -1,7 +1,7 @@
+ CC = g++
+ CFLAGS = -g -O2 -Wall
+ prefix = /usr
+-INCLUDES = -I$(prefix)/include
++INCLUDES =
+ LIBS = -lX11 -lXext -lXpm
+ LDPATH = -L/usr/X11R6/lib
+
+diff -ur aewm++_goodies/appbar-1.0/icon.cc aewm++_goodies~/appbar-1.0/icon.cc
+--- aewm++_goodies/appbar-1.0/icon.cc 2002-01-26 18:10:17.000000000 -0600
++++ aewm++_goodies~/appbar-1.0/icon.cc 2002-11-20 14:00:55.000000000 -0600
+@@ -35,6 +35,8 @@
+
+ #include "icon.hh"
+
++using namespace std;
++
+ char * default_icon_xpm[] = {
+ "16 16 16 1",
+ " c None",
+diff -ur aewm++_goodies/appbar-1.0/scanner.hh aewm++_goodies~/appbar-1.0/scanner.hh
+--- aewm++_goodies/appbar-1.0/scanner.hh 2002-11-09 12:48:07.000000000 -0600
++++ aewm++_goodies~/appbar-1.0/scanner.hh 2002-11-20 14:06:21.000000000 -0600
+@@ -25,13 +25,15 @@
+ #ifndef _SCANNER_HH_
+ #define _SCANNER_HH_
+
+-#include <iostream.h>
+-#include <fstream.h>
++#include <iostream>
++#include <fstream>
+ #include <cstdlib>
+ #include <string>
+
+ #define MAX_TOKEN_BUFFER 256
+
++using namespace std;
++
+ class Scanner {
+ private:
+
+diff -ur aewm++_goodies/setrootimage-1.0/Makefile aewm++_goodies~/setrootimage-1.0/Makefile
+--- aewm++_goodies/setrootimage-1.0/Makefile 2002-11-11 18:29:35.000000000 -0600
++++ aewm++_goodies~/setrootimage-1.0/Makefile 2002-11-20 14:07:16.000000000 -0600
+@@ -1,7 +1,7 @@
+ CC = g++
+ CFLAGS = -g -O2 -Wall
+ prefix = /usr
+-INCLUDES = -I$(prefix)/include
++INCLUDES =
+ LIBS = -lX11 -lXext
+ LDPATH = -L/usr/X11R6/lib
+
+diff -ur aewm++_goodies/setrootimage-1.0/setrootimage.cc aewm++_goodies~/setrootimage-1.0/setrootimage.cc
+--- aewm++_goodies/setrootimage-1.0/setrootimage.cc 2002-02-02 08:14:22.000000000 -0600
++++ aewm++_goodies~/setrootimage-1.0/setrootimage.cc 2002-11-20 14:07:32.000000000 -0600
+@@ -38,6 +38,8 @@
+ #include <iostream>
+ #include "image.hh"
+
++using namespace std;
++
+ BColor parseCommandlineColor(char* the_color)
+ {
+ BColor color;
diff --git a/x11-wm/aewm++-goodies/files/digest-aewm++-goodies-1.0 b/x11-wm/aewm++-goodies/files/digest-aewm++-goodies-1.0
new file mode 100644
index 000000000000..56a9cdb65086
--- /dev/null
+++ b/x11-wm/aewm++-goodies/files/digest-aewm++-goodies-1.0
@@ -0,0 +1 @@
+MD5 10ef25fd00ff0e00133b871ce48d5a4f aewm++_goodies-1.0.tar.bz2 40753