summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Kennedy <mkennedy@gentoo.org>2002-05-26 21:17:43 +0000
committerMatthew Kennedy <mkennedy@gentoo.org>2002-05-26 21:17:43 +0000
commitb99241e33db00f4f0fc0cbf9af0cb617dd4223ab (patch)
tree4cd100e9cacc2468f55c749c1102f67749ca4951 /x11-wm/icewm
parentSilly cvs, don't know how or why it missed this file _again_ but This fixes (diff)
downloadgentoo-2-b99241e33db00f4f0fc0cbf9af0cb617dd4223ab.tar.gz
gentoo-2-b99241e33db00f4f0fc0cbf9af0cb617dd4223ab.tar.bz2
gentoo-2-b99241e33db00f4f0fc0cbf9af0cb617dd4223ab.zip
code patch to support gcc3.1 (thanks to yasea@gmx.net)
Diffstat (limited to 'x11-wm/icewm')
-rw-r--r--x11-wm/icewm/ChangeLog11
-rw-r--r--x11-wm/icewm/files/digest-icewm-1.0.9.2-r41
-rw-r--r--x11-wm/icewm/files/icewm-1.0.9.2-gcc31-gentoo.patch15
-rw-r--r--x11-wm/icewm/icewm-1.0.9.2-r4.ebuild57
4 files changed, 83 insertions, 1 deletions
diff --git a/x11-wm/icewm/ChangeLog b/x11-wm/icewm/ChangeLog
index 2ac19e94c88f..f891e37e0a35 100644
--- a/x11-wm/icewm/ChangeLog
+++ b/x11-wm/icewm/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for x11-wm/icewm
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.4 2002/02/20 04:36:33 chouser Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/ChangeLog,v 1.5 2002/05/26 21:17:43 mkennedy Exp $
+
+*icewm-1.0.9.2-r4 (26 May 2002)
+
+ 26 May 2002; Matthew Kennedy <mkennedy@gentoo.org> ChangeLog,
+ icewm-1.0.9.2-r4.ebuild, files/digest-icewm-1.0.9.2-r4,
+ files/icewm-1.0.9.2-gcc31-gentoo.patch :
+
+ Code patch to support gcc3.1 (thanks to yasea@gmx.net (Thomas
+ Weidner) and http://bugs.gentoo.org/show_bug.cgi?id=2969).
*icewm-1.0.9.2-r3 (19 Feb 2002)
diff --git a/x11-wm/icewm/files/digest-icewm-1.0.9.2-r4 b/x11-wm/icewm/files/digest-icewm-1.0.9.2-r4
new file mode 100644
index 000000000000..14ee41d7fddd
--- /dev/null
+++ b/x11-wm/icewm/files/digest-icewm-1.0.9.2-r4
@@ -0,0 +1 @@
+MD5 076d02415b694518b61b569ddd12822c icewm-1.0.9-2.tar.gz 630017
diff --git a/x11-wm/icewm/files/icewm-1.0.9.2-gcc31-gentoo.patch b/x11-wm/icewm/files/icewm-1.0.9.2-gcc31-gentoo.patch
new file mode 100644
index 000000000000..76273fc12ea6
--- /dev/null
+++ b/x11-wm/icewm/files/icewm-1.0.9.2-gcc31-gentoo.patch
@@ -0,0 +1,15 @@
+diff -ru icewm-1.0.9/src/wmclient.h icewm-1.0.9-edited/src/wmclient.h
+--- icewm-1.0.9/src/wmclient.h Tue Oct 9 16:54:03 2001
++++ icewm-1.0.9-edited/src/wmclient.h Thu May 23 20:44:53 2002
+@@ -11,10 +11,7 @@
+ typedef int FrameState;
+
+ #ifndef __YIMP_UTIL__
+-//!!! remove these if possible
+-typedef struct XWMHints;
+-typedef struct XSizeHints;
+-typedef struct XClassHint;
++# include <X11/Xutil.h>
+ #endif
+
+ class ClientData {
diff --git a/x11-wm/icewm/icewm-1.0.9.2-r4.ebuild b/x11-wm/icewm/icewm-1.0.9.2-r4.ebuild
new file mode 100644
index 000000000000..86dc3c1f06ee
--- /dev/null
+++ b/x11-wm/icewm/icewm-1.0.9.2-r4.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2001 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Daniel Robbins <drobbins@gentoo.org>
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/icewm/icewm-1.0.9.2-r4.ebuild,v 1.1 2002/05/26 21:17:43 mkennedy Exp $
+
+NV=1.0.9-2
+S=${WORKDIR}/icewm-1.0.9
+DESCRIPTION="Ice Window Manager"
+SRC_URI="prdownloads.sourceforge.net/${PN}/${PN}-${NV}.tar.gz"
+HOMEPAGE="www.icewm.org"
+
+DEPEND="virtual/x11
+ nls? ( >=sys-devel/gettext-0.10.40 )
+ imlib? ( >=media-libs/imlib-1.9.10-r1 )"
+
+src_unpack(){
+ unpack ${A}
+ cd ${S}
+ patch -p1 <${FILESDIR}/icewm-1.0.9.2-gcc31-gentoo.patch || die
+
+ # icewm's doc dir layout is un-gentoo-like. To fix it, we have
+ # "make install" skip the docs install, and do it ourselves. That also
+ # means we have to adjust the Makefile so that it can find the help files
+ # when you choose the 'help' item out of its menu.
+ t=src/Makefile
+ cp $t $t.orig
+ sed 's:icewm-$(VERSION)/::' $t.orig > $t
+}
+
+src_compile(){
+ use nls && myconf="$myconf --enable-nls" \
+ || myconf="$myconf --disable-nls"
+ use imlib && myconf="$myconf --with-imlib" \
+ || myconf="$myconf --without-imlib"
+ ./configure \
+ --build=${CHOST} \
+ --prefix=/usr \
+ --with-libdir=/usr/lib/icewm \
+ --with-cfgdir=/etc/icewm \
+ --with-docdir=/usr/share/doc/${PF}/html \
+ $myconf || die "configure failed"
+ emake || die "emake failed"
+}
+
+src_install(){
+ make \
+ prefix=${D}/usr \
+ LIBDIR=${D}/usr/lib/icewm \
+ CFGDIR=${D}/etc/icewm \
+ DOCDIR=${S}/dummy \
+ install || die "make install failed"
+ dodoc AUTHORS BUGS CHANGES COPYING FAQ PLATFORMS README* TODO VERSION
+ dohtml -a html,sgml doc/*
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/icewm
+}