summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2010-11-25 16:51:10 +0000
committerMichael Weber <xmw@gentoo.org>2010-11-25 16:51:10 +0000
commite56eecccbe22f6c0705c20e592b738ae404bb658 (patch)
tree3d11f0432d2e1b25c9bf49e3a233d2947d414ce6 /x11-wm/parti
parentVersion bumped. (diff)
downloadgentoo-2-e56eecccbe22f6c0705c20e592b738ae404bb658.tar.gz
gentoo-2-e56eecccbe22f6c0705c20e592b738ae404bb658.tar.bz2
gentoo-2-e56eecccbe22f6c0705c20e592b738ae404bb658.zip
Version bump to solve clipboard issues
(Portage version: 2.1.8.3/cvs/Linux x86_64)
Diffstat (limited to 'x11-wm/parti')
-rw-r--r--x11-wm/parti/ChangeLog7
-rw-r--r--x11-wm/parti/parti-0.0.6_p456.ebuild39
2 files changed, 45 insertions, 1 deletions
diff --git a/x11-wm/parti/ChangeLog b/x11-wm/parti/ChangeLog
index 225766dfefd9..28f78689b125 100644
--- a/x11-wm/parti/ChangeLog
+++ b/x11-wm/parti/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/parti
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/parti/ChangeLog,v 1.4 2010/10/07 09:46:17 phajdan.jr Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/parti/ChangeLog,v 1.5 2010/11/25 16:51:10 xmw Exp $
+
+*parti-0.0.6_p456 (25 Nov 2010)
+
+ 25 Nov 2010; Michael Weber <xmw@gentoo.org> +parti-0.0.6_p456.ebuild:
+ Version bump to solve clipboard issues
07 Oct 2010; Pawel Hajdan jr <phajdan.jr@gentoo.org> parti-0.0.6.ebuild:
x86 stable wrt bug #339332
diff --git a/x11-wm/parti/parti-0.0.6_p456.ebuild b/x11-wm/parti/parti-0.0.6_p456.ebuild
new file mode 100644
index 000000000000..5147b47c3da5
--- /dev/null
+++ b/x11-wm/parti/parti-0.0.6_p456.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/parti/parti-0.0.6_p456.ebuild,v 1.1 2010/11/25 16:51:10 xmw Exp $
+
+EAPI=2
+
+PYTHON_DEPEND=2
+
+inherit distutils eutils python
+
+DESCRIPTION="X Persistent Remote Apps (xpra) and Partitioning WM (parti) based on wimpiggy"
+HOMEPAGE="http://partiwm.googlecode.com/"
+SRC_URI="mirror://gentoo/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-python/pygtk
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ x11-libs/libXtst"
+
+RDEPEND="${COMMON_RDEPEND}
+ dev-python/ipython
+ x11-apps/xmodmap"
+DEPEND="${COMMON_RDEPEND}
+ dev-python/pyrex
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ python_set_active_version 2
+}
+
+src_prepare() {
+ $(PYTHON -2 -a) make_constants_pxi.py wimpiggy/lowlevel/constants.txt wimpiggy/lowlevel/constants.pxi
+}