summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMamoru Komachi <usata@gentoo.org>2003-10-20 12:24:47 +0000
committerMamoru Komachi <usata@gentoo.org>2003-10-20 12:24:47 +0000
commit4654702f21c3ae73d41c24412860badcc1e9bdf0 (patch)
treef1d668ec30ac4d31c00663ab927c8dcd1a46a67e /x11-wm/wm2
parentNew ebuild, closing Bug #17129. (diff)
downloadgentoo-2-4654702f21c3ae73d41c24412860badcc1e9bdf0.tar.gz
gentoo-2-4654702f21c3ae73d41c24412860badcc1e9bdf0.tar.bz2
gentoo-2-4654702f21c3ae73d41c24412860badcc1e9bdf0.zip
New ebuild, closing Bug #17129.
Diffstat (limited to 'x11-wm/wm2')
-rw-r--r--x11-wm/wm2/ChangeLog11
-rw-r--r--x11-wm/wm2/Manifest3
-rw-r--r--x11-wm/wm2/files/digest-wm2-41
-rw-r--r--x11-wm/wm2/files/wm2-4-gentoo.patch107
-rw-r--r--x11-wm/wm2/wm2-4.ebuild53
5 files changed, 174 insertions, 1 deletions
diff --git a/x11-wm/wm2/ChangeLog b/x11-wm/wm2/ChangeLog
new file mode 100644
index 000000000000..4303cb3132b1
--- /dev/null
+++ b/x11-wm/wm2/ChangeLog
@@ -0,0 +1,11 @@
+# ChangeLog for x11-wm/wm2
+# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wm2/ChangeLog,v 1.1 2003/10/20 12:24:43 usata Exp $
+
+*wm2-4 (20 Oct 2003)
+
+ 20 Oct 2003; Mamoru KOMACHI <usata@gentoo.org> wm2-4.ebuild,
+ files/wm2-4-gentoo.patch:
+ Initial import. Ebuild submitted by Satoshi Fuktommy <fuktommy@24i.net>
+ This closes Bug #17129.
+
diff --git a/x11-wm/wm2/Manifest b/x11-wm/wm2/Manifest
index bc01b3f9e79b..4816cbce1d8b 100644
--- a/x11-wm/wm2/Manifest
+++ b/x11-wm/wm2/Manifest
@@ -1,3 +1,4 @@
-MD5 8664035449a021c3334452d2f0514e20 wm2-4.ebuild 857
+MD5 d41701f7657587048edbf02876ae3d19 wm2-4.ebuild 1327
+MD5 f82afd373da8f7c9dc340f91c83d0941 ChangeLog 415
MD5 9e0ac0452d3a84e7f4837c7f0f08ff37 files/wm2-4-gentoo.patch 3430
MD5 b06be8523fb665cee575914e6b788265 files/digest-wm2-4 56
diff --git a/x11-wm/wm2/files/digest-wm2-4 b/x11-wm/wm2/files/digest-wm2-4
new file mode 100644
index 000000000000..6f85dbf9f1e8
--- /dev/null
+++ b/x11-wm/wm2/files/digest-wm2-4
@@ -0,0 +1 @@
+MD5 3b1d6da47a00c06436891669261bd651 wm2-4.tar.gz 32807
diff --git a/x11-wm/wm2/files/wm2-4-gentoo.patch b/x11-wm/wm2/files/wm2-4-gentoo.patch
new file mode 100644
index 000000000000..9ec201424218
--- /dev/null
+++ b/x11-wm/wm2/files/wm2-4-gentoo.patch
@@ -0,0 +1,107 @@
+diff -Nru wm2-4/Border.C wm2-4.orig/Border.C
+--- wm2-4/Border.C 2003-03-09 19:34:25.000000000 +0900
++++ wm2-4.orig/Border.C 2003-03-09 19:43:14.000000000 +0900
+@@ -183,7 +183,7 @@
+
+ if (m_label) free(m_label);
+ m_label = m_client->iconName() ?
+- NewString(m_client->iconName()) : NewString(CONFIG_INCOGNITO);
++ NewString(m_client->iconName()) : NewString("incognito");
+
+ int len = strlen(m_label);
+ m_tabHeight = XRotTextWidth(m_tabFont, m_label, len) + 6 + m_tabWidth;
+diff -Nru wm2-4/Buttons.C wm2-4.orig/Buttons.C
+--- wm2-4/Buttons.C 2003-03-09 19:42:37.000000000 +0900
++++ wm2-4.orig/Buttons.C 2003-03-09 19:43:14.000000000 +0900
+@@ -139,11 +139,7 @@
+ (allowExit && ((n) > clients.count())) ? "[Exit wm2]" \
+ : clients.item((n)-1)->label())
+
+-#ifdef CONFIG_MENU_REVERSE
+- for (i = m_hiddenClients.count() - 1; i>=0; --i) {
+-#else
+ for (i = 0; i < m_hiddenClients.count(); ++i) {
+-#endif
+ clients.append(m_hiddenClients.item(i));
+ }
+ int nh = clients.count() + 1;
+diff -Nru wm2-4/Client.C wm2-4.orig/Client.C
+--- wm2-4/Client.C 2003-03-09 19:34:25.000000000 +0900
++++ wm2-4.orig/Client.C 2003-03-09 19:43:14.000000000 +0900
+@@ -4,7 +4,7 @@
+
+ #include <X11/Xutil.h>
+
+-const char *const Client::m_defaultLabel = CONFIG_INCOGNITO;
++const char *const Client::m_defaultLabel = "incognito";
+
+
+
+diff -Nru wm2-4/Config.h wm2-4.orig/Config.h
+--- wm2-4/Config.h 2003-03-09 19:41:43.000000000 +0900
++++ wm2-4.orig/Config.h 2003-03-09 19:43:14.000000000 +0900
+@@ -39,9 +39,6 @@
+
+ #define CONFIG_FRAME_THICKNESS 7
+
+-#define CONFIG_INCOGNITO "incognito"
+-#define CONFIG_MENU_REVERSE
+-
+ // If CONFIG_PROD_SHAPE is True, all frame element shapes will be
+ // recalculated afresh every time their focus changes. This will
+ // probably slow things down hideously, but has been reported as
+@@ -49,3 +46,4 @@
+ #define CONFIG_PROD_SHAPE False
+
+ #endif
++
+diff -Nru wm2-4/General.h wm2-4.orig/General.h
+--- wm2-4/General.h 2003-03-09 19:34:25.000000000 +0900
++++ wm2-4.orig/General.h 2003-03-09 19:43:14.000000000 +0900
+@@ -32,7 +32,7 @@
+ #define NewString(x) (strcpy((char *)malloc(strlen(x)+1),(x)))
+
+ #ifndef SIGNAL_CALLBACK_TYPE
+-#define SIGNAL_CALLBACK_TYPE (void (*)(int))
++#define SIGNAL_CALLBACK_TYPE (void (*)(...))
+ #endif
+
+ #define signal(x,y) \
+diff -Nru wm2-4/Makefile wm2-4.orig/Makefile
+--- wm2-4/Makefile 2003-03-09 19:34:25.000000000 +0900
++++ wm2-4.orig/Makefile 2003-03-09 19:43:14.000000000 +0900
+@@ -1,8 +1,8 @@
+
+-LIBS = -L/usr/X11R6/lib -lXext -lX11 -lXmu -lm
++LIBS = -L/usr/X11/lib -lXext -lX11 -lXmu -lm
+
+ CC = gcc
+-CCC = g++
++CCC = gcc
+ CFLAGS = -O2
+ OBJECTS = Border.o Buttons.o Client.o Events.o Main.o Manager.o Rotated.o
+
+diff -Nru wm2-4/Manager.C wm2-4.orig/Manager.C
+--- wm2-4/Manager.C 2003-03-09 19:34:25.000000000 +0900
++++ wm2-4.orig/Manager.C 2003-03-09 19:43:14.000000000 +0900
+@@ -368,7 +368,7 @@
+ return m_currentTime;
+ }
+
+-void WindowManager::sigHandler(int n)
++void WindowManager::sigHandler()
+ {
+ m_signalled = True;
+ }
+diff -Nru wm2-4/Manager.h wm2-4.orig/Manager.h
+--- wm2-4/Manager.h 2003-03-09 19:34:25.000000000 +0900
++++ wm2-4.orig/Manager.h 2003-03-09 19:43:14.000000000 +0900
+@@ -85,7 +85,7 @@
+
+ static Boolean m_initialising;
+ static int errorHandler(Display *, XErrorEvent *);
+- static void sigHandler(int);
++ static void sigHandler();
+ static int m_signalled;
+
+ void initialiseScreen();
diff --git a/x11-wm/wm2/wm2-4.ebuild b/x11-wm/wm2/wm2-4.ebuild
new file mode 100644
index 000000000000..62d2e844402a
--- /dev/null
+++ b/x11-wm/wm2/wm2-4.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/wm2/wm2-4.ebuild,v 1.1 2003/10/20 12:24:43 usata Exp $
+
+IUSE=""
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Small, unconfigurable window manager"
+HOMEPAGE="http://www.all-day-breakfast.com/wm2/"
+SRC_URI="http://www.all-day-breakfast.com/wm2/${P}.tar.gz"
+
+DEPEND="virtual/x11"
+
+SLOT="0"
+LICENSE="freedist"
+KEYWORDS="~x86"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}
+ EPATCH_OPTS="-R"
+ epatch ${FILESDIR}/${PF}-gentoo.patch
+
+ sed 's/^#//' Config.h > wm2.conf
+ if [ -e "/etc/wm2.conf" ]; then
+ echo "#undef _CONFIG_H_" >> Config.h
+ awk '/^[^/]/{print "#" $0}' /etc/wm2.conf >> Config.h
+ fi
+}
+
+src_compile() {
+ make CFLAGS="${CFLAGS}" || die
+}
+
+src_install() {
+ exeinto /usr/bin
+ doexe wm2
+ insinto /etc
+ doins wm2.conf
+ dodoc README
+}
+
+pkg_postinst() {
+ einfo
+ einfo "wm2 is unconfigurable after you have installed. If you want to"
+ einfo "change settings of wm2, please have a look at /etc/wm2.conf"
+ einfo "and rewrite it, then emerge wm2 again (wm2 ebuild uses settings"
+ einfo "from that file automatically). If you think wm2 lacks some important"
+ einfo "features that you want to use (such as background pixmaps),"
+ einfo "consider using wmx, written by the same author."
+ einfo
+}