summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrad Teaford Cowan <bcowan@gentoo.org>2002-11-12 11:48:42 +0000
committerBrad Teaford Cowan <bcowan@gentoo.org>2002-11-12 11:48:42 +0000
commitb82c9b12ebe25bbbe72a0cfff685774e76c24f74 (patch)
treeceaf009ec4e2c1fa581d74b3b6096c4fa673925d /x11-wm/xfce
parentNew ebiuld (diff)
downloadgentoo-2-b82c9b12ebe25bbbe72a0cfff685774e76c24f74.tar.gz
gentoo-2-b82c9b12ebe25bbbe72a0cfff685774e76c24f74.tar.bz2
gentoo-2-b82c9b12ebe25bbbe72a0cfff685774e76c24f74.zip
version bump
Diffstat (limited to 'x11-wm/xfce')
-rw-r--r--x11-wm/xfce/ChangeLog9
-rw-r--r--x11-wm/xfce/files/digest-xfce-3.8.181
-rw-r--r--x11-wm/xfce/xfce-3.8.18.ebuild56
3 files changed, 65 insertions, 1 deletions
diff --git a/x11-wm/xfce/ChangeLog b/x11-wm/xfce/ChangeLog
index 2798197adcef..bbd51b459365 100644
--- a/x11-wm/xfce/ChangeLog
+++ b/x11-wm/xfce/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for x11-wm/xfce
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/ChangeLog,v 1.8 2002/04/25 15:12:15 g2boojum Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/ChangeLog,v 1.9 2002/11/12 11:48:42 bcowan Exp $
+
+*xfce-3.8.18 (12 Nov 2002)
+
+ 12 Nov 2002; Brad Cowan <bcowan@gentoo.org> xfce-3.8.18.ebuild,
+ files/digest-xfce-3.8.18 :
+
+ Version bump.
*xfce-3.8.16 (25 Apr 2002)
diff --git a/x11-wm/xfce/files/digest-xfce-3.8.18 b/x11-wm/xfce/files/digest-xfce-3.8.18
new file mode 100644
index 000000000000..9b69f3b72489
--- /dev/null
+++ b/x11-wm/xfce/files/digest-xfce-3.8.18
@@ -0,0 +1 @@
+MD5 04c197eee32d712a49170539d50279ea xfce-3.8.18.tar.gz 5166881
diff --git a/x11-wm/xfce/xfce-3.8.18.ebuild b/x11-wm/xfce/xfce-3.8.18.ebuild
new file mode 100644
index 000000000000..61c8806f83b5
--- /dev/null
+++ b/x11-wm/xfce/xfce-3.8.18.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/xfce/xfce-3.8.18.ebuild,v 1.1 2002/11/12 11:48:42 bcowan Exp $
+
+IUSE="arts gtk gnome nls"
+
+S=${WORKDIR}/${P}
+
+DESCRIPTION="XFce is a lightweight desktop environment for various UNIX systems."
+SRC_URI="mirror://sourceforge/xfce/${P}.tar.gz"
+HOMEPAGE="http://www.xfce.org/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="x86 sparc sparc64"
+
+DEPEND="virtual/x11
+ =x11-libs/gtk+-1.2*
+ gnome? ( dev-libs/libxml2 )
+ gtk? ( >=media-libs/gdk-pixbuf-0.11.0-r1 >=media-libs/imlib-1.9.10-r1 )
+ arts? ( kde-base/arts )"
+
+RDEPEND="nls? ( sys-devel/gettext )"
+
+src_compile() {
+ local myconf
+
+ use gtk && myconf="--enable-imlib=no --enable-gdk-pixbuf=/usr"
+
+ use gnome && myconf="${myconf} --enable-gdm --enable-libxml2"
+
+ use nls || myconf="${myconf} --disable-nls"
+
+ use arts && myconf="${myconf} --enable-arts"
+
+ econf \
+ --enable-xft \
+ ${myconf} || die
+
+ cd docs
+ cp Makefile Makefile.orig
+ sed "s:/usr/share/xfce:/usr/share/doc/${PF}:" Makefile.orig > Makefile
+ cd ..
+
+ emake || die
+}
+
+src_install () {
+ make DESTDIR=${D} install || die
+ dodir /etc/skel/.xfce
+
+ exeinto /etc/X11/Sessions
+ doexe $FILESDIR/xfce
+
+ dodoc ChangeLog* AUTHORS LICENSE README* TODO*
+}