summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMarinus Schraal <foser@gentoo.org>2004-03-30 22:37:31 +0000
committerMarinus Schraal <foser@gentoo.org>2004-03-30 22:37:31 +0000
commit1633a5a2e848a4a986d7fc6a5697c185ce87c146 (patch)
tree2705222c43b3598e6f5bb4a52c56fe38c8a0c54f /x11-wm
parentopenh323-1.12.2-r2 stable on x86, fixed #43981, includes fix for amd64 (Mani... (diff)
downloadgentoo-2-1633a5a2e848a4a986d7fc6a5697c185ce87c146.tar.gz
gentoo-2-1633a5a2e848a4a986d7fc6a5697c185ce87c146.tar.bz2
gentoo-2-1633a5a2e848a4a986d7fc6a5697c185ce87c146.zip
add fix for xinerama config b0rkage
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/metacity/ChangeLog5
-rw-r--r--x11-wm/metacity/files/metacity-2.8.0-xinerama_config_test.patch11
-rw-r--r--x11-wm/metacity/metacity-2.8.0.ebuild17
3 files changed, 28 insertions, 5 deletions
diff --git a/x11-wm/metacity/ChangeLog b/x11-wm/metacity/ChangeLog
index 3ec3ed12a3b3..a1ec24513265 100644
--- a/x11-wm/metacity/ChangeLog
+++ b/x11-wm/metacity/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for x11-wm/metacity
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.59 2004/03/30 01:32:53 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/ChangeLog,v 1.60 2004/03/30 22:37:31 foser Exp $
+
+ 31 Mar 2004; foser <foser@gentoo.org> metacity-2.8.0.ebuild :
+ Add patch to fix xinerama configure switch (#46291)
30 Mar 2004; Luca Barbato <lu_zero@gentoo.org> :
Removed an unnecessary patch
diff --git a/x11-wm/metacity/files/metacity-2.8.0-xinerama_config_test.patch b/x11-wm/metacity/files/metacity-2.8.0-xinerama_config_test.patch
new file mode 100644
index 000000000000..cadaf522fc0d
--- /dev/null
+++ b/x11-wm/metacity/files/metacity-2.8.0-xinerama_config_test.patch
@@ -0,0 +1,11 @@
+--- metacity-2.8.0/configure.in 2004-03-21 17:16:12.000000000 +0100
++++ metacity-2.8.0.patched/configure.in 2004-03-31 00:21:54.438187584 +0200
+@@ -214,7 +214,7 @@
+ CPPFLAGS="$CPPFLAGS $X_CFLAGS"
+
+ AC_ARG_ENABLE(xinerama,[ --disable-xinerama disable metacity's use of the Xinerama extension],
+- try_xinerama=no,try_xinerama=yes)
++ try_xinerama=$enable_xinerama,try_xinerama=yes)
+
+ use_solaris_xinerama=no
+ use_xfree_xinerama=no
diff --git a/x11-wm/metacity/metacity-2.8.0.ebuild b/x11-wm/metacity/metacity-2.8.0.ebuild
index f0bdf569bfea..bd9ab8ebaf77 100644
--- a/x11-wm/metacity/metacity-2.8.0.ebuild
+++ b/x11-wm/metacity/metacity-2.8.0.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.8.0.ebuild,v 1.2 2004/03/30 01:32:53 lu_zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/metacity/metacity-2.8.0.ebuild,v 1.3 2004/03/30 22:37:31 foser Exp $
-inherit gnome2
+inherit gnome2 eutils
DESCRIPTION="Gnome default windowmanager"
HOMEPAGE="http://www.gnome.org/"
@@ -25,15 +25,23 @@ RDEPEND="virtual/x11
DEPEND="${RDEPEND}
sys-devel/gettext
>=dev-util/pkgconfig-0.12.0
- >=dev-util/intltool-0.29"
+ >=dev-util/intltool-0.29
+ sys-devel/autoconf"
+#autoconf for the config patch only
DOCS="AUTHORS COPYING ChangeLog HACKING INSTALL NEWS README *txt"
G2CONF="${G2CONF} $(use_enable xinerama)"
-src_unpack(){
+src_unpack() {
unpack ${A}
+ cd ${S}
+
+ # fix the xinerama configure stuff (#46291)
+ epatch ${FILESDIR}/${P}-xinerama_config_test.patch
+ WANT_AUTOCONF=2.5 autoconf || die
+
#We can remove that one eventually
# causes ICE on ppc w/ gcc (still)
# use ppc && (
@@ -43,4 +51,5 @@ src_unpack(){
# fi
# )
+
}