summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2015-06-09 19:43:10 +0000
committerBrian Evans <grknight@gentoo.org>2015-06-09 19:43:10 +0000
commite4633fa52d1bc47350be64260a4f34b60d10afd5 (patch)
treeb25b5fb73831fee308da59532445b5caf9519658 /x11-wm
parentDelete redundant echo. (diff)
downloadgentoo-2-e4633fa52d1bc47350be64260a4f34b60d10afd5.tar.gz
gentoo-2-e4633fa52d1bc47350be64260a4f34b60d10afd5.tar.bz2
gentoo-2-e4633fa52d1bc47350be64260a4f34b60d10afd5.zip
Non-maintainer commit: Fix build missing link to dlopen; Patch by me; wrt bug 512476
(Portage version: 2.2.20/cvs/Linux x86_64, signed Manifest commit with key D1F781EFF9F4A3B6)
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/matchbox-desktop/ChangeLog10
-rw-r--r--x11-wm/matchbox-desktop/files/matchbox-desktop-0.9.1-dlopen.patch11
-rw-r--r--x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild13
3 files changed, 28 insertions, 6 deletions
diff --git a/x11-wm/matchbox-desktop/ChangeLog b/x11-wm/matchbox-desktop/ChangeLog
index 05584ae45d83..acf1d5ff5311 100644
--- a/x11-wm/matchbox-desktop/ChangeLog
+++ b/x11-wm/matchbox-desktop/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for x11-wm/matchbox-desktop
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-desktop/ChangeLog,v 1.11 2012/06/04 00:31:01 xmw Exp $
+# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-desktop/ChangeLog,v 1.12 2015/06/09 19:43:10 grknight Exp $
+
+ 09 Jun 2015; Brian Evans <grknight@gentoo.org>
+ +files/matchbox-desktop-0.9.1-dlopen.patch, matchbox-desktop-0.9.1.ebuild:
+ Non-maintainer commit: Fix build missing link to dlopen; Patch by me; wrt bug
+ 512476
04 Jun 2012; Michael Weber <xmw@gentoo.org> matchbox-desktop-0.9.1.ebuild:
ppc stable (bug 309407)
@@ -42,4 +47,3 @@
+matchbox-desktop-0.9.1.ebuild:
- Initial import. Original ebuild by Priit Laes, modifications by Björn
Ruberg and Yuri Vasilevski.
-
diff --git a/x11-wm/matchbox-desktop/files/matchbox-desktop-0.9.1-dlopen.patch b/x11-wm/matchbox-desktop/files/matchbox-desktop-0.9.1-dlopen.patch
new file mode 100644
index 000000000000..3c7c7037eedf
--- /dev/null
+++ b/x11-wm/matchbox-desktop/files/matchbox-desktop-0.9.1-dlopen.patch
@@ -0,0 +1,11 @@
+diff -uarN matchbox-desktop-0.9.1.orig/configure.ac matchbox-desktop-0.9.1/configure.ac
+--- matchbox-desktop-0.9.1.orig/configure.ac 2005-01-24 09:11:02.000000000 -0500
++++ matchbox-desktop-0.9.1/configure.ac 2014-10-29 14:08:54.882668438 -0400
+@@ -12,6 +12,7 @@
+ AC_PROG_CC
+ AC_LIBTOOL_DLOPEN
+ AC_PROG_LIBTOOL
++LT_LIB_DLLOAD
+
+ AC_HEADER_DIRENT
+ AC_HEADER_STDC
diff --git a/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
index 6c536ce8e087..28ffd86a55dd 100644
--- a/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
+++ b/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2015 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild,v 1.9 2012/06/04 00:31:01 xmw Exp $
+# $Header: /var/cvsroot/gentoo-x86/x11-wm/matchbox-desktop/matchbox-desktop-0.9.1.ebuild,v 1.10 2015/06/09 19:43:10 grknight Exp $
-inherit versionator
+inherit versionator autotools eutils
DESCRIPTION="The Matchbox Desktop"
HOMEPAGE="http://matchbox-project.org/"
@@ -19,6 +19,13 @@ DEPEND=">=x11-libs/libmatchbox-1.5
RDEPEND="${DEPEND}
x11-wm/matchbox-common"
+src_unpack() {
+ unpack ${A} || die "Failed to unpack"
+ cd "${S}" || die
+ epatch "${FILESDIR}/${P}-dlopen.patch" || die "Patch failed"
+ eautoreconf || die
+}
+
src_compile() {
econf $(use_enable debug) \
$(use_enable startup-notification) \