summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-03-08 15:06:40 +0000
committerMichał Górny <mgorny@gentoo.org>2015-03-08 15:06:40 +0000
commit1ad6493fd27d761be642f337767ae1bbc8a949d9 (patch)
tree45cc2bc6bfdef11d3c9e08b0aa6a7a0f36373049 /xfce-base/libxfce4ui
parentCleanup. (diff)
downloadgentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.tar.gz
gentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.tar.bz2
gentoo-2-1ad6493fd27d761be642f337767ae1bbc8a949d9.zip
Xfce 4.12 version bump, bug #541962. https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/63 by me and damex.
(Portage version: 2.2.17/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-base/libxfce4ui')
-rw-r--r--xfce-base/libxfce4ui/ChangeLog8
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.12.0.ebuild47
2 files changed, 54 insertions, 1 deletions
diff --git a/xfce-base/libxfce4ui/ChangeLog b/xfce-base/libxfce4ui/ChangeLog
index 4e56fce3450e..31771cf90189 100644
--- a/xfce-base/libxfce4ui/ChangeLog
+++ b/xfce-base/libxfce4ui/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/libxfce4ui
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.54 2015/03/03 13:02:16 dlan Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.55 2015/03/08 15:06:39 mgorny Exp $
+
+*libxfce4ui-4.12.0 (08 Mar 2015)
+
+ 08 Mar 2015; Michał Górny <mgorny@gentoo.org> +libxfce4ui-4.12.0.ebuild:
+ Xfce 4.12 version bump, bug #541962. https://github.com/gentoo/gentoo-portage-
+ rsync-mirror/pull/63 by me and damex.
03 Mar 2015; Yixun Lan <dlan@gentoo.org> libxfce4ui-4.11.1.ebuild:
add arm64 support, tested on A53 board
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.12.0.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.12.0.ebuild
new file mode 100644
index 000000000000..3194664ed92a
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.12.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/libxfce4ui-4.12.0.ebuild,v 1.1 2015/03/08 15:06:39 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.30
+ >=x11-libs/gtk+-2.24:2
+ >=x11-libs/gtk+-3.2:3
+ x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=xfce-base/libxfce4util-4.12
+ >=xfce-base/xfconf-4.12
+ glade? ( dev-util/glade:3 )
+ startup-notification? ( x11-libs/startup-notification )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --enable-gtk3
+ $(use_enable startup-notification)
+ $(use_enable glade gladeui)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}