summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2013-01-13 06:03:33 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2013-01-13 06:03:33 +0000
commitd2a63c18ca335194a8787382106c1e7bbe62a567 (patch)
tree56538222914f781fb0ed94d0266978422515a0e1 /xfce-base/xfce4-panel
parentAdd fix from upstream for PIC compile checks #417179 by Richard Yao. (diff)
downloadgentoo-2-d2a63c18ca335194a8787382106c1e7bbe62a567.tar.gz
gentoo-2-d2a63c18ca335194a8787382106c1e7bbe62a567.tar.bz2
gentoo-2-d2a63c18ca335194a8787382106c1e7bbe62a567.zip
Fix icons not probably resizing when requested wrt #447182 by Carlos Silva. The patch is from upstream git.
(Portage version: 2.2.0_alpha149/cvs/Linux x86_64, signed Manifest commit with key 4868F14D)
Diffstat (limited to 'xfce-base/xfce4-panel')
-rw-r--r--xfce-base/xfce4-panel/ChangeLog11
-rw-r--r--xfce-base/xfce4-panel/files/xfce4-panel-4.10.0-icons.patch35
-rw-r--r--xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild44
3 files changed, 88 insertions, 2 deletions
diff --git a/xfce-base/xfce4-panel/ChangeLog b/xfce-base/xfce4-panel/ChangeLog
index 216312dc3bb2..8fd0f27de2f3 100644
--- a/xfce-base/xfce4-panel/ChangeLog
+++ b/xfce-base/xfce4-panel/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/xfce4-panel
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.229 2012/11/28 12:27:36 ssuominen Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/ChangeLog,v 1.230 2013/01/13 06:03:33 ssuominen Exp $
+
+*xfce4-panel-4.10.0-r1 (13 Jan 2013)
+
+ 13 Jan 2013; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-panel-4.10.0-r1.ebuild, +files/xfce4-panel-4.10.0-icons.patch:
+ Fix icons not probably resizing when requested wrt #447182 by Carlos Silva.
+ The patch is from upstream git.
28 Nov 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-panel-4.10.0.ebuild:
diff --git a/xfce-base/xfce4-panel/files/xfce4-panel-4.10.0-icons.patch b/xfce-base/xfce4-panel/files/xfce4-panel-4.10.0-icons.patch
new file mode 100644
index 000000000000..0bc7d0f6b36e
--- /dev/null
+++ b/xfce-base/xfce4-panel/files/xfce4-panel-4.10.0-icons.patch
@@ -0,0 +1,35 @@
+http://bugs.gentoo.org/447182
+http://bugzilla.xfce.org/show_bug.cgi?id=9615
+
+From 48e1016394fa6bdb1d708823a23a12641482a561 Mon Sep 17 00:00:00 2001
+From: Carlos Silva <r3pek@r3pek.org>
+Date: Fri, 14 Dec 2012 01:14:36 +0000
+Subject: Fix icons not probably resizing when requested.
+
+Looks like gdk_pixbuf_new_from_file_at_scale and gdk_pixbuf_new_from_file_at_size really don't scale the image leaving the image loaded with its original size. So, just load the file without any scale and let the scale be done later on the function.
+
+Signed-off-by: Carlos Silva <r3pek@r3pek.org>
+---
+diff --git a/libxfce4panel/xfce-panel-convenience.c b/libxfce4panel/xfce-panel-convenience.c
+index 19c51bb..a3f3be1 100644
+--- a/libxfce4panel/xfce-panel-convenience.c
++++ b/libxfce4panel/xfce-panel-convenience.c
+@@ -170,15 +170,13 @@ xfce_panel_pixbuf_from_source_at_size (const gchar *source,
+
+ if (G_UNLIKELY (g_path_is_absolute (source)))
+ {
+- pixbuf = gdk_pixbuf_new_from_file_at_scale (source, dest_width, dest_height, TRUE, &error);
++ pixbuf = gdk_pixbuf_new_from_file (source, &error);
+ if (G_UNLIKELY (pixbuf == NULL))
+ {
+ g_message ("Failed to load image \"%s\": %s",
+ source, error->message);
+ g_error_free (error);
+ }
+-
+- return pixbuf;
+ }
+ else
+ {
+--
+cgit v0.9.0.3
diff --git a/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild b/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild
new file mode 100644
index 000000000000..8080de29dbb1
--- /dev/null
+++ b/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-panel/xfce4-panel-4.10.0-r1.ebuild,v 1.1 2013/01/13 06:03:33 ssuominen Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Panel for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/dbus-glib-0.100
+ >=dev-libs/glib-2.24
+ >=x11-libs/cairo-1
+ >=x11-libs/gtk+-2.20:2
+ x11-libs/libX11
+ >=x11-libs/libwnck-2.31:1
+ >=xfce-base/exo-0.8
+ >=xfce-base/garcon-0.2
+ >=xfce-base/libxfce4ui-4.10
+ >=xfce-base/libxfce4util-4.10
+ >=xfce-base/xfconf-4.10"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ PATCHES=( "${FILESDIR}"/${P}-icons.patch )
+
+ XFCONF=(
+ --docdir="${EPREFIX}"/usr/share/doc/${PF}
+ $(xfconf_use_debug)
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ DOCS=( AUTHORS ChangeLog NEWS THANKS )
+}