summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-09-29 14:52:30 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-09-29 14:52:30 +0000
commit178a4c6a0a8a20653fdded21ab11273b1ccaf850 (patch)
tree0ad1ec9129ea4f2a1a4ac83b650174a47f4c773c /xfce-base/xfce4-settings
parentVersion bump (diff)
downloadgentoo-2-178a4c6a0a8a20653fdded21ab11273b1ccaf850.tar.gz
gentoo-2-178a4c6a0a8a20653fdded21ab11273b1ccaf850.tar.bz2
gentoo-2-178a4c6a0a8a20653fdded21ab11273b1ccaf850.zip
Version bump.
(Portage version: 2.2_rc42/cvs/Linux x86_64)
Diffstat (limited to 'xfce-base/xfce4-settings')
-rw-r--r--xfce-base/xfce4-settings/ChangeLog8
-rw-r--r--xfce-base/xfce4-settings/xfce4-settings-4.6.3.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/xfce-base/xfce4-settings/ChangeLog b/xfce-base/xfce4-settings/ChangeLog
index 5efff6805049..968fd6d3d3ab 100644
--- a/xfce-base/xfce4-settings/ChangeLog
+++ b/xfce-base/xfce4-settings/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-base/xfce4-settings
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.18 2009/09/23 10:12:32 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/ChangeLog,v 1.19 2009/09/29 14:52:30 ssuominen Exp $
+
+*xfce4-settings-4.6.3 (29 Sep 2009)
+
+ 29 Sep 2009; Samuli Suominen <ssuominen@gentoo.org>
+ +xfce4-settings-4.6.3.ebuild:
+ Version bump.
*xfce4-settings-4.6.1-r2 (23 Sep 2009)
diff --git a/xfce-base/xfce4-settings/xfce4-settings-4.6.3.ebuild b/xfce-base/xfce4-settings/xfce4-settings-4.6.3.ebuild
new file mode 100644
index 000000000000..d2a43103fa50
--- /dev/null
+++ b/xfce-base/xfce4-settings/xfce4-settings-4.6.3.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/xfce4-settings/xfce4-settings-4.6.3.ebuild,v 1.1 2009/09/29 14:52:30 ssuominen Exp $
+
+EAPI=2
+inherit xfconf
+
+DESCRIPTION="Settings daemon for Xfce4"
+HOMEPAGE="http://www.xfce.org"
+SRC_URI="mirror://xfce/src/xfce/${PN}/4.6/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +keyboard libnotify sound"
+
+RDEPEND=">=dev-libs/glib-2.12:2
+ >=dev-libs/dbus-glib-0.34
+ >=gnome-base/libglade-2
+ >=x11-libs/gtk+-2.10:2
+ >=x11-libs/libX11-1
+ >=x11-libs/libXcursor-1.1
+ >=x11-libs/libXi-1
+ >=x11-libs/libXrandr-1.1
+ >=x11-libs/libwnck-2.12
+ >=x11-base/xorg-server-1.5.3
+ >=xfce-base/libxfce4util-4.6
+ >=xfce-base/libxfcegui4-4.6
+ >=xfce-base/xfconf-4.6
+ >=xfce-base/exo-0.3.100
+ libnotify? ( >=x11-libs/libnotify-0.1.3 )
+ keyboard? ( >=x11-libs/libxklavier-0.3 )
+ sound? ( media-libs/libcanberra )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ sys-devel/gettext
+ dev-util/pkgconfig
+ x11-proto/inputproto
+ x11-proto/xf86vidmodeproto"
+
+pkg_setup() {
+ XFCONF="--disable-dependency-tracking
+ $(use_enable libnotify)
+ $(use_enable keyboard libxklavier)
+ $(use_enable sound sound-settings)
+ $(use_enable debug)"
+ DOCS="AUTHORS ChangeLog NEWS TODO"
+}