summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2015-05-11 17:55:22 +0000
committerMichał Górny <mgorny@gentoo.org>2015-05-11 17:55:22 +0000
commit1701cf5a6bfab6e6f5e105a6f6ab455cda1a118f (patch)
tree5a217008c88d820c44ca966e288248381b3cb514 /xfce-base
parentx86 stable wrt bug #548350 (diff)
downloadgentoo-2-1701cf5a6bfab6e6f5e105a6f6ab455cda1a118f.tar.gz
gentoo-2-1701cf5a6bfab6e6f5e105a6f6ab455cda1a118f.tar.bz2
gentoo-2-1701cf5a6bfab6e6f5e105a6f6ab455cda1a118f.zip
Add gtk3 USE flag. Bug #547270, PR https://github.com/gentoo/gentoo-portage-rsync-mirror/pull/112. Big thanks to Karl Lindén and brakarov.
(Portage version: 2.2.18/cvs/Linux x86_64, signed Manifest commit with key EFB4464E!)
Diffstat (limited to 'xfce-base')
-rw-r--r--xfce-base/libxfce4ui/ChangeLog9
-rw-r--r--xfce-base/libxfce4ui/libxfce4ui-4.12.1-r1.ebuild47
-rw-r--r--xfce-base/libxfce4ui/metadata.xml1
3 files changed, 56 insertions, 1 deletions
diff --git a/xfce-base/libxfce4ui/ChangeLog b/xfce-base/libxfce4ui/ChangeLog
index 5cf1dd29e910..9de02955ea4c 100644
--- a/xfce-base/libxfce4ui/ChangeLog
+++ b/xfce-base/libxfce4ui/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-base/libxfce4ui
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.56 2015/03/15 18:44:14 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/ChangeLog,v 1.57 2015/05/11 17:55:22 mgorny Exp $
+
+*libxfce4ui-4.12.1-r1 (11 May 2015)
+
+ 11 May 2015; Michał Górny <mgorny@gentoo.org> +libxfce4ui-4.12.1-r1.ebuild,
+ metadata.xml:
+ Add gtk3 USE flag. Bug #547270, PR https://github.com/gentoo/gentoo-portage-
+ rsync-mirror/pull/112. Big thanks to Karl Lindén and brakarov.
*libxfce4ui-4.12.1 (15 Mar 2015)
diff --git a/xfce-base/libxfce4ui/libxfce4ui-4.12.1-r1.ebuild b/xfce-base/libxfce4ui/libxfce4ui-4.12.1-r1.ebuild
new file mode 100644
index 000000000000..793ac78beb3d
--- /dev/null
+++ b/xfce-base/libxfce4ui/libxfce4ui-4.12.1-r1.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-base/libxfce4ui/libxfce4ui-4.12.1-r1.ebuild,v 1.1 2015/05/11 17:55:22 mgorny Exp $
+
+EAPI=5
+inherit xfconf
+
+DESCRIPTION="Unified widgets and session management libraries for the Xfce desktop environment"
+HOMEPAGE="http://www.xfce.org/projects/libxfce4"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~x86-solaris"
+IUSE="debug glade +gtk3 startup-notification"
+
+RDEPEND=">=dev-libs/glib-2.30:2=
+ >=x11-libs/gtk+-2.24:2=
+ x11-libs/libX11:=
+ x11-libs/libICE:=
+ x11-libs/libSM:=
+ >=xfce-base/libxfce4util-4.12:=
+ >=xfce-base/xfconf-4.12:=
+ glade? ( dev-util/glade:3= )
+ gtk3? ( >=x11-libs/gtk+-3.2:3= )
+ startup-notification? ( x11-libs/startup-notification:= )
+ !xfce-base/xfce-utils"
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ $(use_enable startup-notification)
+ $(use_enable glade gladeui)
+ $(use_enable gtk3)
+ $(xfconf_use_debug)
+ --with-vendor-info=Gentoo
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+ )
+
+ [[ ${CHOST} == *-darwin* ]] && XFCONF+=( --disable-visibility ) #366857
+
+ DOCS=( AUTHORS ChangeLog NEWS README THANKS TODO )
+}
diff --git a/xfce-base/libxfce4ui/metadata.xml b/xfce-base/libxfce4ui/metadata.xml
index 5d833ecdc431..149c2227ae0a 100644
--- a/xfce-base/libxfce4ui/metadata.xml
+++ b/xfce-base/libxfce4ui/metadata.xml
@@ -4,5 +4,6 @@
<herd>xfce</herd>
<use>
<flag name='glade'>Build support for Glade 3's GtkBuilder implementation</flag>
+ <flag name='gtk3'>Enable gtk3 support</flag>
</use>
</pkgmetadata>