summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-11-17 15:38:03 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-11-17 15:38:03 +0000
commit8218b05c94e20a9da62fb630d660362a8c34d44c (patch)
tree3ff97573b559e13120bbb5a6a603adeba84ef86d /xfce-extra/exo
parentadd missing intltoolize call, bug #239651 (diff)
downloadgentoo-2-8218b05c94e20a9da62fb630d660362a8c34d44c.tar.gz
gentoo-2-8218b05c94e20a9da62fb630d660362a8c34d44c.tar.bz2
gentoo-2-8218b05c94e20a9da62fb630d660362a8c34d44c.zip
additional ebuild cleanup for minor mistakes. use_enable in global scope, need to touch configure.in not configure, no need to call epatch twice. Thanks to drac for the help
(Portage version: 2.2_rc14/cvs/Linux 2.6.27.6 x86_64)
Diffstat (limited to 'xfce-extra/exo')
-rw-r--r--xfce-extra/exo/ChangeLog7
-rw-r--r--xfce-extra/exo/exo-0.3.4-r1.ebuild16
2 files changed, 14 insertions, 9 deletions
diff --git a/xfce-extra/exo/ChangeLog b/xfce-extra/exo/ChangeLog
index 93476edc9f01..48b2125c3605 100644
--- a/xfce-extra/exo/ChangeLog
+++ b/xfce-extra/exo/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for xfce-extra/exo
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.66 2008/11/17 14:55:55 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.67 2008/11/17 15:38:03 darkside Exp $
+
+ 17 Nov 2008; Jeremy Olexa <darkside@gentoo.org> exo-0.3.4-r1.ebuild:
+ additional ebuild cleanup for minor mistakes. use_enable in global scope,
+ need to touch configure.in not configure, no need to call epatch twice.
+ Thanks to drac for the help
17 Nov 2008; Jeremy Olexa <darkside@gentoo.org> exo-0.3.4-r1.ebuild:
add intltoolize call to exo so it will work with intltool-0.37.1, bug #247095
diff --git a/xfce-extra/exo/exo-0.3.4-r1.ebuild b/xfce-extra/exo/exo-0.3.4-r1.ebuild
index 0e8785001eb3..62c22cafcc69 100644
--- a/xfce-extra/exo/exo-0.3.4-r1.ebuild
+++ b/xfce-extra/exo/exo-0.3.4-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.4-r1.ebuild,v 1.10 2008/11/17 14:55:55 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.4-r1.ebuild,v 1.11 2008/11/17 15:38:03 darkside Exp $
inherit eutils xfce44 python multilib autotools
@@ -29,10 +29,6 @@ DEPEND="${RDEPEND}
doc? ( dev-util/gtk-doc )
dev-util/intltool"
-XFCE_CONFIG="${XFCE_CONFIG} $(use_enable python) \
- $(use_enable libnotify notifications) \
- $(use_enable hal) --enable-mcs-plugin"
-
DOCS="AUTHORS ChangeLog HACKING NEWS README THANKS TODO"
# See bug 166568 for reference
@@ -40,11 +36,15 @@ src_unpack() {
unpack ${A}
cd "${S}"
- sed -i -e 's:-Werror::g' "${S}"/configure
- epatch "${FILESDIR}"/${P}-eject.patch
- epatch "${FILESDIR}"/${P}-remove-libmd5.patch
+ sed -i -e 's:-Werror::g' "${S}"/configure.in || die "sed failed"
+ epatch "${FILESDIR}"/${P}-eject.patch \
+ "${FILESDIR}"/${P}-remove-libmd5.patch
intltoolize --force --copy --automake || die "intltoolize failed."
AT_M4DIR=/usr/share/xfce4/dev-tools/m4macros eautoreconf
+
+ XFCE_CONFIG="${XFCE_CONFIG} $(use_enable python) \
+ $(use_enable libnotify notifications) \
+ $(use_enable hal) --enable-mcs-plugin"
}
# See bug 164780 for reference