summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <drac@gentoo.org>2007-02-26 17:54:56 +0000
committerSamuli Suominen <drac@gentoo.org>2007-02-26 17:54:56 +0000
commite2953071bd76f7b8df8e20c2539f7d6c18c6955a (patch)
treeef11cc866b0d0c00a5f6614643274f7cd847cd62 /xfce-extra/exo
parentChange to use virtual/pcmcia instead of directly depending on sys-apps/pcmcia... (diff)
downloadgentoo-2-e2953071bd76f7b8df8e20c2539f7d6c18c6955a.tar.gz
gentoo-2-e2953071bd76f7b8df8e20c2539f7d6c18c6955a.tar.bz2
gentoo-2-e2953071bd76f7b8df8e20c2539f7d6c18c6955a.zip
Fix compilation with >=pygtk-2.9 with a patch from Octavio Ruiz, thanks. Bug #148725. Also remove virtual/x11 usage.
(Portage version: 2.1.2-r11)
Diffstat (limited to 'xfce-extra/exo')
-rw-r--r--xfce-extra/exo/ChangeLog9
-rw-r--r--xfce-extra/exo/exo-0.3.0-r2.ebuild28
-rw-r--r--xfce-extra/exo/files/digest-exo-0.3.0-r23
-rw-r--r--xfce-extra/exo/files/exo-0.3.0-pygtk.patch68
4 files changed, 107 insertions, 1 deletions
diff --git a/xfce-extra/exo/ChangeLog b/xfce-extra/exo/ChangeLog
index cd7aa9912e85..922816be962d 100644
--- a/xfce-extra/exo/ChangeLog
+++ b/xfce-extra/exo/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for xfce-extra/exo
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.30 2007/02/13 20:49:04 drac Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/ChangeLog,v 1.31 2007/02/26 17:54:56 drac Exp $
+
+*exo-0.3.0-r2 (26 Feb 2007)
+
+ 26 Feb 2007; Samuli Suominen <drac@gentoo.org>
+ +files/exo-0.3.0-pygtk.patch, +exo-0.3.0-r2.ebuild:
+ Fix compilation with >=pygtk-2.9 with a patch from Octavio Ruiz, thanks.
+ Bug 148725.
13 Feb 2007; Samuli Suominen <drac@gentoo.org> exo-0.3.2.ebuild:
Stop using -Werror when USE debug is enabled for bug 166568.
diff --git a/xfce-extra/exo/exo-0.3.0-r2.ebuild b/xfce-extra/exo/exo-0.3.0-r2.ebuild
new file mode 100644
index 000000000000..c4f426bd168e
--- /dev/null
+++ b/xfce-extra/exo/exo-0.3.0-r2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/exo/exo-0.3.0-r2.ebuild,v 1.1 2007/02/26 17:54:56 drac Exp $
+
+inherit eutils xfce42
+
+DESCRIPTION="Extension library for Xfce"
+HOMEPAGE="http://www.os-cillation.com/"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ppc64 ~sparc ~x86"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libICE
+ x11-libs/libSM
+ >=x11-libs/gtk+-2.4
+ >=xfce-base/libxfce4mcs-4.2.2-r1
+ >=xfce-base/libxfcegui4-4.2"
+DEPEND="${RDEPEND}
+ x11-libs/libX11
+ x11-libs/libXt"
+
+bzipped
+goodies
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-pygtk.patch
+}
diff --git a/xfce-extra/exo/files/digest-exo-0.3.0-r2 b/xfce-extra/exo/files/digest-exo-0.3.0-r2
new file mode 100644
index 000000000000..1fbbcd1fcc49
--- /dev/null
+++ b/xfce-extra/exo/files/digest-exo-0.3.0-r2
@@ -0,0 +1,3 @@
+MD5 ffcd73ec6b34f19c81afdc3f1a97377b exo-0.3.0.tar.bz2 387737
+RMD160 328c28fa865a47fd7ce826d7ae27e3a3add61a76 exo-0.3.0.tar.bz2 387737
+SHA256 77f27ac51bb490018f553d01300950f4bc83cfe98c44114ea0a331a0606c3382 exo-0.3.0.tar.bz2 387737
diff --git a/xfce-extra/exo/files/exo-0.3.0-pygtk.patch b/xfce-extra/exo/files/exo-0.3.0-pygtk.patch
new file mode 100644
index 000000000000..b530bca84f1b
--- /dev/null
+++ b/xfce-extra/exo/files/exo-0.3.0-pygtk.patch
@@ -0,0 +1,68 @@
+diff -ur exo-0.3.0.orig/python/exo.override exo-0.3.0/python/exo.override
+--- exo-0.3.0.orig/python/exo.override 2005-03-02 08:47:40.000000000 -0600
++++ exo-0.3.0/python/exo.override 2007-01-08 09:44:17.000000000 -0600
+@@ -27,8 +27,13 @@
+ #include <pygtk/pygtk.h>
+ #include <exo/exo.h>
+
++#if !defined(pygtk_tree_path_from_pyobject)
+ extern GtkTreePath *pygtk_tree_path_from_pyobject (PyObject *object);
++#endif
++
++#if !defined(pygtk_tree_path_to_pyobject)
+ extern PyObject *pygtk_tree_path_to_pyobject (GtkTreePath *path);
++#endif
+
+ %%
+ modulename exo
+diff -ur exo-0.3.0.orig/python/exomodule.c exo-0.3.0/python/exomodule.c
+--- exo-0.3.0.orig/python/exomodule.c 2005-02-21 14:24:37.000000000 -0600
++++ exo-0.3.0/python/exomodule.c 2007-01-08 09:49:24.000000000 -0600
+@@ -34,21 +34,8 @@
+ * that are required for the IconView, so we have to duplicate
+ * them here.
+ */
+-PyObject*
+-pygtk_tree_path_to_pyobject (GtkTreePath *path)
+-{
+- gint len, i, *indices;
+- PyObject *ret;
+-
+- len = gtk_tree_path_get_depth (path);
+- indices = gtk_tree_path_get_indices (path);
+-
+- ret = PyTuple_New (len);
+- for (i = 0; i < len; i++)
+- PyTuple_SetItem (ret, i, PyInt_FromLong (indices[i]));
+- return ret;
+-}
+
++#if !defined(pygtk_tree_path_from_pyobject)
+ GtkTreePath*
+ pygtk_tree_path_from_pyobject (PyObject *object)
+ {
+@@ -96,7 +83,24 @@
+
+ return NULL;
+ }
++#endif
+
++#if !defined(pygtk_tree_path_to_pyobject)
++PyObject*
++pygtk_tree_path_to_pyobject (GtkTreePath *path)
++{
++ gint len, i, *indices;
++ PyObject *ret;
++
++ len = gtk_tree_path_get_depth (path);
++ indices = gtk_tree_path_get_indices (path);
++
++ ret = PyTuple_New (len);
++ for (i = 0; i < len; i++)
++ PyTuple_SetItem (ret, i, PyInt_FromLong (indices[i]));
++ return ret;
++}
++#endif
+
+ DL_EXPORT(void)
+ init_exo (void)