summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2010-11-05 15:35:55 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2010-11-05 15:35:55 +0000
commitfe3a39a6a08c5ff9450bad57242a5f8e23db5d05 (patch)
tree26903a95fe60ba80eb2536a32ee68d74222cea17 /xfce-extra/thunar-vcs-plugin
parentMark ~ppc64; bug #288172 (diff)
downloadgentoo-2-fe3a39a6a08c5ff9450bad57242a5f8e23db5d05.tar.gz
gentoo-2-fe3a39a6a08c5ff9450bad57242a5f8e23db5d05.tar.bz2
gentoo-2-fe3a39a6a08c5ff9450bad57242a5f8e23db5d05.zip
Snapshot from thunarx-2 branch.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/thunar-vcs-plugin')
-rw-r--r--xfce-extra/thunar-vcs-plugin/ChangeLog8
-rw-r--r--xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.2_p20101105.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/xfce-extra/thunar-vcs-plugin/ChangeLog b/xfce-extra/thunar-vcs-plugin/ChangeLog
index 73f79c2fa951..5db87e4c3c6b 100644
--- a/xfce-extra/thunar-vcs-plugin/ChangeLog
+++ b/xfce-extra/thunar-vcs-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/thunar-vcs-plugin
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vcs-plugin/ChangeLog,v 1.11 2010/08/20 00:56:38 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vcs-plugin/ChangeLog,v 1.12 2010/11/05 15:35:55 ssuominen Exp $
+
+*thunar-vcs-plugin-0.1.2_p20101105 (05 Nov 2010)
+
+ 05 Nov 2010; Samuli Suominen <ssuominen@gentoo.org>
+ +thunar-vcs-plugin-0.1.2_p20101105.ebuild:
+ Snapshot from thunarx-2 branch.
20 Aug 2010; Jeremy Olexa <darkside@gentoo.org>
thunar-vcs-plugin-0.1.2.ebuild:
diff --git a/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.2_p20101105.ebuild b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.2_p20101105.ebuild
new file mode 100644
index 000000000000..cbb9229f49a2
--- /dev/null
+++ b/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.2_p20101105.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/thunar-vcs-plugin/thunar-vcs-plugin-0.1.2_p20101105.ebuild,v 1.1 2010/11/05 15:35:55 ssuominen Exp $
+
+# git clone -b thunarx-2 git://git.xfce.org/thunar-plugins/thunar-vcs-plugin
+
+EAPI=3
+EAUTORECONF=yes
+inherit xfconf
+
+DESCRIPTION="adds Subversion and GIT actions to the context menu of thunar"
+HOMEPAGE="http://goodies.xfce.org/projects/thunar-plugins/thunar-vcs-plugin"
+SRC_URI="http://dev.gentoo.org/~ssuominen/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug git subversion"
+
+RDEPEND=">=xfce-base/thunar-1.1.0
+ >=x11-libs/gtk+-2.6:2
+ >=dev-libs/glib-2.6:2
+ git? ( dev-vcs/git )
+ subversion? ( >=dev-libs/apr-0.9.7
+ >=dev-vcs/subversion-1.5 )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/pkgconfig"
+
+pkg_setup() {
+ XFCONF=(
+ --disable-dependency-tracking
+ $(use_enable subversion)
+ $(use_enable git)
+ $(xfconf_use_debug)
+ )
+
+ DOCS="AUTHORS ChangeLog NEWS README"
+}