summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-10-31 20:12:50 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-10-31 20:12:50 +0000
commit19085dc25e384c14cbbf89314ee905d618dd9676 (patch)
tree9b9e775dd2024f147be73037bfdc2029df11aab5 /xfce-extra/xfce4-cellmodem-plugin
parentBeta channel bump. (diff)
downloadgentoo-2-19085dc25e384c14cbbf89314ee905d618dd9676.tar.gz
gentoo-2-19085dc25e384c14cbbf89314ee905d618dd9676.tar.bz2
gentoo-2-19085dc25e384c14cbbf89314ee905d618dd9676.zip
Remove sys-libs/zlib requirement because we are using shared libpci instead of static libpci so inheriting the libraries (NEEDED entries) work.
(Portage version: 2.2.0_alpha135/cvs/Linux x86_64)
Diffstat (limited to 'xfce-extra/xfce4-cellmodem-plugin')
-rw-r--r--xfce-extra/xfce4-cellmodem-plugin/ChangeLog8
-rw-r--r--xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-build.patch57
-rw-r--r--xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild5
3 files changed, 67 insertions, 3 deletions
diff --git a/xfce-extra/xfce4-cellmodem-plugin/ChangeLog b/xfce-extra/xfce4-cellmodem-plugin/ChangeLog
index 72a93ba7fdc1..5f9c649fedfc 100644
--- a/xfce-extra/xfce4-cellmodem-plugin/ChangeLog
+++ b/xfce-extra/xfce4-cellmodem-plugin/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for xfce-extra/xfce4-cellmodem-plugin
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cellmodem-plugin/ChangeLog,v 1.5 2012/05/22 10:54:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cellmodem-plugin/ChangeLog,v 1.6 2012/10/31 20:12:50 ssuominen Exp $
+
+ 31 Oct 2012; Samuli Suominen <ssuominen@gentoo.org>
+ xfce4-cellmodem-plugin-0.0.5.ebuild,
+ +files/xfce4-cellmodem-plugin-0.0.5-build.patch:
+ Remove sys-libs/zlib requirement because we are using shared libpci instead
+ of static libpci so inheriting the libraries (NEEDED entries) work.
22 May 2012; Samuli Suominen <ssuominen@gentoo.org>
xfce4-cellmodem-plugin-0.0.5.ebuild:
diff --git a/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-build.patch b/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-build.patch
new file mode 100644
index 000000000000..de6b59aa9931
--- /dev/null
+++ b/xfce-extra/xfce4-cellmodem-plugin/files/xfce4-cellmodem-plugin-0.0.5-build.patch
@@ -0,0 +1,57 @@
+--- configure.ac
++++ configure.ac
+@@ -14,6 +14,7 @@
+ AC_PROG_INTLTOOL
+ AC_GNU_SOURCE
+ AC_HEADER_STDC
++AC_PROG_MKDIR_P
+
+ AC_CHECK_FUNCS([vasprintf])
+
+@@ -33,14 +34,6 @@
+ echo "> Not using debug"
+ fi
+
+-# PCI library needs libz.
+-
+-AC_CHECK_HEADER([zlib.h],
+-AC_CHECK_LIB(z,inflate,
+-LIBS="$LIBS -lz"
+-)
+-)
+-
+ AC_CHECK_HEADER([pci/pci.h],
+ AC_CHECK_LIB(pci,pci_alloc,
+ AC_DEFINE(HAVE_PCIUTILS,[1],[Use pci utils to discover devices])
+--- po/Makefile.in.in
++++ po/Makefile.in.in
+@@ -37,9 +37,9 @@
+ itlocaledir = $(prefix)/$(DATADIRNAME)/locale
+ subdir = po
+ install_sh = @install_sh@
+-# Automake >= 1.8 provides @mkdir_p@.
++# Automake >= 1.8 provides @MKDIR_P@.
+ # Until it can be supposed, use the safe fallback:
+-mkdir_p = $(install_sh) -d
++MKDIR_P = $(install_sh) -d
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+@@ -98,7 +98,7 @@
+ install-data: install-data-@USE_NLS@
+ install-data-no: all
+ install-data-yes: all
+- $(mkdir_p) $(DESTDIR)$(itlocaledir)
++ $(MKDIR_P) $(DESTDIR)$(itlocaledir)
+ if test -n "$(PO_LINGUAS)"; then \
+ linguas="$(PO_LINGUAS)"; \
+ else \
+@@ -106,7 +106,7 @@
+ fi; \
+ for lang in $$linguas; do \
+ dir=$(DESTDIR)$(itlocaledir)/$$lang/LC_MESSAGES; \
+- $(mkdir_p) $$dir; \
++ $(MKDIR_P) $$dir; \
+ if test -r $$lang.gmo; then \
+ $(INSTALL_DATA) $$lang.gmo $$dir/$(GETTEXT_PACKAGE).mo; \
+ echo "installing $$lang.gmo as $$dir/$(GETTEXT_PACKAGE).mo"; \
diff --git a/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild b/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild
index 21584faaf524..26765ebb0394 100644
--- a/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild
+++ b/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild,v 1.7 2012/05/22 10:54:08 ssuominen Exp $
+# $Header: /var/cvsroot/gentoo-x86/xfce-extra/xfce4-cellmodem-plugin/xfce4-cellmodem-plugin-0.0.5.ebuild,v 1.8 2012/10/31 20:12:50 ssuominen Exp $
EAPI=4
EAUTORECONF=yes
@@ -15,7 +15,7 @@ SLOT="0"
KEYWORDS="amd64 x86"
IUSE="debug"
-RDEPEND="sys-apps/pciutils[zlib]
+RDEPEND="sys-apps/pciutils
virtual/libusb:0
>=xfce-base/libxfcegui4-4.8
>=xfce-base/xfce4-panel-4.8"
@@ -27,6 +27,7 @@ pkg_setup() {
PATCHES=(
"${FILESDIR}"/${P}-asneeded.patch
"${FILESDIR}"/${P}-link_for_xfce_warn.patch
+ "${FILESDIR}"/${P}-build.patch
)
XFCONF=(